WordPress.org

Ready to get started?Download WordPress

Forums

JW Player for Flash & HTML5 Video
[resolved] Youtube: JWPlayer now plays lo-fi versions plz help (9 posts)

  1. dasfgh
    Member
    Posted 4 months ago #

    Since recently, it seems to me that JWPlayer is playing the lo-fi version of Youtube on my site. I think that now it plays 240p by default for most of the videos (or maybe even worse resolution like 144p, I can't figure out precisely).

    What I know for sure is that previously the picture and the sound were much better (I think that previously it was playing the 360p versions, which I preffer).

    In one of the videos that I tested, I noticed that Jwplayer switches from lower to higher quality somewhere in the middle of a song. The change is very noticeable.

    I tried different browsers, I cleaned the cache, it doesn't help. I downloaded the latest updates for Jwplayer (its now version 2.1.2), but it didn't help. I changed it's settings from Flash to HTML5, but it shows the Youtube player embeded within JWPlayer, I don't like how that looks. Also, in HTML5 the thumbnail is not shown.

    How can I solve this, please? How can I return everything as it was before? I don't remember making any changes to cause this. I'm very affraid that this might be due to some changes within Youtube. I hope it's not. Thank you!

    https://wordpress.org/plugins/jw-player-plugin-for-wordpress/

  2. JW Player
    Member
    Plugin Author

    Posted 4 months ago #

    Where is this running? In JW6 the quality menu shows up and you should get high quality options if the original file on YouTube has it.

  3. dasfgh
    Member
    Posted 4 months ago #

    This is my site.

    Note the music video on the right. It was working fine until recently. All the videos on the site worked properly. But if I play it now, it will load a low fi version.

    Play the video, turn on full screen and you'll notice the lo-fi picture. The sound will also be lo-fi.

    Once you hit "play", take a close look at the buffer bar. The lo-fi video will start to play, but after a while you'll notice that the HQ version will start to load. I don't know why is this happening.

    So if you skip forward, it'll start to play the HQ version. It like:
    - the player cannot access the HQ file and it starts to play the LQ file
    - Then after few seconds it connects to the HQ and it switches to HQ in the midst of the song.

    My JW Player version: 5.9.2156 (as shown when you right click the video)

    JW Player plugin version: 2.1.2 (as shown in the plugins list of my WordPress)

    I don't see any "quality menu". I suppose I must upgrade to JW6 to have that. I don't want to upgrade because I'm afraid I will loose some options that I have now in my current version. That's what I read in Migrating from JW5 to JW6. And why to upgrade, everything was perfect

  4. dasfgh
    Member
    Posted 4 months ago #

    Update to my previous post (it may be helpful): I noticed that the switch from LQ to HQ occurs after around 18 sec. since the start of the video.

  5. JW Player
    Member
    Plugin Author

    Posted 4 months ago #

    The video on the right says:

    The requested video is not allowed to be played in embedded players.

    Since you are using JW5, you can should enable the HD plugin in the admin of the WP plugin.

    However, if you use JW6, Youtube videos will have a quality selection menu by default - http://www.longtailvideo.com/support/jw-player/29236/basic-youtube-stream

  6. dasfgh
    Member
    Posted 4 months ago #

    Thanks, I know how to enable the HD button, but i dont need it. 360p is fine and it worked well until recently.

    The requested video is not allowed to be played in embedded players.

    Strange, it plays on my pc. Maybe its the Youtube rules, cause we're in different countries.

    I embeded my own non-copyrighted youtube video in this post on my site. It must play in an embeded player.

    Please play it in full screen. It will be lo-fi until around 17 sec. when the HQ will start. The change will be quite visible / audible.

    I tested other videos, the same happens with them!

    I need to get rid of this "switching". I dont understand why the HQ is loaded with delay. This is definetly not normal.

    Maybe its about the communication between JW Player and Youtube, I don't know.

  7. JW Player
    Member
    Plugin Author

    Posted 4 months ago #

    I am using a PC. I am located in NYC.

    Or just use JW6...

  8. dasfgh
    Member
    Posted 4 months ago #

    It seems that I solved the problem by enabling the HD button, thank you for suggesting that.

    If a HD file is not available, it plays the HQ version (looks to me like it's 360p mp4), which is ok.

    I dont understand how come everything was working fine without that HD button for months before these problems started, but anyway.

    I also tested JW6. While it looks faster and better, it did not help me.

    After upgrading, I watched few videos and it seemed that the problem is gone, but it happened again.

    I guess something is wrong in the communication between JW and Youtube and it should be solved.

    Thats why I reverted back to JW5. All it's settings were kept.

    Offtopic: JW6 messed with my subtitled videos, cause they use the JW5 captions plugin (for those who may consider upgrading)

  9. JW Player
    Member
    Plugin Author

    Posted 4 months ago #

    Well, glad adding the HD button solved it.

Reply

You must log in to post.

About this Plugin

About this Topic