WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] YouTube Embed Not Clickable with Float:Left (6 posts)

  1. michaeldallas2217
    Member
    Posted 5 months ago #

    All of a sudden, all the embedded YouTube videos in my posts became "unclickable." They worked and then they all didn't work. Here is the code:

    HTML:
    <div class="videowrap">
    [embed width="123" height="456"]http://www.youtube.com/watch?v=rWGocKUqF7s[/embed]
    </div>

    CSS:
    .videowrap {
    float:left;
    margin: 0 20px 5px 0;
    width:200px;
    height:150px;
    position:relative;
    }

    It makes no difference if the "float:left" is in the CSS or in the Div tag. The video is not clickable with "float:left".

    I need a genius.

  2. michaeldallas2217
    Member
    Posted 5 months ago #

  3. michaeldallas2217
    Member
    Posted 5 months ago #

  4. michaeldallas2217
    Member
    Posted 5 months ago #

    I found a solution, though I am not sure why this is a problem. If, in the post, there is a blank line between the embedded video code, the problem occurs. If you delete the line, the embedded video works fine.

    If anyone knows why this suddenly became a problem, I would like to know.

  5. michaeldallas2217
    Member
    Posted 5 months ago #

    ... a blank line between the video code and the text of the post ...

  6. michaeldallas2217
    Member
    Posted 5 months ago #

    With the blank line, WordPress puts the video and text in separate <p> containers. Without a blank line, WordPress puts the video and text in the same <p> container. While I am not sure why this interferes, the new version of WordPress must have just begun parsing this way.

Reply

You must log in to post.

About this Topic