WordPress.org

Ready to get started?Download WordPress

Forums

[closed] Your theme has bundled outdated copies of WooCommerce template files (18 posts)

  1. metalmick
    Member
    Posted 5 months ago #

    I've just loaded up the Hide My Site plug in and got this message:
    Your theme has bundled outdated copies of WooCommerce template files – if you encounter functionality issues on the frontend this could the reason. Ensure you update or remove them (in general we recommend only bundling the template files you actually need to customize). See the system report for full details.
    I am new to this and cannot find anywhere that explains how to update, remove or bundle these files. I can see them in the system status... what do i do with them and how?
    Thanks.

  2. nicolecurioni
    Member
    Posted 5 months ago #

    I've found the solution:

    Copy over the templates from the WooCommerce templates directory into the woocommerce directory in your theme. You only have to copy over the outdated templates you don’t have to copy over the entire folder.

    Thanks to: http://speakinginbytes.com/2014/02/woocommerce-2-1-outdated-templates/

  3. metalmick
    Member
    Posted 5 months ago #

    Where is the WooCommerce templates directory?

  4. metalmick
    Member
    Posted 5 months ago #

    More confused than ever! I know I'm a beginner but I'm not impressed with the apparent simplicity of WordPress!! :( Deep breath!

    A sample from the Woocommerce system status page on my theme dashboard:

    Templates
    Template Overrides (WooCommerce): archive-product.php,
    cart-empty.php,
    cart.php version 1.6.4 is out of date. The core version is 2.1.0,
    cross-sells.php,
    mini-cart.php version 1.6.4 is out of date. The core version is 2.1.0,
    shipping-calculator.php,
    cart-errors.php,
    form-billing.php version 2.0.0 is out of date. The core version is 2.1.2,
    form-checkout.php,
    form-coupon.php,
    form-login.php,
    form-pay.php,
    form-shipping.php version 1.6.4 is out of date. The core version is 2.1.2,
    review-order.php version 1.6.4 is out of date. The core version is 2.1.0,

    Ok... so it tells me that these files are OUT OF DATE, it also tells me to remove them. How? Anyone?

  5. nicolecurioni
    Member
    Posted 5 months ago #

    Just go to trought your FTP to your wp-content then plugins and woocomerce. Over there you will find more folders with the respective files. You need to copy the files indicated in your system status from that folder to the woocomerce folder in your theme directory (wp-content /themes/yourthemename/woocomerve) or something like that just explore your directory with ftp. Hope this will help you out ;)

  6. Riding Sophia
    Member
    Posted 4 months ago #

    I assume the reason why a theme publishers would include the templates is that they have made changes to them. The integration may not work if you just overwrite the templates. You should take a look at them first using the Plugin editor to see if you can find what the theme author might have added. It may be obvious.

    WordPress is NOT simple--nothing that has any real flexibility could be.

  7. metalmick
    Member
    Posted 4 months ago #

    All done! Woo Hoo! Many thanks to nicolecurioni and Riding Sophia for your help! :)

  8. nicolecurioni
    Member
    Posted 4 months ago #

    I'm glad! :) You're welcome!

  9. divyam2011rock
    Member
    Posted 4 months ago #

  10. Armaglove
    Member
    Posted 4 months ago #

    Dont ever use themeforest "the leader". Its been a mess. Someone please SPELL our how to fix this error....step by step

    "Just go to trought your FTP to your wp-content then plugins and woocomerce. Over there you will find more folders with the respective files. You need to copy the files indicated in your system status from that folder to the woocomerce folder in your theme directory (wp-content /themes/yourthemename/woocomerve) or something like that just explore your directory with ftp."

    Please explain this......

  11. nicolecurioni
    Member
    Posted 4 months ago #

    You need to find the files that your Woocomerce status indicates you as "outdated copies" using your FTP file manager, going in to your domain's main folder in wp-content/plugins/woocommerce

    Ones you're there, you need to copy, as I said before, the files that your system status indicates you as outdated, and past them in to /wp-content/yourtheme/woocommerce folder, exactly in the same place as they were in the woocommerce original folder (you need to overwrite them).

    But, as Riding Sophia said

    The integration may not work if you just overwrite the templates. You should take a look at them first using the Plugin editor to see if you can find what the theme author might have added. It may be obvious.

    Hope this might be more clear :)

    PS. Sorry my english isn't perfect!

  12. vcarlton
    Member
    Posted 4 months ago #

    Thanks nicolecurioni, I had the same issue as metalmick and your explanation helped me to fix it! Cheer!

  13. SPVG
    Member
    Posted 2 months ago #

    @ nicolecurioni. I have the same problem with one of my files (group.php) which is currently on 2.1.0 and needs to be updated to 2.1.7. I just can not work out how to update these file. Can you help please?

  14. storkontheroof
    Member
    Posted 1 month ago #

    Euhm, i would not just copy the files from the WooCommerce plugins folder to the woocommerce templates folder in your theme. They're there for a reason (you probably made some modifications to the html or something...).
    In my opinion best to diff the folders and manually make the changes.

    Good luck!

  15. subfight
    Member
    Posted 4 weeks ago #

    Thanks nicole :)

  16. nicolecurioni
    Member
    Posted 4 weeks ago #

    It worked for me, because I didn't make any customization, but as @storkontheroof said it might have some changes..

    You are welcome @subfight

    And @SPVG not sure if we are talking about the same. Did you solved it?

  17. chris@designwave.co.za
    Member
    Posted 3 weeks ago #

    Thank you guys this worked! Just be careful, trying to fix this stupidly small issue and an email notication problem almost had me redoing a 6-month long website lol :P

    But it's actually very easy!

  18. photocurio
    Member
    Posted 3 weeks ago #

    Its poor coding practice to include files from a popular plugin in a theme. Especially an e-commerce plugin that has frequent and important updates.

    You should choose another theme, and install the woocommerce plugin separately.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.