WordPress.org

Ready to get started?Download WordPress

Forums

SSL Insecure Content Fixer
[resolved] Your server may be behind a load balancer or reverse proxy (14 posts)

  1. jeeyer
    Member
    Posted 7 months ago #

    Hi Ross,

    I'm using your plugin because my website can't be reached on HTTPS/SSL anymore. I've contacted my developer and he and I have no clue how this could have happened.

    Everything was working normally yesterday but we think that after a maintenance update from my host/provider things went wrong...

    Im using WordPress with Woocommerce and when I go to my website: http://thehuntingensemble.nl it shows the page normal in HTTP but when you click on some link/image or what so ever it gives a 404-error.

    I've did the test is_ssl() and when I click on it I get a 404-error but when I remove https:// from the url I get the following result: (see here: https://www.thehuntingensemble.nl/wp-content/plugins/ssl-insecure-content-fixer/is_ssl-test.php)

    Result:
    SSL Insecure Content Fixer - is_ssl() test

    This page checks to see whether WordPress can even test for SSL. If it can't, something else needs fixing.

    is_ssl() says: no, SSL not detected

    Your server may be behind a load balancer or reverse proxy.

    Please ask your web hosting provider why your website can't detect SSL, and show them this article:

    WordPress is_ssl() doesn’t work behind some load balancers.

    My developer suggested that it's a problem at the server from the host (due to maintenance). Because nothing has changed on the wordpress installation. Wierd thing is that on the site of the Host (http://www.antagonist.nl ) that maintenance was done on 24 dec 11.19am and I can remember that I could acces my site normally yesterday evening around 17pm.

    Could this be the problem? I've contacted them but they are closed for Christmas...

    Im using GeoTrust for my SSL connection.

    Do you have any idea how I can get more info about this problem? Any suggestions?

    Best and take care.
    Joost

    http://wordpress.org/plugins/ssl-insecure-content-fixer/

  2. webaware
    Member
    Plugin Author

    Posted 7 months ago #

    G'day Joost,

    If you get a 404 on the https link to the test page, that means that your hosting account is no longer configured to load https pages from the same place as http pages. Most hosting accounts allow you to either keep http and https pages in the same place, or keep them separate; this is a configuration option. Sounds like the "upgrade" has turned off an option!

    Send your host an email asking about this, then go into your hosting control panel and see if you can find that option while you wait for service on the xmas holiday... :)

    cheers and Merry Christmas,
    Ross

  3. jeeyer
    Member
    Posted 7 months ago #

    Wow, Ross thanks for your quick reply! Really means alot to get a response during the Chrismas days! Im totally stressed out by this (haha sorry) I really don't have clue why this happened.

    I sent my Hosting company an email today, but I think I can expect a response on friday or something.

    I've logged in to my DirectAdmin and I went to SSL Certificates and I see this statement: "SSL is currently enabled for this domain. You can disable it here. "

    Does that say that It isn't related to the hosting configuration? Or doesn't that say much?

    Thanks again for your help with this!

    Take care and Merry Christmas to you to!

  4. webaware
    Member
    Plugin Author

    Posted 7 months ago #

    G'day Joost,

    That means that SSL is enabled, which is great, but: where is it serving the files for SSL from? Often with hosting (e.g. on Plesk) you can configure it to serve http from /httpdocs and https from /httpsdocs, but you have an option to serve https from the same place as http. Check for an option for that.

    If you can't find such an option, or a setting for where your https is served from, then you're stuck with waiting for your host to respond.

    cheers,
    Ross

  5. jeeyer
    Member
    Posted 7 months ago #

    Hi Ross,

    Thanks again.
    The Control Panel is running on: DirectAdmin Web Control Panel © 2007 JBMC Software

    Only thing that I can find that has something to with SSL is this screen: http://static.tumblr.com/uhhbfij/7vVmydwho/sslscreen.jpg

    Nothing to configure it to serve http from /httpdocs and https from /httpsdocs...

    I fear tha that im dependent from my Host...What do you think?

    Best
    Joost

  6. webaware
    Member
    Plugin Author

    Posted 7 months ago #

    G'day Joost,

    Sorry, but it sounds like you're going to have to wait for your host to get back to you; they've done something with the hosting config that you can't configure from the control panel :(

    cheers and good luck,
    Ross

  7. webaware
    Member
    Plugin Author

    Posted 7 months ago #

    G'day Joost,

    With DirectAdmin, you need to have a symbolic link from /private_html to /public_html for SSL files to be served from the same place as http. See this forum topic, and get your developer involved again.

    http://forum.directadmin.com/showthread.php?t=38843

    cheers,
    Ross

  8. jeeyer
    Member
    Posted 7 months ago #

    Hi Ross,

    Thanks for sorting this out for me!

    I found the option in DirectAdmin, I really want to set it on "Use a symbolic link from private_html to public_html - allows for same data in http and https" haha, but not sure what will happen. Can it do any harm?

    Maybe it's better to wait for tomorrow when I can reach my developer.

    Thanks again for this.
    Best
    Joost

  9. webaware
    Member
    Plugin Author

    Posted 7 months ago #

    Do it now, it's the answer! :)

    cheers,
    Ross

  10. jeeyer
    Member
    Posted 7 months ago #

    Ross, I did it... and guess what?! It worked! Haha! Thank you so for your amazing help with this and your quick response even during Christmas! Really great that you helped me out!!

    If I donate something through the plugin it will come at the right place, right? (meaning you).

    Thanks again.
    Best

    Joost

  11. webaware
    Member
    Plugin Author

    Posted 7 months ago #

    No worries, I was at the keyboard anyway (no rest for the wicked!)

    Yes, donation will come to me, and thanks in advance!

    Merry Christmas,
    Ross

  12. jeeyer
    Member
    Posted 7 months ago #

    Thanks again Ross! I have donated you a few beers!

    This topic is resolved within an hour on the first day of Christmas, im sure no one can beat that... ;)

    Take care,
    Joost

  13. jeeyer
    Member
    Posted 7 months ago #

    Resolved!

  14. webaware
    Member
    Plugin Author

    Posted 7 months ago #

    Cheers and thanks!

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.