WordPress.org

Ready to get started?Download WordPress

Forums

"Your Drafts" problem (7 posts)

  1. reevo
    Member
    Posted 8 years ago #

    Hi all,

    Happy new year and congratulations on getting v2 up and out there.

    On the whole I'm really pleased with it. Seems to do things just perfectlyexcept...

    On the "Write Page" it has a list of my drafts, bot not the complete list! It shows the first 20ish and then a link that says "and 37 more ยป"

    Please tell me there's a way to turn that later link off and show all drafts all of the time. That seems like a odd function to include to me. Any ideas?

    Cheers for looking in,

    Reevo

  2. Mark (podz)
    Support Maven
    Posted 8 years ago #

    It's there because some people have lots and lots and lots of drafts. That means when their Write page loads they have to scroll down for ages to actually get to type. That's why it is there.

    Unfortunately I don't know how to remove it.

  3. reevo
    Member
    Posted 8 years ago #

    Cheers for the speedy reply Podz.

    The fact that some people have loads of drafts would be a good reason for them to all be on show wouldn't it? At least give the option for them to be so.

    It seems strange to think that with all the extra greatness that comes with VV2 I'll have to click on this link each and every time I need to write a post!

    Very strange, I hope someone has a work around for this...anyone?

    Please don't see this as being ungrateful, I'm not. I think WP is amazing, I'm just a little stunned at this particular functionality choice.

    Cheers

  4. MichaelH
    Member
    Posted 8 years ago #

    Maybe this Plugin has something to interest you. Might want to check with the author about 2.0 compatibility:

    http://wordpress.org/support/topic/42022

  5. reevo
    Member
    Posted 8 years ago #

    Cheers MichaelH. Not really a workaround though. I don't really need another page to have to navigate, just all the drafts showing on the write page.

    Anyone have any ideas?

  6. reevo
    Member
    Posted 8 years ago #

    Managed to fix the problem but had to alter the core files to do it unfortunately.

    There's some code in the admin's index file that sorts out what happens if the number of drafts is less then 15 so I changed them all to 150...sorted. There were 3 instances of the "15".

    Thought I would share in case anyone else didn't like the way that WP deals with drafts by default.

    Reevo

  7. Mark (podz)
    Support Maven
    Posted 8 years ago #

    Thanks for posting back the solution :)

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags