WordPress.org

Ready to get started?Download WordPress

Forums

Your backup folder MIGHT be visible to the public (10 posts)

  1. bobsword
    Member
    Posted 4 years ago #

    It seems many are getting this same error message when installing plugins:

    Your backup folder MIGHT be visible to the public
    To correct this issue, move the .htaccess file from wp-content/plugins/wp-dbmanager to /home/hostblog/public_html/wp-content/backup-db

    I did this and it is still showing as an error.

    Any ideas on a fix?

  2. MichaelH
    Member
    Posted 4 years ago #

    That's related to a specific plugin right? http://wordpress.org/extend/plugins/wp-dbmanager/

    And you copied that file as directed, and you are still getting what error?

  3. loveamericaback
    Member
    Posted 3 years ago #

    Your backup folder MIGHT be visible to the public

    To correct this issue, move the .htaccess file from wp-content/plugins/wp-dbmanager to /mnt/w0108/d40/s38/b026d262/www/fraction/wp-content/backup-db
    I have this message and have no clue how to find the place where it is saying to fix this problem. I hope you can help me. I am new to Word Press. Where do I go to find the .htaacess file?

  4. Rev. Voodoo
    Volunteer Moderator
    Posted 3 years ago #

    It shows you in that path you posted.

    You need to use a file manager if your host offers one, or ftp software if not to access your files on your host/server

    follow the paths in the error, go to these folders
    wp-content -> plugins -> wp-dbmanager and copy the .htaccess file in there

    then go to

    wp-content -> backup-db and paste the .htaccess file

  5. loveamericaback
    Member
    Posted 3 years ago #

    Could not get it to work??? I did it twice.

  6. ucarmetin
    Member
    Posted 3 years ago #

    The same here. I've copied the file to the stated folder but the error message remains there. I've repeated and checked everything several times but nothing changes.
    Has anyone got a cure for this problem?

  7. ucarmetin
    Member
    Posted 3 years ago #

    Just found the solution and it's unbelievably simple =)
    As you know .htaccess files do not have .txt file extension. The htaccess file that is supposed to be moved have .txt extension. What you need to do is to copy the content of htaccess.txt file and paste it into an empty document. After that save this file as .htaccess without any file extension, such as .txt . You can easily do that in Notepad++.

    Now all you have to do is to follow instructions and upload this new .htaccess file into the folder that is specified by the plugin error message.

    Good luck!

  8. eltioska
    Member
    Posted 3 years ago #

    I did exactly as ucarmetin above states.

    However I have a WP3.02 installation with MultiSite activated*

    On the main site's dashboard/admin area it's fine.

    But on the subdomains' dashboard I'm still getting the message, even though I did copy the htaccess.txt to the other folder and renamed it to .htaccess

    I also left a copy of the file in the plugin's folder and renamed it .htaccess, but to no avail. Any ideas?

    ---
    *I'm using WP 3.02 (updated a few minutes ago) with MultiSite activated using subdomains, and domain mapping.

  9. nicholaszen
    Member
    Posted 3 years ago #

    Hi,

    I had the same problem and found the following site via Google. Hope this also can be a help to you guys.

    http://wordpress.stackexchange.com/questions/1027/removing-the-your-backup-folder-might-be-visible-to-the-public-message-generate

  10. eltioska
    Member
    Posted 3 years ago #

    Hullo,

    Once I'd followed the steps outlined above (@nicholaszen's recommendation) the main site was fine. However on the other sites I still got the error message (I'm using WP 3.0.3 with MultiSite activated).

    I had assumed that since I'm using one database for different sites, setting up the options from the dashboard of the main site was enough. Not so. I went through the menu (in WP dashboard) in each of the sites and set the options for WP-DB manager and now it's fine.

    cheers

Topic Closed

This topic has been closed to new replies.

About this Topic