WordPress.org

Ready to get started?Download WordPress

Forums

Your attempt to edit this post: "abc" has failed !!! (21 posts)

  1. hispur
    Member
    Posted 5 years ago #

    Your attempt to edit this post: "abc" has failed.

    Please try again.

    when I post a new article (I have clicked the "published"),it shows that, and the article goes to Drafts ,it can't be published.

    what's the matter? How can id do it?

    thanks a lot !!!

  2. @mercime
    Volunteer Moderator
    Posted 5 years ago #

    It all depends on the permissions the Site Admin gives you as a user.
    On the other hand, if you're site admin, then you've got a problem. What version are you using? Did you just upgrade or did you just add a plugin or delete one?

  3. hispur
    Member
    Posted 5 years ago #

    WP Super Cache has been deactived,All in One SEO Pack is activing now only.

    I upgrade the blog to wordpress 2.6.2 ,Permalinks is Custom Structure :/%category%/%postname%.html

    thanks.

  4. lifestyler
    Member
    Posted 5 years ago #

    Also having this problem on my WP 2.7 install.

    I disabled all plugins but the problem still exists. As suggested in earlier posts on this forum disabling autosave works and lets me publish again. But it shows me a javascript error in IE7. I didnt notice any js errors in Firefox though, but the gross of my editors use IE7 so i want that working flawlessly. I also didnt notice ANY errors posting with FF at all. With or without having autosave enabled.

    So i'm kinda hopeless right now, been trying stuff for hours now but no luck. If anyone ahs suggestions, let me know, i'm able to test and try all kind of things on my blog.

  5. lifestyler
    Member
    Posted 5 years ago #

    ok, this seems to happen when publishing a new post, and also when trying to save it as draft. This both aint working. Below the editor it shows it saved a draft, and it did, but i cant do it myself....

  6. lifestyler
    Member
    Posted 5 years ago #

    come on guys, a lot of people have this problem according to a search in the forums, no one a good definitive solution for this?

  7. lifestyler
    Member
    Posted 5 years ago #

    Ok i just found out some more details by simply testing

    - the "quickpost" on the wordpress dashboard works and actually posts like normal in IE7
    - Adding a new post in IE7 fails when directly publishing
    - Editing a concept post which was saved before works fine in both IE7 and FF
    - Adding a new post in FF works just fine when directly publishing

    I also noticed the following: When writing a new post in IE7 i see at the bottom of the editor that its saving the post as a concept (and it shows me a date/time when its done, after 1 or 2 seconds)
    When i do exactly the same thing in FF it tries saving it as a concept but no matter how long i wait, it doesnt complete the saving.

    any ideas?

  8. lifestyler
    Member
    Posted 5 years ago #

    Ok, because disabling the autosave caused problems for me i tried some more and notice i had to deactivate the 'post' script also to avoid getting a javascript error while going from title field to editor.(i have no idea what this script does, but i didnt notice anything wrong after deactivating it...) And cause i didnt like the wordcount anyway i disabled that to:P

    I Got everything working right now by activating this plugin:

    <?php
    /*
    Plugin Name: Your attempt Fix
    Version: 1.0
    Plugin URI: http://www.wordpress.org
    Description: Fixes the very anoying "Your attempt to edit this post" bug in WP7 admin
    Author: Bas
    Author URI:
    */
    function wp_27_adminpost_fix() {
    	wp_deregister_script('autosave');
    	wp_deregister_script('post');
    	wp_deregister_script('word-count');
    }
    add_action( 'wp_print_scripts', 'wp_27_adminpost_fix' );
    ?>
  9. dzynone
    Member
    Posted 5 years ago #

    How to I implement this?? Thanks.

  10. Amberida
    Member
    Posted 5 years ago #

    I'd like this plugin too... does anyone know where I might be able to find this?

  11. Ranjith
    Member
    Posted 5 years ago #

  12. laqrhead
    Member
    Posted 5 years ago #

    I'm using WordPress 2.8.2 and this morning this problem started occurring. I was adding some plugins to get the WordPress iPhone app to work, but when this started occurring I disabled them. I disabled the RPC publishing altogether and still the problem persists now.

    The plugin mentioned above does indeed suppress the error, however it doesn't really solve the problem. Autosave is a great feature that many of my posters have come to rely on.

    A true fix would be a solution that keeps the autosave and supresses the error message.

  13. laqrhead
    Member
    Posted 5 years ago #

    This problem is a real ghost in the machine. I have a site I use for development and it is exactly the same as the live site. Both sites have identical files and data. Both are on the same server. The only difference is the URL. I was able to get the same problem, however, I deactivated all of my plugins and the problem disappeared. I re-activated the plugins one by one trying to find out which one was causing the problem, and the problem did not reoccur. I tried deactivating and reactivating all of the plugins on the live site and the problem persisted.

    Any suggestions??

  14. Joost de Valk
    Member
    Posted 5 years ago #

    Thanks for the fix lifestyler, I'll try if i can find the bug in core and fix it, but this solves my problem for now!

  15. schikowski
    Member
    Posted 5 years ago #

    I've done this to disable autosave and it solved the problem for me:
    uncomment the line
    wp_enqueue_script('autosave');
    in post-new.php

  16. S.K
    Member
    Posted 5 years ago #

    Did you mean "comment out"?

    S.K

  17. schikowski
    Member
    Posted 5 years ago #

    This is what I meant:
    //wp_enqueue_script('autosave');

  18. S.K
    Member
    Posted 5 years ago #

    Autosave is a real pain. When the script is in action both the "save draft" and "publish" buttons get grayed and it is out your control.

    And I doubt the word count feature is useful to anyone.

    Hence both the calls to scripts (wp_enqueue_script('word-count'); and wp_enqueue_script('autosave');) can be "commented out" from post.php as well as post-new.php in wp-admin folder. But it has to be done on each upgrade.

    Alternately, lifestyler's plugin can be used with one rider:- the script "post" should not be disabled since it will deactivate the post status and visibility options.

    S.K

  19. Mark / t31os
    Moderator
    Posted 5 years ago #

    Ok, but consider no auto-save, i'd predict several angry users posting when they lose work because the auto-save didn't save work prior to when their browser crashed for whatever reason.

    How long does the auto-save take? 1 second, 5, 10?... is it really that big a deal to wait until it's finished?

    Word count i'd agree isn't essential. If you use Firefox there are small extensions that can do this for you if you need it.

    You could always set the autosave interval high so that it never bothers you (can't remember the JS file that handles this offhand, but the interval is right near the top of the file, it's hard to miss). You could set it to some stupid high amount, and it'll be as if it's never there.

  20. zenoven
    Member
    Posted 4 years ago #

    //wp_enqueue_script('autosave');

    works on my site,but is there a better way ?

    my word count function didn't work to , i don't know why !!!

    e.....

  21. Dave Doolin
    Member
    Posted 4 years ago #

    I just lost a couple of hundred words when WordPress logged me out when attempting to autosave.

    I have no earthly idea how to "duplicate" this problem, but this seems to the right thread for mentioning it.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags