WordPress.org

Ready to get started?Download WordPress

Forums

WP eCommerce
"You save" amount not formatted as currency! (9 posts)

  1. PaulCutcliffe
    Member
    Posted 1 year ago #

    I have a store using WP-Ecommerce, and a couple of versions ago, the "You save" price stopped being formatted as currency.

    Example: Jump Start Foot Pump (please note this site sells adult products, although this product is safe to look at in an office!)

    I've changed the 'Old Price' and 'Price' labels to say 'RRP' and 'Our Price', but now it says this:

    RRP: £10.49 (crossed out)
    Our Price: £7.99
    You save: 2.5! (23.83%)

    it used to say this:

    RRP: £10.49 (crossed out)
    Our Price: £7.99
    You save: £2.50! (23.83%)

    The labels I've changed have moved to the /wpsc-includes/product-template.php file, where they only need changing once (previously they needed changing in two places), but I can't find where the "You save" text comes form.

    Does anyone else have this issue? How can I fix it?

    http://wordpress.org/extend/plugins/wp-e-commerce/

  2. Visser Labs
    Member
    Plugin Author

    Posted 1 year ago #

    Hi PaulCutcliffe, I've raised this with the team. Is this current in WP e-Commerce 3.8.9.4?

    'You save' comes from /wpsc-includes/product-template.php on line #1933

  3. PaulCutcliffe
    Member
    Posted 1 year ago #

    Thanks for the info!

    Yes, it is currently 3.8.9.4 - I always update to the latest version.

    I think the issue first arose at the same time that the labels that I change were consolidated into the product-template.php file - when I previously had to edit these in two places, the You Save amounts were correctly formatted as currency.

    Thanks again.

  4. PaulCutcliffe
    Member
    Posted 1 year ago #

    Thanks again for pointing out where the 'You save' text & price are defined. I don't know how to correctly format the amount as currency, so for now, I've changed:

    'output_you_save' => false,

    ... which nicely removes the problem.

    However, if anyone can help with the formatting, I'd be most grateful.

    Just one thing - is this issue not affecting everyone?

  5. igloobob
    Member
    Posted 1 year ago #

    Paul I am having this exact issue and would love an answer. And you're a STAR for pointing out how to change the Old Price etc labels, I've been trying to figure that out for DAYS!!

  6. Justin Sainton
    Member
    Plugin Author

    Posted 1 year ago #

    Truly odd behavior - everything seems to be working for me.

    Check this page out - http://ms-test-three.zaowebdesign.com/products-page/product-category/new-product/

    Has variations, different sales prices for each one, non-USA currency - fairly customized. The currency is pretty consistently styled for the "You Save" section as expected.

    Is this running the latest version?

  7. igloobob
    Member
    Posted 1 year ago #

    I am running the latest version yes. It was the 'You Save' section that didn't display the currency for me. Not the shipping.

  8. igloobob
    Member
    Posted 1 year ago #

    I disabled it as per the instruction above by

    'output_you_save' => false,

  9. igloobob
    Member
    Posted 1 year ago #

    sorry, just used the variation on your example and see the you save bit now. I'll check mine again...

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic