WordPress.org

Ready to get started?Download WordPress

Forums

MailChimp List Subscribe Form
"You must fill in Address" msg EVERY TIME! (7 posts)

  1. jrotella
    Member
    Posted 1 year ago #

    I've got the plugin installed on my site. I plugged in my API (generated a new one today). Required fields are email, first name, last name, address.

    No matter what you fill in, it just comes back with "You must fill in Address." Even if all the address fields (even Address line 2) are filled in!

    It's making me crazy

    The site is http://www.createNcraft.com

    Please help

    http://wordpress.org/extend/plugins/mailchimp/

  2. mc_nate
    Member
    Posted 1 year ago #

    Hey there!

    It looks like I missed the plugin on that page. If you don't mind, throw it back up there and I'll be happy to have another look at things!

    Cheers

  3. jrotella
    Member
    Posted 1 year ago #

    Sorry! I took it down because it wasn't working and I got frustrated :)

    I put it back up. It's on the very bottom of the right hand column.

    Thanks for your help!!
    Joe

  4. mc_nate
    Member
    Posted 1 year ago #

    Hey again, Joe!

    Alright, that's definitely not supposed to happen. It looks like we're not sending that address information over correctly. I've opened up a ticket with the developers to get this taken care of ASAP.

    In the meantime, you might check out our embedded form as a temporary workaround.

    How can I add my signup form to my website?: http://eepurl.com/gOGN

    I appreciate the heads up on this, and I'll let you know when I hear back from the devs about an update.

    Cheers!

  5. jrotella
    Member
    Posted 1 year ago #

    Thank you so much for your note!!

    I removed the widget from all my pages (so no one tries to use it) and just put a button to a signup form.

    In case you wanted to test with my site (which I would LOVE!), I put the widget on this page:

    http://www.createncraft.com/testsignup/

    I don't have that in my navigation so only you should be able to find/see it. At least I hope so LOL

    Thank you SO SO much for keeping in touch!
    Joe

  6. mc_nate
    Member
    Posted 1 year ago #

    Right on. :)

    It looks like we should be pushing out a fix for this bug here in a few days-ish (how's that for a vague timeline?). So, after that update, things should work correctly.

    Again, I appreciate you bringing that to our attention.

    Cheers

  7. jrotella
    Member
    Posted 1 year ago #

    Yahoo!! If you're able to tell me when you think it's fixed, I will gladly give it a try :)
    Thanks again!
    Joe

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic