WordPress.org

Ready to get started?Download WordPress

Forums

"You must be logged in to post a comment" takes me to dashboard (7 posts)

  1. jcmilton
    Member
    Posted 6 years ago #

    1. I'm logged into my dashboard as administrator.
    2. Options>General are set to:"Users must be registered and logged in to comment."
    3. When I go to blog and try to test the comments, I see "You must be logged in to post a comment."
    4. When I click on the "logged in" link I'm taken directly to my dashboard, where I'm still logged in as an administrator.

    Huh? Something is weird here. Any help?

  2. trippen
    Member
    Posted 6 years ago #

    same problem anyone have a answer ?

  3. Jeremy Clark
    Moderator
    Posted 6 years ago #

    It probably has to do with the theme incorrectly recognizing that a user is logged in. Try it again with the default theme.

  4. trippen
    Member
    Posted 6 years ago #

    Hello tried default theme disabled all plug ins and still same problem.
    I have "Anyone posts a comment" checked

    site is here http://californiadestinationguide.com/

  5. Jeremy Clark
    Moderator
    Posted 6 years ago #

    I have "Anyone posts a comment" checked
    Well that is different then what the original poster was trying to do, so why don't you explain your problem again.

  6. trippen
    Member
    Posted 6 years ago #

    OK I will
    When you try to post it says you must be logged in to post and takes you to the dashboard.
    Now even if you are logged in it still takes you to dashboard.
    I created a new user (not admin) and try to post and it just takes you to the user dashboard even when your are logged in.
    I turned off that you must be logged in and it still says you must be logged in to comment.

    I was having so much fun with word press until I found out you can not post on my site :)

  7. trippen
    Member
    Posted 6 years ago #

    OK fixed it :)
    I went to General Options and had Word Press address as http://www.domain and blog address as http//doamin
    swithed both to http://www.domain and comments work now.

Topic Closed

This topic has been closed to new replies.

About this Topic