WordPress.org

Ready to get started?Download WordPress

Forums

"You don't have permission to do that" Error (17 posts)

  1. miletjs
    Member
    Posted 7 years ago #

    Hello WordPress Admins / Developers,

    I have recently upgraded (and installed a fresh) to WP 2.1 via Fantastico but now I couldn't delete posts or create new categories. I am encountering an error "You dont have permission to do that" I tried clearing all cookies, cache, I am the administrator of the site but to no success. I think this issue was prevalent in version 2.0.3. Is there by any chance that when the wordpress codes were modified in version 2.1, you have brought back this issue again? Any help from you on how to resolve this problem is greatly appreciated.

  2. MichaelH
    Member
    Posted 7 years ago #

    Just installed a WordPress 2.1 blog via Fantastico and had no problem.

    A search of the forums found possible solutions:
    http://wordpress.org/search/have+permission+to+do+that+fantastico?forums=1

    Deactivating plugins:
    http://wordpress.org/support/topic/105065?replies=7

    Reasserting administrator role:
    http://wordpress.org/support/topic/103953?replies=10

    Please note this addresses your thread here:
    http://wordpress.org/support/topic/105439?replies=3

  3. miletjs
    Member
    Posted 7 years ago #

    Hello

    I have tried all of those things. In fact before I posted this problem here, I have already thoroughly searched the forums (and even wordpress.com forums). I really can't understand what's the problem. For some people this is not, but for some this is.

    I notice though that if I deactivated the "Enable Javascript" from my firefox, i can now add/delete categories. But we know that I cant just deactivate it because some wordpress core files need javascript. What must I do? Im suspecting that the .js files in wp-includes are causing these problems.

    Another problem is when "Publish" button is clicked and if the post was auto-saved, it will pop a question, "Edit Post? Yes or No" when yes is clicked, it will go back to main write page and the post is now gone.

    I really need the developers/admins help on this matter as they can better understand what the root cause is.

    Thanks in advance.

  4. miletjs
    Member
    Posted 7 years ago #

    Hi MichaelH,

    Any updates on this? Thanks a lot.

  5. DeathEater
    Member
    Posted 7 years ago #

    Oh re-applying permission is working! But it's tricky. You should first set different role for your account then immediately (without logout or something) give you again administrator privilegies! Then I successfully added category!!!

  6. miletjs
    Member
    Posted 7 years ago #

    Hello,

    I tried this but this didnt work for me :(

  7. ShadowKnight
    Member
    Posted 7 years ago #

    The only thing that seems to work for me is to disable JavaScript. The same issue exists in Safari and IE across multiple machines.

  8. ShadowKnight
    Member
    Posted 7 years ago #

    What a shame upgrading to 2.1.1 did not address this bug!

  9. miletjs
    Member
    Posted 7 years ago #

    What a shame upgrading to 2.1.1 did not address this bug!

    I heard about this

    PAGING: WORDPRESS 2.1 series DEVELOPERS:
    Will this issue be ever addressed? This is a prevalent issues for a lot of people I know (including myself)

  10. ThomasSchulz
    Member
    Posted 7 years ago #

    I think this thread should be merged into:

    http://wordpress.org/support/topic/105065

    Seems like many people, myself included, are experiencing this problem.

  11. miletjs
    Member
    Posted 7 years ago #

    this is really bizarre

    Ive upgraded to the latest version and I am still encountering this problem. Why is that?

  12. miletjs
    Member
    Posted 7 years ago #

    Ha!

    I tried http://trac.wordpress.org/ticket/3807 and it worked!!

    Calling WordPress,
    I'm wondering why you still HAVE NOT CORRECTED this bug despite the fact that you have released a new version already?

  13. basvd
    Member
    Posted 7 years ago #

    I wrote a brief article about this issue. I attached a patch for WordPress 2.2 and instructions.

    I also submitted a patch to the corresponding ticket on trac, so let's see if this gets fixed soon.

  14. laurabruenphoto
    Member
    Posted 6 years ago #

    I have no idea HOW to do that patch, can someone help me?

  15. basvd
    Member
    Posted 6 years ago #

    Yes, you can now download the fix as a simple plugin.

  16. jeet020
    Member
    Posted 6 years ago #

    Hi to all,

    I have found the solution for "You don't have permission to do that" Error.

    You can check it here :
    http://www.0hv.net/you-dont-have-permission-to-do-that-error-here-is-simple-solution

    Thanks.

  17. erisian
    Member
    Posted 6 years ago #

    basvd:

    the alteration you suggested to the pluggable.php file functioned great for me.
    thanks for all the help.

    seems like it is the most solid option out there and makes perfect sense as far as the cause goes as well.

    just fyi, i tried your plugin first and had no luck whatsoever.
    if you need me to revert and test anything specific for you, just give me a heads up an i will gladly do so. consider it thanks.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags