WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] "You Don't Have Permission To Do That" - Can't delete posts/categories (55 posts)

  1. ecetim
    Member
    Posted 7 years ago #

    I signed up for a new hosting provider and used Fantastico to install WP 2.0.6. I then followed the upgrade instructions to move up to 2.1.

    If I try to delete a post under the "Manage" tab, it says "You do not have permission to do that." Same if I try to add a category.

    I am the only user setup on this blog and I am an Administrator.

    I have changed the CHMOD permissions to allow anyone to write/read/execute my entire wp folder.

    Other people ran into this problem in the past, but none of the tips I found have helped. Here are the links I found relating to this:

    http://en.forums.wordpress.com/topic.php?id=1041&page=2&replies=48

  2. ecetim
    Member
    Posted 7 years ago #

    It is related to Javascript - if I disable JavaScript in FF 1.5.0.9 it works. Experimenting further...

  3. ecetim
    Member
    Posted 7 years ago #

    OK I found it. Go to Tools-->Options-->Content. Select "Advanced" and make sure "Change status bar text is checked." Voila, you should be good to go!

    This is in FF 1.5.0.9

  4. ecetim
    Member
    Posted 7 years ago #

    Nevermind....for some reason that doesn't work anymore. Disabling Javascript lets you add/delete stuff, but of course causes other problems. In the meantime I will disable Javascript when I need to modify, otherwise leave it on.

    Any help?

  5. jkeyes
    Member
    Posted 7 years ago #

    I would suggest you install Firebug and see if anything shows up in the console. It might help narrow the problem area.

  6. jkeyes
    Member
    Posted 7 years ago #

    I should have said, Firebug is a Firefox extension: http://getfirebug.com/.

  7. jenseeka
    Member
    Posted 7 years ago #

    wow I think I found it....

    it was a plugin!!!!!!

    That thing "You dont have permission to do that" started happening yesterday and I was like what the?
    so I spent all of today looking through forums and everyone kept saying stuff about Javascript and that sorta thing...

    so a minute ago I thought... well it did start happening after I activated that plugin.

    DO you guys use "Kahn's Instant Notepad" - for the record I thought that was a cool plugin, but I'm sorry it's interefering with the ability to edit stuff!

    all you need to do is deactivate that plugin and you're fine!

    either someone fix that plugin or get buggy challenged.

  8. miletjs
    Member
    Posted 7 years ago #

    no i dont have that plugin

    im so desperate i tried all the tricks to no success

    the only trick that worked is disabling javascript in firefox

    but as you all know i cant just disable it because some if not most of wordpress core files need javascript

    I got myself a firebug but i cant locate where the error is, though it appears to be in the .js files in wp-includes directory

    until this is fixed by the admins/developers, am so terribly helpless!

  9. jkeyes
    Member
    Posted 7 years ago #

    If you have a public link to your installation I'll take a look.

  10. miletjs
    Member
    Posted 7 years ago #

    hi jkeyes, what do you mean?

  11. jkeyes
    Member
    Posted 7 years ago #

    Sorry forgot this it was a wp-admin issue you were having.

    If you want to set up a temporary account and email me details you can, I understand the trust issues involved here so it's no problem if you don't want to.

  12. khanh
    Member
    Posted 7 years ago #

    It seems some code in my plugins clashes with certain WP Javascript functions. I have fixed the problem, so if you use either KCA, KIN or KQF, please go to http://ink.bur.st/wordpress-plugins/ and download the latest versions.

  13. TechZ
    Member
    Posted 7 years ago #

    I'm having the same issue on my blog as well, the funny thing is that it has radomly started...no more adding/delete of Categories..just "You do not have permission"

    What I've tried:

    Turning off ALL plugins
    Switching to default theme
    Trying Opera/Firefox/IE6 to create a category
    Doing that above mentioned firefox/status bar trick
    Made sure I'm the admin account on WP

    The only thing that worked is disable JavaScript in FF and make the category.

  14. ShadowKnight
    Member
    Posted 7 years ago #

    Ditto Techz and add Safari to the browser list

  15. miletjs
    Member
    Posted 7 years ago #

    It seems some code in my plugins clashes with certain WP Javascript functions.

    in my case i am certain i dont have any plugin that clashes because the problem is prevalent in a fresh installed wordpress

  16. ShadowKnight
    Member
    Posted 7 years ago #

    Honestly this is ridiculous, when will there be a fix?

  17. ecetim
    Member
    Posted 7 years ago #

    Has anyone tried WP 2.1.1? I haven't had the time to upgrade yet

  18. Edde Beket
    Member
    Posted 7 years ago #

    Same issue: we're unable to delete posts from the list. However, if you "edit" a post and click the delete button there, everything works fine.

  19. Hemisha
    Member
    Posted 7 years ago #

    I have the same problem and I was wondering if I could change the post where it says ERROR - You do not have permission. In my FTP wp-admin > post.php > it says

    } elseif ($action == 'editattachment') {
    $location = 'attachments.php';
    } else {
    $location = 'post-new.php';
    }
    }

    wp_redirect($location); // Send user on their way while we keep working

    exit();
    break;

    case 'delete':
    $post_id = (isset($_GET['post'])) ? intval($_GET['post']) : intval($_POST['post_ID']);
    check_admin_referer('delete-post_' . $post_id);

    $post = & get_post($post_id);

    if ( !current_user_can('delete_post', $post_id) )
    wp_die( __('[b]You are not allowed to delete this post.[/b]') );

    if ( $post->post_type == 'attachment' ) {
    if ( ! wp_delete_attachment($post_id) )
    wp_die( __('Error in deleting...') );
    } else {

    This is where the source of it is coming from.. how can I change this?

  20. grimnir
    Member
    Posted 7 years ago #

    I am reproducing the permissions issue consistently with a fresh install of 2.1.2. I can re-download, blow away and re-create the database and still get the message 'You don't have permission to do that.' when I log in as admin and try to add a category or a user.

    I'd really like to use WordPress for my blog but this build has a major problem in this issue and it does not seem to be getting much serious attention except for the users that are stumped by it.

  21. ThomasSchulz
    Member
    Posted 7 years ago #

    Hi,

    I have recently begun experiencing this problem as well.
    (http://wordpress.org/support/topic/109084)
    I also experience it in fresh 2.1.2 installations.

    1)
    In categories.php I tested using this code:

    if ( current_user_can('manage_categories') )
    { echo 'can manage'; }
    else { echo 'can not manage'; }

    if ( current_user_can('add-category') )
    { echo 'can add'; }
    else { echo 'can not add'; }

    And it seems it believes that I can "manage-category" but not "add-category"

    2)
    I have checked wp_userdata / wp_capabilities - everything seems correct, e.g: a:1:{s:13:"administrator";b:1;}

    3)
    If I execute my own PHP/SQL code I can delete categories.

    4)
    In WordPress code, it seems that "die(-1)" means permission failed.

    ...

    However, as I am still new to WordPress (and Ajax) internals, I have had troubles diggging deeper... So I have some questions:

    When inside manage-categories and one tries to add a category... Are there any checks done before:

    admin-ajax.php / switch-case 'add-cat' ?

    What do you think is the best way for me to output log-messages in both PHP / Ajax? (best way to track "code flow")

    I do not have a lot of luck using "wp_die" ...

    ...

    Anyways, I can not prove it... But I have a feeling this may be permission related... in either of two ways:

    Perhaps there is a security/user/context issue with Ajax/Javascript/Php/WordPress on Apache/PHP/MySql?

    Perhaps it can also, in some weird way, still be chmod or MySql security/user/context related?

    ...

    What versions of Apache etc. are we experiencing this problem on? Perhaps that could give a clue.

  22. ThomasSchulz
    Member
    Posted 7 years ago #

    Searching around, I found a bug report with a fix that may work for some:
    http://trac.wordpress.org/ticket/3807

    It was mentioned in this thread:
    http://wordpress.org/support/topic/103953

    Anyways, I think that sums up everything. I have tried finding related threads that are inactive pointing everyone to this in the hope of us together finding a solution.

  23. shylah
    Member
    Posted 7 years ago #

    I, too, am having this problem. I discovered it when trying to add a Link category. This topic was started a month ago and still no response at all from Admin.. is there any chance you guys plan to fix this issue?

  24. TechZ
    Member
    Posted 7 years ago #

    An update, it still happens with WP, even the latest 2.1.2

    The only way to add a category, making changes, is to disable JavaScript.

  25. MsTek
    Member
    Posted 7 years ago #

    Yes. I disabled the Java script and everything worked.

    This bug needs to be fixed. Thanks!

  26. TheFreak
    Member
    Posted 7 years ago #

    I found this link posted from another blog. Tried it myself and it seems to have worked without the need to disable JS etc.

    http://trac.wordpress.org/ticket/3807

    Hope it works for you.

  27. Doodlebee
    Member
    Posted 7 years ago #

    I did the same thing as mentioned above -
    http://trac.wordpress.org/ticket/3807

    For the record, though, my issue was with 2.0.9. On a brand-spanking new install. I had just installed it and went to delete the default post and had this issue for days. I visited that link and had to alter it a bit for me - because the solution is for 2.1.x versions - but not by much. The solution linked is to replace lines #244-250 of "wp-includes/pluggable.php" - it worked for me by editing wp-includes/pluggable-functions.php, lines 241-247.

  28. isama
    Member
    Posted 7 years ago #

    I found this link posted from another blog. Tried it myself and it seems to have worked without the need to disable JS etc.

    http://trac.wordpress.org/ticket/3807

    I use Safari and this worked for me also. Thanks heaps!!!!

  29. Thord Daniel Hedengren
    Member
    Posted 7 years ago #

    The pluggable fix seems to work for me too.

  30. lordart
    Member
    Posted 7 years ago #

    Am having the same problems too...with WP v2.1.3

Topic Closed

This topic has been closed to new replies.

About this Topic