WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] "You Don't Have Permission To Do That" - Can't delete posts/categories (55 posts)

  1. inotqiqi
    Member
    Posted 7 years ago #

    same here!

  2. mike
    Member
    Posted 7 years ago #

    Same problem with 2.1.3. It appears that this bug has been set to milestone at 2.2. What do we do until then??

  3. blkhearts
    Member
    Posted 7 years ago #

    Phew, so glad I found this post. I logged into my blog as the administrator and noticed that I could not delete anything. I kept getting the "You Don't Have Permission To Do That" msg.

    After disabling javascript, I could moderate properly with in my WP admin. This really stinks to have to disable javascript to do anything in the admin everytime.

    I suspect the issue is due to the installation of the AjaxWp plugin (An AJAX enhancement for WordPress blogs).

    http://www.giannim.com/blog/index.php?page_id=13

    From what I have read in this post, sounds like WP is not happy with certain plugins.

  4. maskus
    Member
    Posted 7 years ago #

    Hi,

    I just want to notify that in version 2.2 it's the same problem...can't create new categories and users, and shows the message that i'm not authorized...

    A parcial solution is use the plugin to manage categories, create all you want there and then deactivate.

  5. cocoricoco
    Member
    Posted 7 years ago #

    Hi,

    I'm on wordpress 2.2 and I'm having the same problem as you people. Any solution?

  6. 1webhosting
    Member
    Posted 7 years ago #

    new install of 2.2 and I can't delete categories, please fix or this software is just useless.

  7. Marcel Brinkkemper
    Member
    Posted 7 years ago #

    when you experienc this after installing 2.2 this could be a mod_security problem. it is related to http://wordpress.org/support/topic/117993?replies=26

    I got a 403 error on admin-ajax.php and index.php so I have placed a .htaccess in the wp-admin directory with

    <IfModule mod_security.c>
    SecFilterInheritance Off
    </IfModule>
  8. Raabjerg
    Member
    Posted 7 years ago #

    I've had this problem too... but I also found a solution to my problem.

    I've got a WordPress installation on a server at an ISP that works fine.

    I then installed wordpress on my own server (running OpenSuSE 10.2), and got the problem not being able to do things like deleting posts and creating categories. Instead I just got the "You Don't Have Permission To Do That" message.

    I've been using a couple of hours debugging, and found that if I uninstall the PHP5-suhosin extension the problem disappears.

    I know it isn't the best solution to the problem, especially if you want to (need to) use the suhosin extension - but it works.

  9. Carmel
    Member
    Posted 7 years ago #

    It seems that this problem is still occuring. I just instealled a fresh wordpress via fantastico, on a different server, and it seems to be giving me the problem described here...

  10. ovationfinancial
    Member
    Posted 7 years ago #

    Deactivated all my plugins, tried everything in every thread/post, still nothing.

    This is no small problem.

    I guess WordPress can't/won't fix it.

    Time to move on to other software, WordPress's days are over.

  11. missbri
    Member
    Posted 7 years ago #

    Anyone who is having this problem with 2.2 doing that also, as I am, you can
    go to "Manage".
    Next select the post you want to delete and click "Edit" next to the post
    and go to the bottom of the page and click "Delete This Post". Thats the only solution I have for it.

  12. Johan
    Member
    Posted 7 years ago #

    The solution was (for me) that I was using my old prototype.js (in /wp-includes/js/) that I got when I implemented lightbox.

    Solution:
    Replace the lightbox-version of prototype.js (~47 k in size) with the one from wordpress (~71 k in size) and deleting will work (and lightbox still works too).

    /j

  13. earthtojens
    Member
    Posted 6 years ago #

    I do the same thing missbri does in multiple places. I get the the now famous "You don't have permission to do that" on just about everything I try to delete. But if I edit the thing I want to get rid of and use the "Delete this type" button at the bootom of the edit page it works fine and dandy. Running WP 2.2.1 installed via Fantastico hosted on Electric Kitten.

  14. samureye
    Member
    Posted 6 years ago #

    Same problem here....anything definitive?

  15. ecetim
    Member
    Posted 6 years ago #

    I think the final solution is as was posted earlier in this thread:
    http://trac.wordpress.org/ticket/3807

    I am setting this thread as solved, as this fix seems to have worked for everyone here including myself.

  16. simonlife
    Member
    Posted 6 years ago #

    Not quite resolved. I have a closely related problem, and it is identical except that I don't see a "You don't have permission to do that" message. I just got the main admin page thrown onto my screen. A screenshot of a failed autosave ajax call:

    http://www.simonlife.com/media/wp-autosave-error.jpg

  17. earthtojens
    Member
    Posted 6 years ago #

    I did the solution posted on http://trac.wordpress.org/ticket/3807 as ecetim suggested. The 3807.diff needed to be done on line 303 instead of line 381 of pluggable.php. It seems to have worked for me.
    Does anyone know if this problem will be fixed in the next version of wordpress? I am 2.2.1

  18. basvd
    Member
    Posted 6 years ago #

    There is no need to apply a patch anymore. You can now try this plugin.

  19. jeet020
    Member
    Posted 6 years ago #

    Hi to all,

    I have found the solution for "You don't have permission to do that" Error.

    You can check it here :
    http://www.0hv.net/you-dont-have-permission-to-do-that-error-here-is-simple-solution

    Thanks.

  20. sat123
    Member
    Posted 6 years ago #

    I just installed that and got those errors i've tried all steps like following some ticket links and plugins(including the above) but it does not work still.

    Looking for some help.

    Above step by jeet020 also does not work. i am hosted in 1 and 1 and using wp 2.2

  21. sat123
    Member
    Posted 6 years ago #

    Oh now i got them working. I did follow all the steps that were mentioned in trac and here in support and even applied step by jeet20. But any thing was not working yesterday night and i went to sleep and now when i open all things are working. thanx a lot all.

  22. jeet020
    Member
    Posted 6 years ago #

    Hey thanks sat123, its working because you did my steps.
    Its really working by replacing the "js" files.
    I am putting the link here again: http://www.0hv.net/you-dont-have-permission-to-do-that-error-here-is-simple-solution

  23. sat123
    Member
    Posted 6 years ago #

    Then so nice of you. Thanx for posting that. I replaced the js folder of my 2.2.2 installation with that folder of 2.3 beta(latest by now).

  24. optimisticfriend
    Member
    Posted 6 years ago #

    I had the same problem after adding a widget (BlogRush). I used the fix from http://trac.wordpress.org/ticket/3807 but the code was on line 358 of the pluggable.php file (WordPress version 2.3.1).

    Everything worked immediately after replacing:

    $cookie = explode('; ', urldecode(empty($_POST['cookie']) ? $_GET['cookie'] : $_POST['cookie'])); // AJAX scripts must pass cookie=document.cookie
    foreach ( $cookie as $tasty ) {
    if ( false !== strpos($tasty, USER_COOKIE) )
    $user = substr(strstr($tasty, '='), 1);
    if ( false !== strpos($tasty, PASS_COOKIE) )
    $pass = substr(strstr($tasty, '='), 1);
    }

    Replaced with this:

    $user = $_COOKIE[USER_COOKIE];
    $pass = $_COOKIE[PASS_COOKIE];

  25. fifieldn
    Member
    Posted 6 years ago #

    I installed the share_this plugin, part of the install involved placing a file called prototype.js in the js directory. It was this file that prevented me from deleting a page...

Topic Closed

This topic has been closed to new replies.

About this Topic