WordPress.org

Ready to get started?Download WordPress

Forums

You don't have permission to access /blog/wp-login.php on this server (6 posts)

  1. t3spiritz
    Member
    Posted 5 years ago #

    Having searched the topics on this I still don't seem to have come across a solution though frustratingly someone has resolved this problem without explaining how!

    Anyway the following msg is the result of trying to log in. I have two blogs and they are both affected in the same way.

    You don't have permission to access /blog/wp-login.php on this server.
    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

    I have tried changing the permissions on the .htaccess file and I have tried changing the content to:

    <IfModule mod_security.c>
    SecFilterEngine Off
    SecFilterScanPOST Off
    </IfModule>

    but no joy.

    The fault has developed after being able to loggin with no problems to both blogs and without any recent changes. Very odd.

  2. moshu
    Member
    Posted 5 years ago #

    I have tried changing the permissions on the .htaccess file and I have tried changing the content to:

    NO! The instructions says that you add a separate .htaccess containing the lines above to the wp-admin folder - and leave the main .htaccess, in the root, alone.

  3. t3spiritz
    Member
    Posted 5 years ago #

    OK, I'll give that a try Moshu. Thanks for your help.

  4. t3spiritz
    Member
    Posted 5 years ago #

    I just searched both blogs for a htaccess file in the root folder and there was no such file. I looked in the other folders and the only file of that name was in wp-admin which contained the following

    <IfModule mod_security.c>
    SecFilterInheritance Off
    </IfModule>

    (I had experimented with the following but now restored to the above
    <IfModule mod_security.c>
    SecFilterEngine Off
    SecFilterScanPOST Off
    </IfModule> )

    So if there is to be a .htaccess file in the root, what text should it contain?

    Thanks!

  5. t3spiritz
    Member
    Posted 5 years ago #

    Thanks Moshu
    I copied the .htaccess file as is from the wp-admin and placed it in the root folder and bingo! Thanks

  6. natattack06
    Member
    Posted 5 years ago #

    I tried the same thing as t3spiritz and still get 404 error.

    When hitting "login" to add a comment to a posting, the error appears. I copied the wp-admin .htacess into the sites root directory.

    I also set options.php to 755, 770 and nothing changed.

Topic Closed

This topic has been closed to new replies.

About this Topic