WordPress.org

Ready to get started?Download WordPress

Forums

You don't have permission to access /blog/ on this server (9 posts)

  1. LastChip
    Member
    Posted 4 years ago #

    OK, the story so far.

    I had all sorts of problems accessing WordPress, but this was solved by you kind folks here on the installation pages and WordPress has been running fine for the last couple of days.

    However, today, for no apparent reason, it's stopped dead, with the message in the title.

    Everything I've researched so far, suggests there is no index.php file; but there is.

    If I place a plain index.htm file in the blog folder, I can access the file just fine, so clearly,

    a) my browser is looking in the right palce, and;

    b) it goes deeper than a missing index.php.

    Whether I try and access the blog or the login page, I get the same "You don't have permission" message.

    The only changes that have been made are as follows;

    Last night, I stopped the DNS server, as I thought I didn't need it running. This has had no effect on my Apache2 server, with my regular web pages being served without errors. I've switched it back on this morning, just in case it affected WordPress, but it's made no difference to the result.

    Reading the installation page, one common error noted, was a missing ?> end tag to the config.php file. I added this, but again, I've still got this problem.

    I've also added a theme, but don't know how to restore back to the default, without access to the WordPress control panel. However, it should be noted, that theme has been running for the past two days also, without any problems.

    I've checked as best I can phpMyAdmin for database errors, but I'm no expert. However, as far as I can see, it all seems to be up and running.

    Once again, any help would be most appreciated.

  2. LastChip
    Member
    Posted 4 years ago #

    I'd be most grateful for any help on this please.

  3. LastChip
    Member
    Posted 4 years ago #

    OK, I've just done a complete reinstall, with a clean database, with exactly the same result.

    Completely locked out of WordPress; what on earth can it be?

  4. LastChip
    Member
    Posted 4 years ago #

    Anyone?

  5. LeoPote
    Member
    Posted 4 years ago #

    Hello, LastChip

    I have the same problem at my first installation of wordpress.

    My message is: You don't have permission to access /blog/ on this server

    Did you find a solution!

    Thank you!

  6. LeoPote
    Member
    Posted 4 years ago #

    This link solved my problem...
    http://www.slingcode.com/apache.php

  7. LeoPote
    Member
    Posted 4 years ago #

    Problem solved:
    <Directory "/your/virtualhost/docroot/with/noslash">
    Options All ExecCGI FollowSymLinks Includes Indexes
    Allow from All
    Order Allow,Deny
    AllowOverride All Options
    </Directory>

    <VirtualHost *:80>
    ServerName http://www.newvirtualhost.com
    Options All ExecCGI FollowSymLinks Indexes
    DirectoryIndex index.php index.html index.hml index.phtml index.shtml
    DocumentRoot "/your/virtualhost/docroot/with/noslash"
    </VirtualHost>

  8. Vicky Nguyen
    Member
    Posted 4 years ago #

    I have tried to add the code from LeoPote to my .htaccess but still not work :( . Did it help for LastChip?

  9. rscully
    Member
    Posted 4 years ago #

    I had a similar problem and the fix was easier than described above. I simply deleted the .htaccess file and let WordPress rebuild a new one.

    YMMV

Topic Closed

This topic has been closed to new replies.

About this Topic