WordPress.org

Ready to get started?Download WordPress

Forums

"You do not have sufficient permissions to access this page." with SECRET_KEY (11 posts)

  1. Jehan
    Member
    Posted 6 years ago #

    Hello,

    I have just upgraded my WordPress site from 2.0 to 2.5. Everything went pretty well as far as I can see it and it is working as expected... except for the SECRET_KEY new feature.

    By default, I had not it in my wp-config.php, and all went well. Yet when I added the right line, I had of course to reconnect my user in order to access the admin pages. And then when I log in, I get the message "You do not have sufficient permissions to access this page.".

    For information, the user logging in is the administrator of the blog. I have searched the site and the forum for a similar case, but did not find such. Would someone have an idea to help me please? I can have my blog admin work as long as I don't enable this new feature, but as this is a security enhancement, it would be a shame not to use it! :-/
    Thanks.

    Jehan

  2. ecaron
    Member
    Posted 6 years ago #

    Jehan,

    Make sure that you're defining the SECRET_KEY before the require_once line for wp-settings. Put it before the "That's all, stop editing!" line (typically line 18) and you'll be good to go!

  3. howboy
    Member
    Posted 6 years ago #

    I have a similar problem and have spent all day trying to resolve it.
    It arose mysteriously without me changing anything on the blog, as far as I know.

    When I try to login, after putting in correct usr name and pass I get the message:
    You do not have sufficient permissions to access this page.
    no admin interface

    But if I use the back button to go to the blog, not logged in, the one any reader would see, and refresh, the Site Admin button is activated instead of the Login button, so actually I am logged in, WP just won't let me see the admin interface.

    I've worked through most of the troubleshooting tips here:
    http://codex.wordpress.org/Login_Trouble

    - deleted cookies
    - deleted plug-ins
    - replaced wp-login.php (in fact upgraded entirely to v2.5)
    - reset password at least three times
    - did NOT edit Users Table as this is not really a password problem, the password works, its the permissions)
    - checked siteurl and home in the db - they are properly configured and there's no "If someone has moved WordPress..." in the config file
    - the site is not within a https:// domain
    - I don't know from firewalls; but I use Windows XP and Norton Anti-virus; my internet provider, Rogers.com may have firewalls but I also have another WP blog on the same server, running v2 and it's fine so I don't think that's it
    - I also asked my host, Pair.com, to check the permissions and they said they are all normal and told me to consult with WP

    So here I am. I have read all the many many posts on this topic and am sorry to be asking yet again but I've done everything I can think of...

    help?

  4. howboy
    Member
    Posted 6 years ago #

    oh one other thing, I think I came across a post that dealt with the latest upgrade of Firefox possibly creating this problem. I tried IE and installed Opera but the problem persists cross-browsers.

  5. bradbice
    Member
    Posted 6 years ago #

    @ecaron: But the instructions say to put it in the wp-config.php file.
    http://codex.wordpress.org/Upgrading_WordPress_Extended#Step_13:_Add_the_SECRET_KEY_definition_to_wp-config.php

    I am having the same issue. I added the line, and it wouldn't let me in to wp-admin. Commenting out or removing the line allows access.

  6. bradbice
    Member
    Posted 6 years ago #

    @ecaron: Oops, you WERE talking about wp-config.php, but you SAID wp-settings.php so I got confused. Sorry about that.

  7. Samuel Wood (Otto)
    Tech Ninja
    Posted 6 years ago #

    "You do not have sufficient permissions to access this page." has nothing to do with the secret key. It indicates that there's some kind of problem with permissions or some such thing. Check that the permissions are set correctly on any files/directories you touched.

  8. svenjick
    Member
    Posted 6 years ago #

    Hi,

    It seems that different people are getting this error for different reasons. One of them is moving a WordPress to a new place and changing the wp_ prefix of the db tables.

    If this is your case, then there is a solution I just found, which I detailed here: http://wordpress.org/support/topic/173751?replies=2#post-750300

    Hope this helps. Kindly,

    Svenjick

  9. itsvery
    Member
    Posted 6 years ago #

    I had the same problem after upgrading and

    Make sure that you're defining the SECRET_KEY before the require_once line for wp-config. Put it before the "That's all, stop editing!" line (typically line 18) and you'll be good to go!

    did solve the problem.
    Thanks ecaron.

    It should not be Firefox-related - i am using Firefox 3 since yesterday and the problem was solved with simply putting the SECRET_KEY on the correct place.

  10. JohnL
    Member
    Posted 5 years ago #

    Thanks for reporting on this, folx.

    Solved for me.

  11. lambs
    Member
    Posted 5 years ago #

    I tried everything, but nothin worked, then went to phpmyadmin went to the wp_table then wp_user roles opened that up and compared it with my other working blogs found a difference changed it and it worked!!!! ok in the text on the second line it should be a:53: INSTEAD of a:51: simple now everything works!!!!

Topic Closed

This topic has been closed to new replies.

About this Topic