WordPress.org

Ready to get started?Download WordPress

Forums

You do not have sufficient permissions to access this page. (2 posts)

  1. converting2wp
    Member
    Posted 3 years ago #

    I'm trying to take a WordPress installation v. 2.1.3 and create a development environment to do the upgrade to 3.1.

    I've read the article at http://codex.wordpress.org/Login_Trouble but the suggestions don't seem to apply.

    There are two servers involved:

    Old server: PHP 5.2.14, MySQL 5.0.90, Linux 2.6.34-gentoo-r6
    New server: PHP 5.2.15, MySQL 5.1.53, Linux 2.6.32.8-grsec-2.1.14-modsign-xeon-64

    I've a small test area on the old server and I can create a test environment there. But we're moving to the more robust new server and I can't get original version working in the new environment to start the upgrade in earnest.

    For the migration of the database:
    o disabled all plugins and logged out of the old site.
    o took a database backup of the wp_ tables
    o uploaded that to a database on the new server and changed the wp_options table for siteurl and home.

    For the migration of WordPress
    o did a clean install of the 2.1.3 files
    o copied in the theme we've been using
    o created a correct wp-config.php

    The front end seems to work fine -- I can browse the files, and functionality that doesn't depend on the (still disabled) plugins is okay.

    But when I try to login to the backend (with the valid credentials from the old site) I get

    You do not have sufficient permissions to access this page.

    I tried just ignoring the problem and charging ahead with the upgrade (in a few steps all the way to 3.1) -- but all of the upgraded systems showed the same symptoms.

    The user_meta data for the admin account looks correct. Resetting the password doesn't help.

    My hosting service has recommended a "fresh install" - but I need to migrate user ids and their connections to all the old posts, and last I checked, not all of that info was preserved when doing a WordPress export. Besides, it would seem this *should* work.

    Any clues on where to poke at this?

  2. converting2wp
    Member
    Posted 3 years ago #

    This is apparently resolved. It was a two step process:

    1. Do the upgrade from 2.1.3 to 3.1 in the old environment and then migrate that database to the new environment.

    That got everything looking okay except that going to the Appearance > Widgets gave the "You do not have sufficient permissions" page and the Access logs showed a 500 server error.

    2. Uninstall Automattic's "sidebar widgets" plugin. [Even though it had been inactive through the upgrade it was still somehow affecting the access to the new widget dashboard panel.]

    Hope this helps someone else.

Topic Closed

This topic has been closed to new replies.

About this Topic