WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] You do not have sufficient permissions to access this page (11 posts)

  1. larswordpress
    Member
    Posted 3 years ago #

    Greetings,

    Today I've updated a blog from 2.9.2 -> 3.0.1 with automatic update.
    After this update my blog displays fine but I can't access my admin panel anymore.
    When I try to login with my admin accounts I get :

    "You do not have sufficient permissions to access this page."

    I've been looking around for this problem but couldn't fix it:
    -I've tried disabling my plugins by changing the plugins folder name, but the error exists.
    -I've tried to use a force update script but, the error exists.
    -I've looked in my database for multiple names in the wp_usermeta table, but the error exists.
    -When I run wp_admin/upgrade.php it says I have to right version.

    I've tried those solutions but the problem still exists, I hope someone can help me with this issue since I can't figure out how to solve this problem.

    Thanks in advance,

    Lars

  2. esmi
    Theme Diva & Forum Moderator
    Posted 3 years ago #

    Try:
    - switching to the default theme by renaming your current theme's folder in wp-content/themes using FTP or whatever file management application your host provides.

    - resetting the plugins folder by FTP or phpMyAdmin.

  3. jollymoon
    Member
    Posted 3 years ago #

    What an adventure !

    I started out noticing that my "USERS" menu item was missing.

    Then I tried to export my .WXR (really a .xml) so that I could upload my data to a new installation if needed thinking this would replace the missing "USERS" menu item. I kept getting "You do not have sufficient permissions to access this page."

    .htaccess manipulations and deactivating all my plugins (including changing the directory names) had no affect on admin getting permissions. Neither did "switching to the default WordPress theme" no go... didn't work. Even creating a new "administrator" user did not help. I also tried setting all my directory permissions to 777, no go. The "force-upgrade.php" script mentioned in several posts did not work either. There was also nothing in the wp-config.php file that helped including blanking or deleting the "secret" access keys.

    I even reloaded all the WP files for 3.0.3 and did the "manual" upgrade instructions and still NADA.

    I checked the SQL tables for "admin" (or your adminstrator name)and made sure the wp_user_level is set to "10" in the wp_metauser and that the wp_capabilities is set to
    " a:1:{s:13:"administrator";s:1:"1";} " (no quotes) (wp_ is the default prefix and if you named your DB files with something else in your wp-config.php then that is where you need to go look , like wpx_ or wp2_ or wordpress_ etc.)

    I finally got the permissions for admin to work by changing the version number in my SQL table to "8204" (it was something like 15032) Make sure you know there is more than one page in the SQL editing and table area...mine had 8 pages and it was on the 2nd page). You have to have access and know how to edit your SQL database files... (scary, I know) and then go to your WordPress directory and "upgrade.php" -voila- Permissions restored. And the "USER" menu item appeared as well!

    Now I got permissions to work, BUT every single post and link on my blog got a "404 error" message! I thought I had royally messed up. All the data was there in the DB and in the "posts" when you logged into admin, but none of the links to each "post" would work.

    Finally, I had a plugin called "WP DataBase Manager" that has an option to "REPAIR" database. I ran it as a last ditch effort and it worked. It DID! and everything is working perfectly!

    Sure hope this saves all you people the 6 hours+ of hunting and digging that I went through.

  4. Choja
    Member
    Posted 3 years ago #

    Hi Jollymoon, Glad you fixed your problem fella. Wish I could say the same.

    What an indictment on WP that this issue seems almost ubiquitous on the forums and still no fix that users like me can implement.

    I set up a WP site for a dive company in Indonesia. It was something I wanted to do for them to say thanks for really looking after my wife and I during a recent holiday. I got the site up and can post pages etc but when I try to change the appearance of the site (for their logo) using the 'Header' button in Dashboard, whatever attempt I make to upload an image, or even a pre-loaded image fails with the dreaded: You do not have sufficient permissions to access this page.

    I mean C'mon WP, wake up!

    There are NO plugins on the site, I've disabled them all. Tried everything from re-installing WP to attempting a poke at the SQL server... but that's way too deep for me.

    Can someone at WP please address this issue with maybe a video or SOMETHING so I can get back to creating the site for these guys.

    PLEASE.

  5. ralphispoon
    Member
    Posted 3 years ago #

    I finally got the permissions for admin to work by changing the version number in my SQL table to "8204" (it was something like 15032) Make sure you know there is more than one page in the SQL editing and table area...mine had 8 pages and it was on the 2nd page). You have to have access and know how to edit your SQL database files... (scary, I know) and then go to your WordPress directory and "upgrade.php" -voila- Permissions restored. And the "USER" menu item appeared as well!

    I'm an absolute newbie to wordpress but have managed to get this far...

    any chance of a walk-through of the above part?
    thanks

  6. jollymoon
    Member
    Posted 3 years ago #

    I had almost forgotten how to do this...

    You have to edit INSIDE your MySQL from whatever program your ISP lets you access it with... This would be inside your web console that allows you to edit your website at the server.

    You edit the "wp_metadata" file inside the database that controls your WordPress installation. You have to use "browse" and find the tables USER_ID, wp_metauser, wp_capabilities... and select EDIT... Make sure you note the user # and edit the correct tables.

    The wp_options file contains a line about version number called DB_VERSION change this number to 8204 ... (on page 2, look for a little drop down box with page numbers)

    Save the changes and exit the MySQL editor... then follow the rest of the help above...with the upgrade.php and the WP Database Manager Plugin.

    Gotta be brave and change NOTHING else in your MySQL editor and you might make it.

    [insert major waiver statement of damage and liability to your database and all the people who will be mad at me for posting this]

  7. ralphispoon
    Member
    Posted 3 years ago #

    Thanks for the quick replies people, but as brilliant as your help is, its still a little over my knowledge of databases etc.

    So i can look a my database by going through plesk and opening phpMyAdmin, after which I have no idea about finding the table to edit. i have clicked on every 'browse' button i could find but couldnt find anything that would resemble what you're pointing me towards.

    You edit the "wp_metadata" file inside the database that controls your WordPress installation. You have to use "browse" and find the tables USER_ID, wp_metauser, wp_capabilities... and select EDIT... Make sure you note the user # and edit the correct tables.

    am i missing something, or should there be a browse butting that allows me to browse the whole thing?

    thanks for your help with this!

  8. ralphispoon
    Member
    Posted 3 years ago #

    WOW, ok. I have changed the version number and it still gives me the error message after attempting to log in, 'You do not have sufficient permissions to access this page.'.

    What next??

  9. jollymoon
    Member
    Posted 3 years ago #

    Did you make sure you saved it? (inside your SQL editing program? before exiting?)

    Did you run the upgrade.php? ( Like above?)

    Did you download and install Database Manager plugin? and run REPAIR ? (like above?)

    Hope this helps...

  10. thebibleblog
    Member
    Posted 3 years ago #

    You do not have sufficient permissions to access this page.

    I found a solution:

    Changing the prefix wp_ to another example_ causes this error message to be generated.

    I tried everything I could think of like new installation, older versions, plugins, themes etc. The only way I was able to get back to the admin was to revert back to the wp_ database prefix.

    Once I went and again changed back all the database prefixes, and updated the wp-config.php I went to the tab of my browser with the error message on it, clicked refresh on the browser and bingo I'm back in admin.

    I am quite sad for this to have happened, for the wp_ prefix is a security issue. With wp security scan not working, this hole in the system we really need a better security system.

    I am a firm believer in redundancy over protection. If we could for example copy an image of our site application, and restore it. Much like restore points in windows. I think we would be well blessed.

    Another issue of new suspected user attacks using the email @emailworldwide.info with a letter text name and numbers following examples:
    ayla1049581006@emailworldwide.info
    carlo612928298@emailworldwide.info

    While working on my wordpress setups, I noticed two similar users registered about two hours apart. Shortly after they left my system quit showing front side pages.

    Hope this is a blessing to someone,
    Carl

  11. Azuaron
    Member
    Posted 2 years ago #

    When changing the table prefix post-install, it's important to change more than just the table prefixes. To date, here are the additional values that must be changed:

    In the usermeta table, there are several meta_keys:

    prefix_capabilities
    prefix_dashboard_quick_press_last_post_id
    prefix_user-settings
    prefix_user-settings-time

    In the options table, there is a critical option_name that needs to be changed:

    prefix_user_roles

    Depending on your install and plugins, there may be more.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.