WordPress.org

Ready to get started?Download WordPress

Forums

124

[resolved] "You do not have sufficient permissions to access this page." (94 posts)

  1. spackletoe
    Member
    Posted 8 years ago #

    Looks like something went wrong during my upgrade to 2.0. My site is still up, but I can't get to the admin section at all.

    I get this message then I try to log in with a valid account, even with the admin account:

    "You do not have sufficient permissions to access this page."

    There were some errors on the upgrade where the table "usermeta" was not created. I'm not sure if I can manually put this in or what, but out of 3 blogs that I've upgraded to 2.0 so far, this one is the only one that gave me trouble.

    The only thing that I can think of that makes this one different is that it is in a database that includes 2 more WordPress blogs. Not sure if that would make a difference.

    Not sure it helps, but the blog is here: http://www.joepopp.com

    Thanks,

    -spack

  2. bluegator
    Member
    Posted 8 years ago #

    I am getting a similar error, but slightly more specific.

    The upgrade seems to have worked fine with the exception that I cannot access post.php, even with an administrator account

    I have tried the following:

    1. Setting the permissions to "Editor" then back to "Administrator".

    2. Create a brand new user set to administrator and then try to post new or edit.

    The error is simply a blank screen with "You do not have sufficient permissions to access this page."

    Any help would be great, otherwise I'll have to revert to 1.5.2

  3. ergate
    Member
    Posted 8 years ago #

    I had this problem and I solved it by disabling all my plugins. As soon as I did that the permissions cleared right up. I am now going through my plugins one at a time until the error repeats itself.

    I would start there, very likely a conflict in that area.

  4. Servant
    Member
    Posted 8 years ago #

    Just want to confirm ergate's findings. Although I de-activated plugins prior tot he upgrade, I got this error when activating particular plugins. Hope this helps

  5. bluegator
    Member
    Posted 8 years ago #

    Thanks for the advice... My particular case was the LivePress plugin.. I guess I'll have to search for a newer version or different plugin for synching with livejournal.

  6. davidhouse
    Member
    Posted 8 years ago #

    You should report this to the LivePress guys so they can look into it as well.

  7. spackletoe
    Member
    Posted 8 years ago #

    Thanks for the info guys, I've removed all of my plug-ins and I can log in now! BUT... There's no navbar, and I get the "you don't have permission" message when I try to go anywhere.

    I think this is because don't have a usermeta table in my DB. The system doesn't know what priviledges I have and so it doesn't let me go to any pages within the admin section.

    Anyone know how I should go about manually addding the table and fields to the DB to get my access back? I'm going to try to attempt to do some myPHPAdmin surgery by duplicating info from another one of my successful 2.0 upgrades. Wish me luck, and any info is appreciated.

    Thanks,

    -spack

  8. ergate
    Member
    Posted 8 years ago #

    I am not a WP expert, but I would probably make sure I have backups of all my db info, then do a complete fresh install, new tables etc. Then start importing the tables/data into the fresh db.

  9. Koztoujours
    Member
    Posted 8 years ago #

    Hello.

    I have tried the upgrade on a test blog (hopefully not the real one) and I have the same message, "You do not have sufficient permissions to access this page", as soon as I try to use any admin igth, such as posting... as I am the only user of the blog.

    I have access to the admin page but it seems that I am not recognized as the admin.. Indeed, I cannot log in with my admin infos.

  10. Koztoujours
    Member
    Posted 8 years ago #

    I have tried to change the password manually in the SQL base. No changes.

  11. ergate
    Member
    Posted 8 years ago #

    Did you check plugins as Previously mentioned in this thread?

  12. xpdude
    Member
    Posted 8 years ago #

    I am experiencing a similar problem as well. I can't log in after I logged out (My blog has only one user, and that's me). Whenever I try to get anywhere in wp-admin, the message appears.

  13. spackletoe
    Member
    Posted 8 years ago #

    Well, I can't seem to get anything to come up, even after tinkering with the tables in MyPHP. I don't seem to have appropriate access to import stuff from another working database.

    Really frustrating. I'd love to hear from someone who knows that wordpress is expecting to find in the DB as far as user permission go.

    Starting over from a backup yields the same result as where I am now.

  14. petit
    Member
    Posted 8 years ago #

    Just a hunch!
    At upgrading, did you overwrite the wp-config.php, where the database name and user/pw resides. In that fatal event, restore the old config file.

  15. phoenixd
    Member
    Posted 8 years ago #

    I am having the same problem. wp-config.php was not overwritten. Upload went fine.

    My capabilities is listed as
    a:1:{s:13:"administrator";b:1;}
    in Usermeta.

  16. spackletoe
    Member
    Posted 8 years ago #

    I can verify that a WORKING admin account has that same field and the same value in that field. But putting it in manually didn't seem to do the trick.

    a:1:{s:13:"administrator";b:1;}

    How can I turn on some sort of verbose mode that will tell me why certain errors are coming up? Is this possible?

  17. MichaelH
    Member
    Posted 8 years ago #

    Just a shot in the dark--also check that the wp_usermeta table record for your user_id with a meta_key of wp_user_level is set to 10.

  18. phoenixd
    Member
    Posted 8 years ago #

    What all should be in usermeta?
    I have first_name, last_name, nickname, wp_user_level, and wp_capabilities

  19. spackletoe
    Member
    Posted 8 years ago #

    MichaelH, I have that exactly, but for some reason it's not recognizing it.

    phoenix, as far as I know, here's that the usermeta table looks like:

    wp_usermeta table has the following fields:
    umeta_id
    user_id
    meta_key
    meta_value

    MY wp_usermeta table has the following rows (all with user_id field = 1):
    first_name (my first name)
    last_name (my last name)
    nickname (admin)
    wp_user_level (10)
    wp_capabilities (a:1:{s:13:"administrator";b:1;})
    rich_editing (true)

    Now one thing that I have that may be unique is that I use a different prefix in my config file: "wp1_" but I wouldn't think that would make much difference.

    Anyone else have anythign that's workin that looks different from the above?

  20. Koztoujours
    Member
    Posted 8 years ago #

    As far as I am concerned, and to answer a previous question, I do not have any plugin as the blog that I upgraded was only a test one. I did not install any.

  21. wangxiaohu
    Member
    Posted 8 years ago #

    I have the same problem after logged into the admin interface. Except Dashboard, all other links in admin interface give me "You do not have sufficient permissions to access this page."

  22. fautpasresterla
    Member
    Posted 8 years ago #

    It seems to be a bug with the cache on user capabilities.
    A workaround consists in commenting the following lines in wp-includes/pluggable-functions.php:

    // $user = wp_cache_get($user_id, 'users');
    //
    // if ( $user )
    // return $user;

    (37-41)

  23. wangxiaohu
    Member
    Posted 8 years ago #

    I am now able to get rid of this problem by:

    1. Log out if you see "Log out" some where
    2. Remove /wp-content/cache completely
    3. Login again

    However, I found another problem that the reset password function is not working. I am still using the old password to login.

    It seems that the bug is related to the cache system of new WP2.

  24. Koztoujours
    Member
    Posted 8 years ago #

    I had noted that issue concerning the reste password functionality on RC3 ...

    Just one thing : when you say "2. Remove /wp-content/cache completely", could you explain "cache". I am not english-speaking (as U may have noted) and I am not sure of what this means. I guess it's not deleting the wp-content folder ;-) !

  25. spackletoe
    Member
    Posted 8 years ago #

    Man, I hate to say it, but neither solution above worked. After commenting out those lines in pluggable-functions AND deleting my cache folder, I still get the "You do not have sufficient permissions to access this page." upon login.

    It tries to take me immediately to profile.php, by the way. When I just try to go to the dashboard page, it lets me, but as before these fixes, there is no main navigation and any link I try tell me I don't have permission to access it.

    Koztoujours: There's a folder called "cache" in your wp-includes folder, he's talking about deleting that.

    So outside of this being a full on 2.0 bug, how do we figure out what to do next? Was anyone able to verify my table/field information above?

  26. spackletoe
    Member
    Posted 8 years ago #

    okay guys, I did a huge work-around. I created a new 2.0 install in the same database with a new prefix, then I renamed the posts, comments, categories, and a couple other tables in my 1.5 install's DB to make them work in the new install. This required adding some fields to those tables, but it wasn't too difficult.

    The only thing I can see that is weird is that the comment counts are all off. So the site says there are 0 comments in each post when there are actually more. Does anyone know how I could re-build the comment count? This is obviously something that gets done when the upgrade to 2.0 happens, but I can't go back to that now, unfortunately.

    Thanks for all of your help!

    -spack

  27. Koztoujours
    Member
    Posted 8 years ago #

    Thank for your info, spackletoe, but, as U say, your work-around is huge !!! I don't thiink I am going to upgrade my "real" blog until I have other clues to do it properly.

  28. digitalfrog
    Member
    Posted 8 years ago #

    Mhhhh...

    Add me to the list :-(

    I used firefox to do the upgrade and it went wrong.
    I went back to explorer and did not get further error messages but still the infamous permissions message.

    I do have a wp_usemeta but with 0 record in it...

    Am I the only one ?

    Ralph

  29. Koztoujours
    Member
    Posted 8 years ago #

    Is there anybody up there who would feel like considering this issue ?

  30. digitalfrog
    Member
    Posted 8 years ago #

    Okay, looks like I found a way to fix it. I'm not a guru, so this might not be a clean way to make things work but it worked for me ;-)

    I knew something was wrong with the wp_usemeta having 0 records. So I:

    - renamed the wordpress database
    - did a fresh install (not upgrade)
    - did an export of the wp_usermeta
    - dropped the new database
    - rename the old db back to wordpress
    - droppped the old wp_usermeta
    - imported the newer wp_usermeta

    it works... I assume I only have 'admin' as a user now, but I don't think it will have any impact for me.

    Ralph

124

Topic Closed

This topic has been closed to new replies.

About this Topic