WordPress.org

Ready to get started?Download WordPress

Forums

You do not have sufficient permissions on mac os 10.6.8 (6 posts)

  1. ericomtx
    Member
    Posted 2 years ago #

    Hello
    I have installed wordpress 3.2.1 in the following :
    /opt/local/apache2/htdocs
    It is set as ericomtx id / admin group ownership for the entire dir and also with rwxr-xr-x privileges
    I installed it on postgres 9.1.1 and the DB is ok, I am able to test it manually or using eclipse data tools
    When I try to log into :
    http://localhost/wordpress/wp-login.php ... after I log I get the error :
    You do not have sufficient permissions to access this page in :
    wp-admin/profile.php which has the same ericomtx id / admin group ownership and rwxr-xr-x privileges

    my mac os is 10.6.8

    please can some one indicate a starting point ?
    Thks
    √Črico

    [moving to Localhost Installs forum]

  2. thereformation
    Member
    Posted 2 years ago #

    You probably need to set your group to be www or nobody, with read/write privs to you get it going. Then you should be able to knock back the privs to write only for your uploads/ theme directory.

    I usually install into my users/sites folder, then configure http vhosts to point to the correct location, along with editing hosts so I can run wordpress sites under domains like example.loc

  3. ericomtx
    Member
    Posted 2 years ago #

    Wouldn't this be a postgres issue ? I have the pgphpadmin installed local and I am able to access the application. I got istalled by macports on /opt/local/www and the dir is with the admin and owner from htpdocs ...

    I mean ... would be missing any privilege in the DB side ?

    I see in the MySQL install there is a step for setting the granting in MySql DB ... ?

    Thks for your assistance on this !!
    Regards
    √Črico

  4. thereformation
    Member
    Posted 2 years ago #

    Yeah, but it sounds like you are able to log in, which means wp can access your database to look up the users table.

    Does the front end of the site run at all?

  5. ericomtx
    Member
    Posted 2 years ago #

    I tried the following :
    1. changed the wordpress to /opt/local/www and created an alias in conf for it (copied and changed the dir path from my pgadmin which is working fine)
    2. only that didn't work either ... same error
    3. changed the ownership of the wordpress directory to root/admin :
    $ ls -la
    total 0
    drwxr-xr-x 4 root admin 136 Dec 23 15:48 .
    drwxr-xr-x 16 root admin 544 Dec 3 23:17 ..
    drwxr-xr-x 75 root admin 2550 Dec 16 15:31 phppgadmin
    drwxr-xr-x@ 26 root admin 884 Dec 19 21:43 wordpress
    4. still get the same error ...
    5. phppgadmin works ...
    always recycling apache in the steps from above

    6. about the site itself ... yes it is up ... only admin parts are being blocked ...

    7. $ pwd
    /opt/local/www/wordpress
    $ ls -la
    total 408
    drwxr-xr-x@ 26 root admin 884 Dec 19 21:43 .
    drwxr-xr-x 4 root admin 136 Dec 23 15:48 ..
    -rw-r--r--@ 1 root staff 6148 Dec 19 21:53 .DS_Store
    -rw-r--r--@ 1 root staff 397 May 25 2008 index.php
    ....
    drwxr-xr-x@ 90 root admin 3060 Dec 12 22:30 wp-admin
    ....
    -rw-r--r--@ 1 root staff 3177 Nov 1 2010 wp-config-sample.php
    -rw-r--r--@ 1 root staff 3158 Dec 19 21:44 wp-config.php
    drwxr-xr-x@ 8 root admin 272 Dec 19 21:38 wp-content

    8.$ pwd
    /opt/local/www/wordpress/wp-admin
    $ ls -la
    total 1608
    drwxr-xr-x@ 90 root admin 3060 Dec 12 22:30 .
    drwxr-xr-x@ 26 root admin 884 Dec 19 21:43 ..
    -rwxrwxrwx@ 1 root admin 9896 Dec 2 17:17 about.php
    ....
    -rwxrwxrwx@ 1 root admin 6499 Oct 31 21:28 admin.php
    ....
    -rwxrwxrwx@ 1 root admin 4897 Dec 2 04:31 index.php
    ....
    still nothing ...

  6. ericomtx
    Member
    Posted 2 years ago #

    there is an error on postgres log :
    ERROR: syntax error at or near "(" at character 485
    STATEMENT: SELECT pg_attribute.attname AS "Field",
    CASE pg_type.typname
    WHEN 'int2' THEN 'int(4)'
    WHEN 'int4' THEN 'int(11)'
    WHEN 'int8' THEN 'bigint(20) unsigned'
    WHEN 'varchar' THEN 'varchar(' || pg_attribute.atttypmod-4 || ')'
    WHEN 'timestamp' THEN 'datetime'
    WHEN 'text' THEN 'longtext'
    ELSE pg_type.typname
    END AS "Type",
    CASE WHEN pg_attribute.attnotnull THEN ''
    ELSE 'YES'
    END AS "Null",
    CASE pg_type.typname
    WHEN 'varchar' THEN substring(pg_attrdef.adsrc FROM '^\'(.*)\'.*$')
    WHEN 'timestamp' THEN CASE WHEN pg_attrdef.adsrc LIKE '%now()%' THEN '0000-00-00 00:00:00' ELSE pg_attrdef.adsrc END
    ELSE pg_attrdef.adsrc
    END AS "Default"
    FROM pg_class
    INNER JOIN pg_attribute
    ON (pg_class.oid=pg_attribute.attrelid)
    INNER JOIN pg_type
    ON (pg_attribute.atttypid=pg_type.oid)
    LEFT JOIN pg_attrdef
    ON (pg_class.oid=pg_attrdef.adrelid AND pg_attribute.attnum=pg_attrdef.adnum)
    WHERE pg_class.relname='wp_term_relationships' AND pg_attribute.attnum>=1 AND NOT pg_attribute.attisdropped;

    can it be related to the problem ?

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.