WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] You do not have sufficient permissions after update to 3.4.2 (19 posts)

  1. jpedroza2k
    Member
    Posted 1 year ago #

    I ran the update on three of my sites that use the same database, but with different prefixes. They do, however, share a common authentication table. The two that have the different prefix are giving me the error:

    You do not have sufficient permissions to access this page.

    This is after I login, and on every page in the dashboard. I have verified my permissions are set, and I can log into the one that is the default authentication table, just not the other two.

    Is anyone else seeing this? I have searched the forums and Google, but no love so far.

  2. esmi
    Forum Moderator
    Posted 1 year ago #

    Try:
    - switching to the Twenty Eleven theme by renaming your current theme's folder inside wp-content/themes and adding "-old" to the end of the folder name using FTP or whatever file management application your host provides.

    - resetting the plugins folder by FTP or phpMyAdmin.

    - re-uploading all files & folders - except the wp-content folder - from a fresh download of WordPress.

    - running the upgrade manually via wp-admin/upgrade.php

  3. jpedroza2k
    Member
    Posted 1 year ago #

    I forgot to mention, I have tried disabling all the plugins across all three sites as well, and no luck there either. There are no errors in the logs for any of the sites either.

  4. jpedroza2k
    Member
    Posted 1 year ago #

    switching to the Twenty Eleven theme by renaming your current theme's folder inside wp-content/themes and adding "-old" to the end of the folder name using FTP or whatever file management application your host provides.

    I tried this, but the same error still shows. Also, the live site showed a white screen.

    - resetting the plugins folder by FTP or phpMyAdmin.

    I did this on all three sites, so that none of them had any plugins loaded.

    - re-uploading all files & folders - except the wp-content folder - from a fresh download of WordPress.

    Same error

    - running the upgrade manually via wp-admin/upgrade.php

    Shows "No update required"

    edit: fixed typo

  5. esmi
    Forum Moderator
    Posted 1 year ago #

    Do you have a pre-upgrade database backup?

  6. jpedroza2k
    Member
    Posted 1 year ago #

    Sadly, no. The update was run by an over zealous client and the only other copy was a weekly archive last Friday. They made major changes in content that they don't want to have to redo if possible.

  7. esmi
    Forum Moderator
    Posted 1 year ago #

    Anything in the error logs?

  8. jpedroza2k
    Member
    Posted 1 year ago #

    There are no errors in the logs for any of the sites either.

    Nothing in there at all. It seems to be localized to the wordpress environment. I even enabled debugging on the site in wp-config.php and there were two template warnings, no errors. Even fixing the issues with the warnings didn't help.

  9. esmi
    Forum Moderator
    Posted 1 year ago #

    Did you reset the plugins using Phpmyadmin?

  10. jpedroza2k
    Member
    Posted 1 year ago #

    Did you reset the plugins using Phpmyadmin?

    Yes, I didn't use phpMyAdmin, I used the cli, but same results.

  11. esmi
    Forum Moderator
    Posted 1 year ago #

    Have all machines using the site had their caches flushed and cookies cleared?

  12. jpedroza2k
    Member
    Posted 1 year ago #

    Have all machines using the site had their caches flushed and cookies cleared?

    Yes, and we have even tried it on different devices and browsers.

  13. atgeist
    Member
    Posted 1 year ago #

    I'm having the same issues at 7efitspa.com

  14. jpedroza2k
    Member
    Posted 1 year ago #

    I'm having the same issues at 7efitspa.com

    Are you running multiple blogs from one authentication and separate prefixes, or is it a single blog?

  15. atgeist
    Member
    Posted 1 year ago #

    single blog

  16. esmi
    Forum Moderator
    Posted 1 year ago #

    It's looking increasing like the database that's running 2 sit4s may have been damaged during the upgrade. You mentioned one authentication for two sites? Could you elaborate on that? Perhaps it's the authentication that's gone pear-shaped.

  17. atgeist
    Member
    Posted 1 year ago #

    here is what I've tried thus far:

      clean install via ftp
      disabled all plugins (changed name of plugins folder, also via php admin)
      changed name of theme folder (won't adopt twentyeleven theme either)
  18. jpedroza2k
    Member
    Posted 1 year ago #

    It's looking increasing like the database that's running 2 sit4s may have been damaged during the upgrade. You mentioned one authentication for two sites? Could you elaborate on that? Perhaps it's the authentication that's gone pear-shaped.

    What we have is three blogs, each has its own table prefix, wp_, ag_, ai_. We also have the following in the config:

    define('CUSTOM_USER_TABLE', 'wp_users');
    define('CUSTOM_USER_META_TABLE', 'wp_usermeta');
    define('CUSTOM_CAPABILITIES_PREFIX', 'wp_');

    This causes the authentication for all three sites to use the same authentication database. The only blog that is functional on the back end is the one that uses wp_ for the table prefix (the only one that doesn't have the custom code for the user_table, etc.

  19. jpedroza2k
    Member
    Posted 1 year ago #

    I found the issue:
    This posting is the solution.

    Specifically, for those in the same mess:

    Then you have to find in wp-includes/capabilities.php the line:

    $this->cap_key = $wpdb->prefix . 'capabilities';

    and replace it with

    if (defined ('CUSTOM_CAPABILITIES_PREFIX')) {
    $this->cap_key = CUSTOM_CAPABILITIES_PREFIX . 'capabilities';
    }
    else { $this->cap_key = $wpdb->prefix . 'capabilities';
    }

    That' s all! Good luck!

    The way this works, is that it checks if there is a custom prefix and if so appends it to the cap_key property. If not, it uses the default.

    Hope this helps.

Topic Closed

This topic has been closed to new replies.

About this Topic