WordPress.org

Ready to get started?Download WordPress

Forums

You do not have permission to preview drafts. (27 posts)

  1. sprezzaturon
    Member
    Posted 5 years ago #

    I've upgraded to 2.7 from 2.6.5. I am logged into my blog as admin. I click on "preview" to look at a already published post. The page appears with nothing but "You do not have permission to preview drafts." Any halp would be greatly appreciated!

    Thanks,
    sprezzatura.rrd2 at yahoo dot com

  2. mrmist
    Forum Janitor
    Posted 5 years ago #

    Hello

    New drafts or all drafts?
    Your own or other people's?

    Not sure what you mean by "an already published post" - if it's published then it wont be a draft any more, so you wouldn't have the preview button.

    Can you explain the process you are going through in more detail?

  3. movingzachb
    Member
    Posted 5 years ago #

    I am having the same issue - i type an article ( i am an admin ) You do not have permission to preview drafts. comes up on a new page in black text - thats it.

  4. RoseCitySister
    Member
    Posted 5 years ago #

    I wonder - what are your setups - i.e. php, etc. I just previewed a published post and it doesn't do that, it works just fine...

  5. movingzachb
    Member
    Posted 5 years ago #

    Firefox Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.4) Gecko/2008102920 Firefox/3.0.4

    No, I have not tried it in any other browsers.
    URL http://www.evolved.fm/2008/12/dubai-after-dark/?preview=true&preview_id=318&preview_nonce=aeba67d40d (if it works for you) that shows the You do not have permission etc..

  6. RoseCitySister
    Member
    Posted 5 years ago #

    Sorry - I meant on your server where you have the software installed, not on your computer. What versions of PHP/MySQL do you have?

  7. tonytrainor
    Member
    Posted 5 years ago #

    Hi, I'm running 2.7, having upgraded a week ago. Today I tried to open a series of sub pages, six in all, from links on my main page but I get a blank page and the message, "You do not have permission to preview drafts."

    These sub pages are not drafts. They have all been published in the past and are inaccessible as from today. I tested my site as a visitor, logging out of admin, and still the pages appeared as blanks. The title and comment boxes sections were visible at the top and tail of each page, but all the content that you'd see in the edit box was missing.

    I can still open the subpages in the dashboard editor, in visual and html view, and the material is there. However, they cannot be previewed or visited.

    Could it be that when I originally linked the pages, I linked the main page to the preview URLs? I can't see that being a problem in that my sub pages only became blank today. Although my content exists in edit view, I don't want to cut and paste it on to new pages and lose all my existing search links.

    The one thing I did today was load the Feedburner plugin for WordPress, which I've since disabled and can't imagine that this is the problem.

    I wondered if there might be a hitch with page autosaves from the past replacing my saved material with a big nothing. Is the autosave function writing blank space over actual pages that still open but only in edit view? When I try to preview from the dashboard page/post editor, I also get a page devoid of content

    Any ideas?

  8. RoseCitySister
    Member
    Posted 5 years ago #

    I really don't understand what you mean by "linked the pages from the Preview URLs".

  9. Jason
    Member
    Posted 5 years ago #

    Ok, everything else aside, the main problem seems to be the Preview button generating this error: "You do not have permission to preview drafts."

    I'm also experiencing the error when I click the Preview button on the Edit Post page. The button exists even when editing and trying to preview a new, unpublished post.

    I am running wp 2.7 on PHP 5.3.8 and MySQL 5.0.5.

    Could this be a directory permissions issue? Just spit balling here. Any thoughts would be appreciated.

  10. EdwinO
    Member
    Posted 5 years ago #

    I had the same message this morning.
    Accidently I found a solution, or call it workaround, for this. Changing your Blog URL settings, or change them manually might do the trick.
    Anyway I See if this works

  11. exodusfrom9to5
    Member
    Posted 5 years ago #

    Hi everyone, everyone here is using FireFox, correct?

    If so, that might be the problem. I use it too and I see the

    you do not have permission
    msg too

  12. roggie
    Member
    Posted 5 years ago #

    It's not a browser problem, I had the same trouble with FF and IE. As EdwinO said, the answer seems to be in the blog title. Make sure WordPress address (URL) and Blog address (URL) are the same (worked for me).

  13. rosschapman
    Member
    Posted 5 years ago #

    I noticed this problem once I moved my WordPress installation to a sub directory. Wonder if that is affecting things.

  14. mdfrancois
    Member
    Posted 5 years ago #

    this works fine if wordpress address and blog address match.

    things don't work if they do not match. i use a subdomain as the blog address, and the blog is in a subdirectory, and I can never preview anything. I always get the ' You do not have permission to preview drafts.'. this is on 2.7.1. I have another blog where everything is the same (PHP, linux, apached, wp2.7.1, and it works fine, and the wordpress and blog address match.

  15. justderek
    Member
    Posted 5 years ago #

    Well then, the problem remains. I don't see a reason why anyone should have to sacrifice the ability to preview their drafts if they want their WP installation to be in a subdirectory but keep their "clean" url.

    The capability to have your blog's url be different from the directory where WP is installed has been supported in WP for ages, and this previewing glitch has only popped up since the advent of 2.7.1.

    I still therefore ask, what gives?

  16. noise
    Member
    Posted 5 years ago #

    yep - got the problem here as well

  17. noise
    Member
    Posted 5 years ago #

    although not with a new installed test version with a new database with new posts.

    I wonder if it's something that happens on older installs.

    sure wish I didn't upgrade...

  18. justderek
    Member
    Posted 5 years ago #

    I wonder if it's something that happens on older installs.

    Don't think so - mine's a relatively recent install. I think it's mainly to do with wordpress being installed in a subdirectory and using the old .htaccess work-around to keep "clean" permalinks.

  19. Science and SEO
    Member
    Posted 5 years ago #

    I'm having the same problem. "You do not have permission to preview drafts." ??

  20. georginaswan
    Member
    Posted 5 years ago #

    I too have this problem, running version 2.7.1. I think justderek may be onto something with the subdirectory issue. I have just changed the directories so that users can access from the main domain but the WordPress files are located within a subdirectory. Eg website visitors go to http://www.example.com but the WordPress install is in http://example.com/wordpress

    UPDATE: Interestingly, if I just use http://example.com there's no problem - I can preview images with no error. Unfortunately, the people using the blog want to use http://www.example.com. So nobody's happy :(

    Any help would be fab. Thanks.

  21. jose makalolot
    Member
    Posted 4 years ago #

    I have the same problem with the site am working on.

    Much more to my dismay, I can't view other pages aside from the static page I assigned.

    Please try to check, I get a 404 error.

    http://www.absolutetranslations.dk/en/investment-good-return/

    main page is http://www.absolutetranslations.dk/en/

  22. georginaswan
    Member
    Posted 4 years ago #

    A bit of an update: I can now preview pages in Internet Explorer (IE7) but it's still not working for Firefox (PC or Mac), Chrome (or Safari). I was having issues in IE7 but I cleared out the cache and it seems to do the trick. All very strange and makes it difficult if you have multiple bloggers who are accessing from different systems and browsers. But on the bright side, at least I have one way of previewing posts :)

  23. rcwatson
    Member
    Posted 4 years ago #

    *bump* anyone find a fix for this? it's totally putting egg on my face for an install I was promoting as a solution for content workflow. this was a critical component of that workflow. any help would be appreciated.

    Thanks.

  24. tbrandt
    Member
    Posted 4 years ago #

    Check your htaccess file and make sure you do not have the wordpress default code in there more than once. I created my standard htaccess file at the same time I uploaded my install, but before I ran it. As well as the draft error message, I also could not access the standard About page. Saw this post with no help but decided to check my htaccess file. WordPress had re-added to my htaccess and when I erased the second copy, all went well with my install. Hope that is your problem as well.

  25. GimliGlider
    Member
    Posted 4 years ago #

    I was having this problem just a few minutes ago. It would sound hilarious but all I did was quit Mozilla and told it not to save Session information (I use Tab Mix Plus to save tabs in case browser crashes). On next start-up everything went back to normal and I was able to preview posts

    Gimli
    http://www.gimliglider.com

  26. sarahnphillips
    Member
    Posted 4 years ago #

    I had this problem too and just figured out what I was doing wrong.

    In my case, it all had to do with bad linking.

    I failed to realize that when you preview a page the url is not the true url of the page, even if it has already been published. I was copying the url of preview links to build my site rather than the much shorter, proper url. My whole site was peppered with these preview links. Once I went in and corrected all the links, everything works fine.

  27. janvandam
    Member
    Posted 4 years ago #

    I just had the same problem.
    the solution is:
    remove all cookies from the cache, restart the pc and log in at your wordpress correctly.
    You will see that the problem is solved.
    (that's what I did !!!)

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags