WordPress.org

Ready to get started?Download WordPress

Forums

'You do not have permission to do that' error is back! (13 posts)

  1. 20something
    Member
    Posted 6 years ago #

    When I updated to 2.3 I started getting the 'you do not have permission to do that' error when trying to add categories and publish posts. I checked all throughout the forums to see if there was a fix. There was not. Essentially, I was told this is a common bug and there is no fix and I would have to stop using firefox and use IE or Safari to do these things. It worked, so I gave up trying to fix.

    Now, I updated to 2.5, and I started getting the error in IE. I dl'ed Safari, I get the error there as well, and the error is still in Firefox. Because WordPress developers are more concerned with aesthetic qualities versus making sure that their software is compatible with all browsers and their coding is legit, I am now unable to make any new posts on my blog. My blog is rendered useless. This is a known bug on wordpress's end, and unless someone can help me fix this, I'm off to another platform. Someone please help!!

  2. jbbrwcky
    Member
    Posted 6 years ago #

    I have begun to encounter this error too, just for the WP2.5 version (the blog I'm referring to used to use the WP2.3.3 version).

  3. emaciek
    Member
    Posted 6 years ago #

    I have similar problem. I was using 2.3.3. but after encountering this problem I have deleted whole wordpress including tables. And it is still there. I can't explain that. Cache in browser?

  4. emaciek
    Member
    Posted 6 years ago #

    OK. Change index.php permissions and it is fine.

  5. RobertBruce
    Member
    Posted 6 years ago #

    emaciek

    Don't leave me in the lurch - what index.php must I change and change it to what permissions? 777?

  6. 20something
    Member
    Posted 6 years ago #

    Yes, please do tell Emaciek

  7. 20something
    Member
    Posted 6 years ago #

    OK guys, I may have found a solution. I'm guessing many of you had the issue prior to 2.5 and had used Bas's Ajax referrer fix plugin. Supposedly this ajax issue was fixed with the 2.5 upgrade, and now the Ajax referrer plugin actually is preventing the upgrade fix from working. De-activate the plugin, clear your entire browser history, and you should be good to go.

  8. RobertBruce
    Member
    Posted 6 years ago #

    @20something - nope! I tried this. It still gives me the 500 birdie!I had this with the 2.4 upgrade but the solution then does not work with 2.5

    I am stumped. Feel like reloading 2.3.

  9. RobertBruce
    Member
    Posted 6 years ago #

    Above should read 2.3 upgrade

  10. jeffposaka
    Member
    Posted 6 years ago #

    I noticed I cannot add new categories as well. Any solutions available? Any ideas?

  11. Lloyd Budd

    Posted 6 years ago #

    You still encounter this issue with all plugins disabled?

  12. Anonymous
    Unregistered
    Posted 6 years ago #

    I've upgraded to WP2.6 and this issue was resolved by a simple activate/deactivate each plugin. Maintenance Mode Plugin (v3.2) by Michael Woehrer seems to broke WP and cause the "You do not have permission to do that" prompt. Hope it helps.

    Love.

  13. prostoalex
    Member
    Posted 5 years ago #

    Same here - deactivate all and reactivate all plugins helped.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.