WordPress.org

Ready to get started?Download WordPress

Forums

Revive Old Post (Former Tweet Old Post)
[resolved] "You do not have enough permission to set the option." error (12 posts)

  1. indietravel
    Member
    Posted 1 year ago #

    WP 3.5.2
    Tweet Old Post v 4.0.7

    After installing plugin and heading to settings, administrators get the error:
    "You do not have enough permission to set the option. Please contact your admin."

    We've tried removing plugin, scrubbing database of all mentions of it (search and detroy top_opt_), and re-installing from scratch.

    Please advise.

    http://wordpress.org/extend/plugins/tweet-old-post/

  2. Ajay Matharu
    Member
    Posted 1 year ago #

    lot of people have raised this issue.
    I would require the wordpress access to check this.

  3. indietravel
    Member
    Posted 1 year ago #

    Thanks for your reply. Is there any diagnostics we can run rather than creating an admin account for you?

    Failing that, what is a secure way to get a temporary account for you?

  4. indietravel
    Member
    Posted 1 year ago #

    Rolling back to 3.3.3 fixes this issue, so I'm guessing it's a permissions error in the 4.x code?

    Let me know about questions above.

  5. indietravel
    Member
    Posted 1 year ago #

    Update: although 3.3.3 allows us access to the admin page, we can't get twitter authorised.

    Are there any diagnostics we can run rather than creating an admin account for you?

    Failing that, what is a secure way to get a temporary account for you?

  6. lahiru
    Member
    Posted 1 year ago #

    Same problem here. Tried changing file permissions and downgrading to 4.0.6 but no luck.

  7. indietravel
    Member
    Posted 1 year ago #

    We did have access to the admin panel after we downgraded, but then realised that the functionality still wasn't working. No solution yet.

  8. lionelroux
    Member
    Posted 1 year ago #

    update the top_admin.php file

    set line 10
    if (current_user_can('edit_plugins'))

    to
    if (current_user_can('activate_plugins'))

    It seems there is something wrong withj multisite administrator/super admin config.

  9. Can
    Member
    Posted 1 year ago #

    Thanks lionelroux, that solves the problem!

  10. computerdirk
    Member
    Posted 6 months ago #

    Maybe you have in your wp-config.php the option DISALLOW_FILE_EDIT set to true. Set it to false and the plugin will work...

  11. DavidFB
    Member
    Posted 6 months ago #

    I have the stated problem and am not on Multisite.

  12. codeinwp
    Member
    Plugin Author

    Posted 6 months ago #

    Hi David,

    Sorry for the late answer, do you still have the issue, send us more details at : info@readythemes.com

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic