WordPress.org

Ready to get started?Download WordPress

Forums

NextGEN Gallery
You browser doesn't have Flash, Silverlight, HTML5, or HTML4 support. (63 posts)

  1. Gonçalo Peres
    Member
    Posted 10 months ago #

    Greetings.

    I'm running WordPress 3.6 Multisite and NextGen Gallery 2.0.17 and was also having this same issue (You browser doesn't have Flash, Silverlight, HTML5, or HTML4 support).

    I've replaced my current version (2.0.17) with the latest beta (2.0.18) and confirm that the issue has been resolved.

    Thank you :)

  2. marchzz
    Member
    Posted 10 months ago #

    Does local host matter? (See my posts above.) I'm not multisite.

    Thanks NextGen.

    Leo

  3. voopress
    Member
    Posted 10 months ago #

    Anyone have more info on this? I too have the same problem using NextGen Gallery with Social Gallery.

    'You browser doesn't have Flash, Silverlight, HTML5, or HTML4 support'

    Disabling all plugins along with trying to use only one galley also doesn't work.

  4. voopress
    Member
    Posted 10 months ago #

  5. marchzz
    Member
    Posted 10 months ago #

    Couldn't get NextGen Gallery to work with local host but it works fine with the "live" site.

    Leo

  6. redkobold
    Member
    Posted 9 months ago #

    WORKAROUND - GOOGLE CHROME instead of IE10

    I recently migrated to Windows 7 from Windows XP and from IE8 to IE10. First time I tried to use upload some pics after the transition I got the grammatically incorrect error-

    "You browser doesn't have Flash, Silverlight, HTML5, or HTML4 support."

    Did all of the updates with no luck then just installed Chrome and went to my site and uploaded the pics with no problem.

    I do not get this error when accessing my site with Google Chrome.
    Version 29.0.1547.66 m

    Good luck.

  7. knollo
    Member
    Posted 9 months ago #

    got the same problem, but no workaround helps. i am on 2.0.27

    what shall i do?

  8. sanzo77
    Member
    Posted 9 months ago #

    I've the same problem. I tried all the tricks that I've read here, but nothing helps.
    I've a localhost installation and I can read from the javascript console that nextgen plugin wants to include stuff from localhost/mysite...... and not from localhost:8888/mysite.....
    I've found for example in the module.nextgen_gallery_display.php the following line
    $router->get_static_url('photocrati-nextgen_gallery_display#nextgen_gallery_related_images.css')
    I don't know what get_static_url gives back but could be thar it gives back only 'localhost' and not 'localhost:8888'
    Can you fix it?

  9. sanzo77
    Member
    Posted 9 months ago #

    I want to add that remapping MAMP on localhost and changing the correct value in mysql db all works right ;-)

  10. knollo
    Member
    Posted 9 months ago #

    does anyone got a hint for me? it's still not working.

  11. knollo
    Member
    Posted 9 months ago #

    safari's error log says:

    http://mydomain/wp-content/plugins/nextgen-gallery/products/photocrati_nextgen/modules/nextgen_addgallery_page/static/plupload_queue/css/jquery.plupload.queue.css?ver=3.6.1

    Failed to load resource: the server responded with a status of 404 (Not Found)

    http://mydomain/wp-content/plugins/nextgen-gallery/products/photocrati_nextgen/modules/nextgen_admin/static/jquery.placeholder.min.js?ver=2.0.7

    Failed to load resource: the server responded with a status of 404 (Not Found)

    http://mydomain/wp-content/plugins/nextgen-gallery/products/photocrati_nextgen/modules/nextgen_addgallery_page/static/plupload_queue/jquery.plupload.queue.js?ver=3.6.1

    Failed to load resource: the server responded with a status of 404 (Not Found)

    and finally:

    TypeError: 'undefined' is not a function (evaluating '$("#uploader").pluploadQueue(plupload_options)')

  12. knollo
    Member
    Posted 9 months ago #

    yet another update (2.0.30) and still the same error. :-(

  13. photocrati
    Member
    Plugin Author

    Posted 9 months ago #

    @knollo - Have you submitted a Bug Report (http://www.nextgen-gallery.com/report-bug/) for this issue you are seeing?

    We really want to squash this particular bug once and for all but would also greatly appreciate log in credentials to your WordPress installation to get a closer look at the issue you are seeing.

    Thanks!

    - Cais.

  14. Andreas
    Member
    Posted 9 months ago #

    Hello, I have the same problem in a multisite installation (Chrome, Firefox).

    And you know, if you have a running network and all the other plugins works fine togehter, I can't switch the theme or deactivate all other plugins. The problems exist in the nextgen gallery only.

    Please fix this issue soon as possible!

    Thanks

    Andy

  15. James Mehorter
    Member
    Posted 9 months ago #

    I also have this issue, but I'm not running Multisite. I'm running NextGen Version 2.0.31 and I have a local and production version of the identical website running. The local version (I'm using my hosts file to do local development) does not work and shows http://d.pr/i/ZalS and the production version does work, showing http://d.pr/i/cDP4

    I am using the same Google Chrome Version 30.0.1599.69 and Safari Version 6.0.5 to view each site on Mac OS X Mountain Lion. Both browsers display the same issue, so this clearly is not a "You browser doesn't have Flash, Silverlight, HTML5, or HTML4 support." issue as the error insists.

    EDIT: I can also confirm this problem exists in Windows running IE8 or IE10 when running a site locally (No multisite still though).

    I did submit a bug ticket, but was not given a ticket number to reference.

  16. photocrati
    Member
    Plugin Author

    Posted 9 months ago #

    @James Mehorter - Based on the OS you referenced I would suspect you are using MAMP for your local installation, have you tried re-mapping "localhost:8888" (the default) to simply "localhost" (port 80)?

    - Cais.

  17. James Mehorter
    Member
    Posted 9 months ago #

    Cais, yes. That was done when I installed MAMP long ago. This issue is with the plugin-not our setups. I've now confirmed the same issue on Windows and OS X using Chrome, Safari, and IE when running a site locally-no multisite. Sounds like you need to check the detection script you're using to determine if Flash/HTML5/Silverlight and such is installed. Regardless of any user's setup, your detection script should know when I'm running an HTML5 compliant browser.

  18. photocrati
    Member
    Plugin Author

    Posted 9 months ago #

    James - Re-mapping localhost:8888 to localhost was seeing some successes in similar situations but does not work in every case.

    Sorting out local installation issues are very difficult, especially when we are not able to recreate them ourselves from the information we have generally been provided.

    You are more than welcome to submit a Bug Report (http://www.nextgen-gallery.com/report-bug/) with the full specifics of your installation and we can try to mimic it for testing but unfortunately that is all we are able to offer at this time.

    We do understand how frustrating it can be to not have a local environment to test with, as well, and would like to get this sorted out as soon as we can for those users and developers that prefer working locally when testing, etc.

    Thanks!

    - Cais.

  19. simo71
    Member
    Posted 8 months ago #

    I have two sites with nextgen gallery with the same host (natan)

    with the first also disabling all plugins I have the same error with IE not make the upload,no errors with firefox
    with the second I have no fault with both IE and firefox

    - I do not have settings multisite

    I tried to follow the recommended procedure:

    disable all browser extensions
    - Reinstalling flash on your computer > restart computer and reload browser & your site
    - Temporarily switching to WordPress default theme > clear browser cache & reload your site
    - Deactivate all plugins (including NextGEN Gallery) > clear browser cache > re-activate NextGEN Gallery only & reload your site

  20. MPESGT01
    Member
    Posted 8 months ago #

    Hi, fresh new install on a fresh new blog = 2 errors

    1 - add images = You browser doesn't have Flash, Silverlight, HTML5, or HTML4 support.
    2 - overview = (Yon don't have enough privilege access) (plus their is a URL dismatch)

    I use Mac / Chrome, every latest updates are done.

  21. caratage
    Member
    Posted 7 months ago #

    I had the same issue. Normal install, no multisite. Running a custom theme. It turned out that the theme had dequeued the photocrati_ajax script.

    Check your functions.php and comment out:

    wp_dequeue_script('photocrati_ajax');

  22. photocrati
    Member
    Plugin Author

    Posted 7 months ago #

    All - First, please post your own topic for an issue you are experiencing on your own site.

    Second, you are welcome to submit a Bug Report (http://www.nextgen-gallery.com/report-bug/) with your site specifics so we can try to help you sort out your particular issue.

    Thanks!

    - Cais.

    PS: @caratage, thanks for that tip ... and I am curious which theme it is that is purposely using wp_dequeue_script('photocrati_ajax');. Send us a note on our contact form, if you prefer not to note it here.

    http://www.nextgen-gallery.com/contact

  23. caratage
    Member
    Posted 7 months ago #

    It's my own theme (not publicly available) where I dequeued scripts for testing and optimisation purposes and then forgot to enqueue it again.

    Just thought that the issue might be related to problems loading photocrati_ajax from admin.php as it is the case as soon you dequeue the script...

  24. photocrati
    Member
    Plugin Author

    Posted 7 months ago #

    @caratage - Thanks, that makes perfect sense to use that sort of process when testing.

    - Cais.

  25. simo71
    Member
    Posted 6 months ago #

    I would like to know if anyone has solved the error:
    "You browser doesn't have Flash, Silverlight, HTML5, or HTML4 support"

  26. Filippo Tasca
    Member
    Posted 6 months ago #

    No, I've found no solution. I think it's an issue related to a problem with the Plupload plugin, but I can't solve it.

  27. Filippo Tasca
    Member
    Posted 6 months ago #

    It seems that some scripts are not loaded, like plupload. I can't understand why in localhost everything works and when i put my theme online some scripts are not loaded. I've tried forcing my theme to load plupload plugin enqueuing the script in the functions.php of my theme, and something seems to work better: now i can see the graphic interface correctly, but the error message "You browser doesn't have Flash, Silverlight, HTML5, or HTML4 support" still remains.

  28. Filippo Tasca
    Member
    Posted 6 months ago #

    Now it works: enqueue your own copy of jquery-ui and plupload in functions.php. You maybe also need to comment out this line of code:

    $('input.nextgen_settings_field_colorpicker').wpColorPicker();

    from

    wp-content/plugins/nextgen-gallery/products/photocrati_nextgen/modules/nextgen_admin/static/nextgen_admin_page.js::line-65

    Maybe the problem is related to the php DOCUMET_ROOT variable. On my machine (unix) everything works, on the online server (windows) it throws the error

    Notice: Undefined index: DOCUMENT_ROOT in ********\wp-content\plugins\nextgen-gallery\products\photocrati_nextgen\modules\fs\class.fs.php on line 36

    I've edited that function and the error is not displaying anymore. Now my function initialize() is this one:

    function initialize()
    	{
    		parent::initialize();
            // let's make sure the $_SERVER['DOCUMENT_ROOT'] variable is set
            if(!isset($_SERVER['DOCUMENT_ROOT'])){ if(isset($_SERVER['SCRIPT_FILENAME'])){
            $_SERVER['DOCUMENT_ROOT'] = str_replace( '\\', '/', substr($_SERVER['SCRIPT_FILENAME'], 0, 0-strlen($_SERVER['PHP_SELF'])));
            }; };
            if(!isset($_SERVER['DOCUMENT_ROOT'])){ if(isset($_SERVER['PATH_TRANSLATED'])){
            $_SERVER['DOCUMENT_ROOT'] = str_replace( '\\', '/', substr(str_replace('\\\\', '\\', $_SERVER['PATH_TRANSLATED']), 0, 0-strlen($_SERVER['PHP_SELF'])));
            }; };
            $this->_document_root = $this->set_document_root($_SERVER['DOCUMENT_ROOT']);
    <code></code>}
  29. simo71
    Member
    Posted 6 months ago #

    @filippo tasca

    I have overwritten all the files and wordpress plugins nextgen gallery. The message "You browser doesn't have Flash, Silverlight, HTML5, or HTML4 support" not displayed. When do I upload pictures unfortunately not successful whit IE 8, with firefox the upload is successful

  30. Filippo Tasca
    Member
    Posted 6 months ago #

    I have tested it with chrome and seems to work (as in firefox). I'm working on a Mac OSX, so I can't test IE!

Reply »

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.