WordPress.org

Ready to get started?Download WordPress

Forums

You are not allowed to edit this post. (26 posts)

  1. kiess
    Member
    Posted 2 years ago #

    i did a fresh install of 3.1.2 and a new database through Godaddy hosting. i can't create any posts or pages without getting this error:

    You are not allowed to edit this post.

    i also tried to trash some existing posts and got similar errors about how i can't move to trash.

    i'm the only user set up and i'm an administrator - it shows me logged in as well. i also disabled all plugins and reverted to the base theme - same story.

    the only thing i really did that was extraordinary is import some posts from an older version of the blog and map the users to the one user account.

    if anyone can help i'd appreciate it - pulling my hair out over here.

  2. Samuel B
    moderator
    Posted 2 years ago #

    try creating a new admin user and test
    there is no known bug like this

    you are on a linux server at godaddy's, right? because their windows servers stink

  3. kiess
    Member
    Posted 2 years ago #

    linux server, yeah.

    same issue with a new user; creates successfully, logs in successfully, but same errors.

  4. Samuel B
    moderator
    Posted 2 years ago #

  5. kiess
    Member
    Posted 2 years ago #

    yeah i read those before posting - no luck there. i searched for the table row he mentioned but it wasn't there; and the other link in there someone links to is about 4 years old and doesn't seem relevant.

    i think your two links are the same, actually.

  6. kiess
    Member
    Posted 2 years ago #

    anyone else have any ideas on this?

  7. katiekills
    Member
    Posted 2 years ago #

    The same exact thing has been happening to me. I import an xml file of old tumblr posts using the WordPress Import plugin, and the admin privileges are disabled when trying to add a new page or post with the same message:

    You are not allowed to edit this post.

    This is seriously infuriating. Help please?

  8. kiess
    Member
    Posted 2 years ago #

    so maybe it has to do with the importing of xml files in some way...does that help any moderators to shed any light on the issue?

  9. andygp
    Member
    Posted 2 years ago #

    I'm also getting the same issue.

    Can not create a new post. I get message "You are not allowed to edit this post"

    I can edit old posts.

    I tried adding a new admin user, but it doesn't work. I get a confirmation email with the username blank. But no user entry is made to the database.

    I have tried disabling all plugins.

    I am using version 3.1.2 of wordpress on linux server on Dreamhost.

    I tried rolling back (delete all, and reinstall) to 3.0.2 and restored backups, but still get the same issue ... strange. I think something has changed in DB configuration on the web host, but I don't know what I am looking for!

    I know I have made some entries back when I was using 3.0.2 so I don't know why the re-install still have issues.

  10. chuffer
    Member
    Posted 2 years ago #

    I have the same problems . upgraded to 3.1.2 also asked my host service (IXwebhosting--- very helpful ) who could find nothing wrong with the db and done a complete new install and this time only copied the post table from old db to new db and guess what .. problem of being unable to post came back . The problem is in the db but only when you try to keep your old posts .
    Surely this must narrow the solution down a lot to someone who really knows wordpress code . I am desperate and very very unhappy with all the supposed solutions people keep repeating on this forum . Anyone out there who can really Help ?

  11. kiess
    Member
    Posted 2 years ago #

    yeah i'm dead in the water too until someone can help narrow this down....

  12. esmi
    Theme Diva & Forum Moderator
    Posted 2 years ago #

  13. kiess
    Member
    Posted 2 years ago #

    well just fyi in regards to Esmi's link and some of its suggested solutions:

    - just tried the forced database upgrade and that didn't do anything - same problems.

    - commenting out a certain string in the wp-settings.php file was a no go too, as the string in question doesn't even seem to exist in the latest version of the wp-settings.php file.

    - i tried updating the table names (changing "wp_user_roles" to "wp_new_user_roles" etc) and that actually made me unable to even log in to wordpress at all.

    so this appears to be yet another link that doesn't contain any actual viable solutions. feel free to double check me but i think those were the main 3 suggestions in the thread.

  14. chuffer
    Member
    Posted 2 years ago #

    how did you change the db version in phpadmin . Tried the suffix fix and no joy there either and also tried the link to
    http://beconfused.com/2007/how-to-solve-you-do-not-have-sufficient-permissions-to-access-this-page-in-wordpress/
    without much joy either .
    surely this is a bug if you can't add records to the db easily . Surely everything like transferring posts from old db to new db should be backwards compatable.
    Not very impressed so far

  15. kiess
    Member
    Posted 2 years ago #

    chuffer - the db version is a line in the wp_options table (there are about 220 rows in there and i didn't see it on the first page). when you hard change it to an old number and refresh your wp admin page it sees it's out of date, updates it, and you're set. unfortunately that didn't change anything.

    i'm not too happy at the moment either - i picked wordpress for its ease of use and i'm already several weeks behind schedule because of bugs...

    h-e-l-p.

  16. chuffer
    Member
    Posted 2 years ago #

    Thanks for that
    No good though - big suprise eh !
    Come on people somebody must have figured this out by now . WordPress is a clever installation and written by clever people so please help us dummies
    TA .

  17. andygp
    Member
    Posted 2 years ago #

    Just just tried a fresh install of 3.1.2 locally on my computer with XAMPP, imported the old database and restored wp-content/ - and still get the same problems.

    So it must not to do with anything with the server.

    I also think there is something corrupted with the datatabase.

    I know I use to have wordpress working with a XAMPP local install.

    Just to confirm, I also did another fresh install locally, with brand new database and all, and I can post all okay.

  18. kiess
    Member
    Posted 2 years ago #

    yeah i can do a fresh install as well even on my hosting server and it works fine -- it's when you import old posts that everything seems to corrupt and fall apart. i don't get it. but i need old posts so we have to figure this out one way or another.

  19. chuffer
    Member
    Posted 2 years ago #

    Same for me KIESS . wordpress upgrades are not much good for me if I can't keep my old messages . Surely this isn't a problem that just we three have . Any developers out there that want a challenge . It looks like a nice little challenge for some one .

  20. andygp
    Member
    Posted 2 years ago #

    I have solved my problem! It turns out it was something that I did.

    The DB user and password I had in wp-config.php did not have INSERT privileges to the database.

    I had some time in the past, accidentally disabled INSERT for the user.

    Re-enabling the command and checking the user had full access to the DB, then fixed this issue.

    When I was testing locally, I had messed the editing of wp-config.php and my local XAMPP setup was actually accessing the external DB with the bad privileges.

    I only discovered this when I completely deleted my live install, and re-installed it from scratch, when it come to the wizard setup to create the DB, it said that all INSERT commands had failed which I thought was a little odd, because it created the tables and everything fine, and the db user/pass all fine. Further checking in my web hosting config page showed the problem.

  21. kiess
    Member
    Posted 2 years ago #

    i don't think this is the same issue for me/the rest of us. my server (godaddy) sets up the database and user automatically to work with wordpress, and i'm not sure i even see a place in their control panel to change the privileges of a database user (there is only one, after all). on top of that, the whole thing works on a fresh install before you try to import old posts -- if it was a user privilege issue i feel like nothing would work on a fresh install either.

    anyway, curious if anyone else tries this and if it works for them.

  22. kiess
    Member
    Posted 2 years ago #

    so i have a positive update -- i think i finally figured it out.

    i did another fresh install (4 of them, actually) because i was hellbent on figuring out exactly what caused the errors.

    i did an import of old posts from a Blogger blog and everything worked fine and it still let me add posts.

    i did an import of old posts from another WordPress and that also worked fine and let me add posts as well. so far so good.

    then i tried Tumblr, and guess what? it broke again -- instantly. every post says "submit for review" instead of "publish" and i can't do anything.

    i started thinking maybe the export tool that i used for Tumblr somehow corrupted the .xml file i was importing. so i found and used a different export tool, which is here: http://www.tumblr2wp.com/ it generates a wordpress compatible xml file from your tumblr blog and you import it using the wordpress importer.

    guess what? it works.

    all my old posts are now onsite and i still seem to have admin privileges somehow. so i don't really know what happened or why it's working, but maybe some Tumblr exporters corrupt the file and thus corrupt your install somehow. either way it seems to be working now -- knock on wood.

    hope this works for someone else.

  23. zowieguy
    Member
    Posted 2 years ago #

    HELP!!.. I have been working on this issues for so many hours no with no luck. I am logged in as Admin but I cannot create new posts, upload new images or change any plugin settings. I have checked this forum for any solutions and have found none that work. I have done fresh installs, re uploaded database files, checked and rechecked all tables.. I know there has to be a fix but I am at an impasse. If someone has dealt with this before and had successful results please contact me asap. I am willing to pay $ for any help that works. Thanks -

  24. lokisapocalypse
    Member
    Posted 2 years ago #

    I was able to resolve this by editing wp-includes/post.php.

    There is a line that reads:

    $post_date_gmt = '0000-00-00 00:00:00';

    I replaced it with:

    $post_date_gmt = current_time('mysql');

    and I did not have any further issues.

  25. madsrode
    Member
    Posted 2 years ago #

    I case that anyone still should have trouble with this, I found a solution that worked for me.

    My setup was moving a blog from one to another using the export/import function. But after importing on the new site i got the message "You are not allowed to edit this post" when I tried to do a new post.

    The solution was to, instead of creating the user from the old database in the wizard, I created them before I started the import and all had admin rights.

    I hope this can help :-)

  26. hartho
    Member
    Posted 2 years ago #

    After a few hours looking into this problem, I found out that the import of the pre-production database onto the real production site, didn't restore the table structure properly! It missed the auto increment flags (which is the thing that causes this error), and it didn't restore the proper collation setting.

    I made the settings equal for all 11 tables to the pre-production database that I'd still running on my local NAS and problem solved :)!

Topic Closed

This topic has been closed to new replies.

About this Topic