WordPress.org

Ready to get started?Download WordPress

Forums

Yoast "WordPress SEO" Plugin not Paginating Posts using Shortcode (2 posts)

  1. kernmedia
    Member
    Posted 1 year ago #

    Howdy all...I was reading this previous support thread (http://wordpress.org/support/topic/plugin-wordpress-seo-by-yoast-warning-duplicate-meta-descriptions-and-title-tags-when-paginating) but I'm still having the problem of Posts (with <!-nextpage-> short code) not having the page number appended to the meta title. Here's how my Post meta titles are formatted in the Yoast plugin:

    %%title%% %%page%% %%sep%% %%sitename%%

    Should be fine. Also, I have the "Force rewrite titles" checkbox checked. I tried unchecking that and it didn't have an impact.

    Here is an example URL that our company is having trouble with: http://www.gundigest.com/optics-reviews-articles/handgun-hunting-choosing-scopes-and-sights/2

    We are on WordPress 3.5.1 and the WordPress SEO plugin is version 1.4.3.

    Lastly, thanks to Yoast for providing an incredible plugin for us all to use. We really do all owe him big time. I am certainly not complaining in this suppor thread, just looking for a solution.

  2. kernmedia
    Member
    Posted 1 year ago #

    I just found a Post on this same site that is not having this issue. Page # is showing up in the meta title. http://www.gundigest.com/reloading-handloading-articles-advice/brass-basics-case-selection-and-prep-2/2

    The difference?

    First example - http://www.gundigest.com/optics-reviews-articles/handgun-hunting-choosing-scopes-and-sights/2
    We have defined a custom meta title for this post.

    Second example - http://www.gundigest.com/reloading-handloading-articles-advice/brass-basics-case-selection-and-prep-2/2
    We have not defined a custom meta title for this post.

    So, it seems that Page # will not appear in the meta title when a custom meta title is written, even though the Post meta title settings are set as follows:

    %%title%% %%page%% %%sep%% %%sitename%%

    My question for Joost is why can't %%title%% pull in the custom meta title that we wrote? Why does this entire setting get ignored and only the custom meta title is provided. Note: It's not the fact that I have "Force Rewrite Titles" checked since I unchecked that and nothing changed.

Topic Closed

This topic has been closed to new replies.

About this Topic