WordPress.org

Ready to get started?Download WordPress

Forums

WordPress SEO by Yoast
[closed] Yoast WordPress SEO Plugin DOES NOT WORK! (29 posts)

  1. homeispalosverdes
    Member
    Posted 1 year ago #

    Yoast SEO WordPress plugin does not work CRAP!!!!!!!!!!!!!!!!!

    Should have backed up older version of wordpress.

    why do i continue to update stuff that is just fine and then get screwed in the process

    So the specifics are that the plugin does not "appear" when I'm creating or editing a post or page.

    http://wordpress.org/extend/plugins/wordpress-seo/

  2. Safari-Mark
    Member
    Posted 1 year ago #

    Had the same problem and it was one of my plugins that was causing it. De-activated that plugin and it works like normal.

  3. Joost de Valk
    Member
    Plugin Author

    Posted 1 year ago #

    Check Display settings in the top right of your edit screen, could just be that the WordPress SEO box is disabled there.

  4. milasking
    Member
    Posted 1 year ago #

    I de-activated all my plugins, re-activited the wordpress SEO and the bar appears in the post dashboard but will not reveal anything. HELP... not working (wordpress 3.5). Glad this is the 1st site I upgraded to 3.5...

  5. milasking
    Member
    Posted 1 year ago #

    also tried going to your developers page and download that version, still does not work

  6. homeispalosverdes
    Member
    Posted 1 year ago #

    Nothing works. Media button, nothing. version 3.5 is broken

  7. hassantariq
    Member
    Posted 1 year ago #

    Not working for me as well. Even when I click on the SCREEN OPTIONS it doesn't show anything :/ Don't like this WordPress 3.5 and even I didn't backed up any thing before updating. My mistake.

  8. aliosha75
    Member
    Posted 1 year ago #

    Hi,
    I noticed the same thing, yoast plugin doesn't work since i made the 3.5 wordpress upgrade.
    I noticed that options became visible if i disable these css with Firebug :

    .wpseotab {
    display: none;
    }
    ul.wpseo-metabox-tabs {
    display: none;
    }
    But i don't understand why.
    There is also a javascript problem i guess.
    I hope it can be helpful.

  9. megawebspace
    Member
    Posted 1 year ago #

    this is exactely what i discovered with WordPress 3.5
    Disabeling these css rules will display the WordPress SEO Options.

    What I do not understand is why not everyone is having this problem.

  10. gooma2
    Member
    Posted 1 year ago #

    Hey megawebspace, I think many of us have noticed very different results with the WP 3.5 update.

    Since there are so many different themes and plugins we all use they react differently so not everyone will have the same issues going on.

  11. heimana
    Member
    Posted 1 year ago #

    Got same problem, and since I'm using Photocrati as cover theme, on the home page it only shows the photocrati block and not the gallery! And more, the website is soooo slow...
    Desactivate it, desinstalled but still got crap!

  12. guitarsuperman23
    Member
    Posted 1 year ago #

    LOVE this plugin by the way, But it is not workign....

    For some reason, I can't toggle ANYTHING on my wordpress.

    For instance, I go onto a page to edit, I see the WordPress YOAST section, but it is not dropping down the menu to edit titles, etc.

    It worked before, so all of my pages are good, but I wanted to add a new page and now it doesn't allow me to do anything as far as page/post by page/post basis.

    Please advise what I should do!

    My site is http://elawsuitloans.com

  13. KentAjans
    Member
    Posted 1 year ago #

    Is there any solution for that? Same problem here, you can toggle but nothing show (all set display:none)

    And pretty sure its not about other plug-ins cause nothing added newly

    Thanks

  14. threelittlefish
    Member
    Posted 1 year ago #

    I am having the same issue, the bar appears but will not drop down.

  15. Veseloops
    Member
    Posted 1 year ago #

    Same problem here, any solution?

  16. rayman813
    Member
    Posted 1 year ago #

    The problem is that you have a javascript error in the admin panel. The SEO plugin loads after everything else, so if there is an error in a script somewhere the javascript that makes the tabs display doesn't run. Find the file that is causing the error and comment the erroneous line out and it should work. (You then have to fix the error :P )

  17. Veseloops
    Member
    Posted 1 year ago #

    And how can we know what is the file causing the error?
    anyone solve the problem?

  18. nelisseos
    Member
    Posted 1 year ago #

    I'm having a similar issue with my website http://www.humbletravels.com

    Their is no drop down box in my post and when I click the SEO check button their is no action.

    What can I do to fix this?

  19. macmonkeymark
    Member
    Posted 1 year ago #

    I just had this problem. I isolated it to a snippet of deferred javascript code that I'd just put in my child theme's functions.php file. Took it out and it was all fine.

  20. westerdaled
    Member
    Posted 1 year ago #

    Hi yep i have the same issue on my Genesis powered blog. Is there a definitive fix for this.
    Currently, we have override the CSS wp-content/plugins/wordpress-seo/css/metabox-tabs.css?ver=3.6 . through firebug or jetpack CSS edit?
    In both cases you remove display: none; as described by aliosha75 in the comments above.

    I would have thought Joost would have applied a fix to his excellent plugin by now, or am I missing something ;-0

  21. jrf
    Member
    Posted 1 year ago #

    The problem is that you have a javascript error in the admin panel. The SEO plugin loads after everything else, so if there is an error in a script somewhere the javascript that makes the tabs display doesn't run. Find the file that is causing the error and comment the erroneous line out and it should work. (You then have to fix the error :P )

    Rayman813 is right. There will be a javascript error caused by a theme or plugin (not WP SEO). Fix that and the WP SEO Metabox will work as expected.

    Don't blame a plugin for the errors of other plugins/themes.

  22. westerdaled
    Member
    Posted 12 months ago #

    jrf

    Thanks for correcting me. I was coming around to thinking it wasn't the Yoast plugin as it is regularly updated. Since, this issue is common it looks like we are all using the plugin with the bug. I don't suppose any of us of have the time to disable and enable each plugin we use individually .....

  23. jrf
    Member
    Posted 12 months ago #

    Well, you may not all be using the same buggy plugin, there are - unfortunately - lots of buggy plugins around, so this can happen with a number of plugin combinations.

  24. astrasuite
    Member
    Posted 12 months ago #

    Install Plugin Organizer, then it will be easy to activate/deactivate plugins from within a post or page. But it's main contribution is to optimize your system by not loading plugins that are not needed (normally, plugins are loaded even if not used, making the system slower). This is the plugin I will install first above all, the best.

  25. hilmil
    Member
    Posted 11 months ago #

    Are there any compatibility issues with WP 3.6 ? The plugin is not working properly. I see SEO Screen Options when I edit Pages, but not Posts. Even so, correcting suggested copy and key phrases, does not improve my SEO rating - stays yellow.

  26. westerdaled
    Member
    Posted 11 months ago #

    astrasuite,

    Good tip re Plugin Organizer. As for compatibility issues with 3.6 all I know is the issue with missing post Yoast settings panel which can be easily remedied with the suggestions above ( edit theme styles or change in Firebug).

  27. antheathomas
    Member
    Posted 11 months ago #

    I'm totally confused and a novice. Where do I go to see if there is a javascript error, and how do I fix it. I need some phone support, can anyone suggest someone, or how I get that?

  28. jrf
    Member
    Posted 11 months ago #

    @antheathomas - go to the javascript console to see the error. You should be able to find it via one of the menus of your web browser, can't tell you exactly where as that depends on your browser.
    Alternatively install the excellent Firebug plugin which is available for most browsers and will give you even more extensive debugging information.

    Also, presuming you're willing to pay for support, you can post a request for someone to help you at http://jobs.wordpress.net/

  29. antheathomas
    Member
    Posted 11 months ago #

    Thanks so much for your reply @jrf - I have found the javascript, and can see some errors in red, but have no idea what they mean!

    A firebug plugin is a great idea, so I'll look into that.

    I'm more than happy to pay for someone to help, as I'd prefer it to be sorted out by a professional. I'll contact the link you sent me.

    Thanks again, I really appreciate you sending me in the right direction.

    Cheers........Anthea

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic