WordPress.org

Ready to get started?Download WordPress

Forums

WordPress SEO by Yoast
Yoast titles and meta help (3 posts)

  1. sportsbets4free
    Member
    Posted 1 year ago #

    WordPress version:3.4.2
    WordPress SEO version: Latest

    I did this: installed it

    I expected the plugin to do this: show the page title

    Instead it did this: shows the title and website name

    Hi, can someone tell me which combination i need to display just the SEO Title in search results? Surely is it just %%title%%?

    Currently i have - %%title%% but it shows the title and the website name like below -

    bet365 Android App - Download bet365 App For Android Today!Sports Bets For Free

    http://www.sportsbets4free.co.uk/home-2/mobile-betting-apps/android-betting-apps/bet-365-android-app/

    Thanks

    http://wordpress.org/extend/plugins/wordpress-seo/

  2. kevin heath
    Member
    Posted 1 year ago #

    Hi

    Check your theme header file. You'll probably find that your theme is automatically inserting the site name at the end of the title.

    to check just turn off the yoast plugin and reload the page. you;ll probably find the site name still being called by the theme.

    Kevin

  3. sarthaksinghal
    Member
    Posted 1 year ago #

    The below code is from the default Twenty Eleven Theme and you will run into the issue here also. See the code below which worked for me to resolve it.

    <title><?php
    	/*
    	 * Print the <title> tag based on what is being viewed.
    	 */
    	global $page, $paged;
    
    	wp_title( '|', true, 'right' );
    
    	// Add the blog name.
    	bloginfo( 'name' );
    
    	// Add the blog description for the home/front page.
    	$site_description = get_bloginfo( 'description', 'display' );
    	if ( $site_description && ( is_home() || is_front_page() ) )
    		echo " | $site_description";
    
    	// Add a page number if necessary:
    	if ( $paged >= 2 || $page >= 2 )
    		echo ' | ' . sprintf( __( 'Page %s', 'twentyeleven' ), max( $paged, $page ) );
    
    	?></title>

    Code which resolved the issue. If you look at the comments, the Name and Description related things have been removed below. It works what you enter in the meta settings of Yoast.

    <title><?php
    	/*
    	 * Print the <title> tag based on what is being viewed.
    	 */
    	global $page, $paged;
    	wp_title( '|', true, 'right' );
    
    	// Add a page number if necessary:
    	if ( $paged >= 2 || $page >= 2 )
    		echo ' | ' . sprintf( __( 'Page %s', 'twentyeleven' ), max( $paged, $page ) );
    
    	?></title>

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic