WordPress.org

Ready to get started?Download WordPress

Forums

WordPress SEO by Yoast
Yoast SEO adding %% symbols before & after logo (10 posts)

  1. dice2dice
    Member
    Posted 1 year ago #

    Hi guys,

    The WordPress plugin is causing my site name to be displayed with 2 '%%' symbols before and after the name.

    Another user of my theme (Made Theme) identified an issue with the plugin and suggested a resolution which I have enacted but it hasn't resolved all of the issues though it has resolved some.
    When I deactivate the plugin the error goes away.

    This is my reported SEO error:
    Title is too long, it's more than 70 chars!
    title (86 chars, 16 too long)
    %%www.whichinvestmenttrust.com%% » The Independent Investment Trust Analyst

    Below is an issue someone else identified and resolved:
    Re: Yoast SEO

    Postby JackYu » Wed Sep 19, 2012 7:39 pm
    In my eyes, Yoast is still the most awesome SEO plugin that I don't want to miss. Getting this to work is actually no big deal:

    Yoast hooks into wp_title() with a filter to change it and include SEO features. The Theme however, already includes a rather complex way to generate a title based on your sub-page. All you need to do is change:

    <title>
    <?php //Print the <title> tag based on what is being viewed
    global $page, $paged;
    wp_title( '|', true, 'right' );
    // Add the blog name.
    bloginfo( 'name' );
    // Add the blog description for the home/front page.
    $site_description = get_bloginfo( 'description', 'display' );
    if ( $site_description && ( is_home() || is_front_page() ) ) echo " | $site_description";
    // Add a page number if necessary:
    if ( $paged >= 2 || $page >= 2 ) echo ' | ' . sprintf( __( 'Page %s', 'made' ), max( $paged, $page ) );
    ?>
    </title>

    towards:

    <title>
    <?php wp_title( '|', true, 'right' );
    ?>
    </title>

    [Please post code & markup between backticks or use the code button. Your posted code may now have been permanently damaged by the forum's parser.]

    This just replaces the made theme functionality with the standard WP function and leaves the rest to Yoast.
    End

    If you have any ideas or suggestions I'd love to know?

    Many thanks

    http://wordpress.org/extend/plugins/wordpress-seo/

  2. dice2dice
    Member
    Posted 1 year ago #

    If I can't fix my issue with Yoast SEO can anyone suggest an alternative SEO solution? Another Pluggin perhaps?

    Thanks, Dice

  3. jrf
    Member
    Posted 1 year ago #

    A link would help....
    Also: it's quite unclear from your post what the "issue someone else identified and resolved" has to do with your current problem...

  4. mbrsolution
    Member
    Posted 1 year ago #

    Hi @dice2dice, I had a look at your URL and it appears that you have two space at the very top on your home page. Maybe that is causing some of your problems. That might fix your %% issue.

    Kind regards

  5. hhtmp88
    Member
    Posted 1 year ago #

    Hi dice2dice!

    I have not use any seo plugs, but simply do some simple setup in the admin panel, here is what I do:
    -> go "Settings"
    -> then "Permanlinks"
    -> select "Custom Structure"
    -> enter the URL format that you like, e.g "%post_id%-%postname%/"
    -> That's it!

    Hope this help!

  6. mbrsolution
    Member
    Posted 1 year ago #

    I agree with @hhtmp88, your permalink structure might be wrong. This would definitely cause your %% issue on your title.

    Kind regards

  7. jrf
    Member
    Posted 1 year ago #

    @mbrsolution and @hhtmp88 - the user is asking about the page **title**, not about the permalink structure....

    @dice2dice - check what you have set under SEO -> Titles and Meta -> Home tab -> Title template field.

  8. dice2dice
    Member
    Posted 1 year ago #

    Thank you to you all for responding.

    It is very kindly appreciated.

    Unfortunately my site was highjacked and I was unable to access the back end of it for several days. Thant issue is now resolved thankfully.

    I have tried the suggestions for resolving my %% error such as the suggested solution by @hhtmp88. It hasn't worked.

    My permalink structure is set to post name. E.g "http://www.whichinvestmenttrust.com/sample-post/"

    Thank you once again to @hhtmp88 @mbrsolution @jrf for you help.

  9. dice2dice
    Member
    Posted 1 year ago #

    @jrf Under Title template in the location you described I have the following which looks to me like it is the source of the unloved '%%' symbols but it also has more content/words that is displayed. I am unsure if I should delete all but the site name.

    This is pasted directly from 'Title template:'
    %%www.whichinvestmenttrust.com%% %%page%% %%sep%% %%sitedesc%%

  10. jrf
    Member
    Posted 1 year ago #

    %%www.whichinvestmenttrust.com%% %%page%% %%sep%% %%sitedesc%%

    @dice2dice Yup! That's the cause of the problem.
    If you look at the Help tab on that same page, you can see what the available variables are.

    • %%page%%
    • %%sep%%
    • %%sitedesc%%

    are all WP SEO replaceable variables - you can see on the help page what they will be replaced by.

    • %%www.whichinvestmenttrust.com%%

    is not a WP SEO variable and so will be taken literally, percent signs and all.

    So if you want www.whichinvestmenttrust.com to be in title, just have it in the template as a literal, i.e. without the percent signs.

    All in all, there is nothing wrong with WP SEO in this case, I'm sorry to say, but it's just you doing it wrong....

    Smile,
    Juliette

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic