WordPress.org

Ready to get started?Download WordPress

Forums

WordPress SEO by Yoast
Yoast Not Working on Blog Posts (19 posts)

  1. prospectfgi
    Member
    Posted 1 year ago #

    Hello,

    Today the Yoast widget is no longer working on my blog posts. It appears underneath the post area, but the is no longer an area for me to set the focus keyword, meta title, etc. The plgin have not been deactivated or touched in any way. Any suggestions as to how to resolve this?

    Thank you

    http://wordpress.org/extend/plugins/wordpress-seo/

  2. prospectfgi
    Member
    Posted 1 year ago #

    I have tried deactivating the plugin and then reactivating it, but still no luck...

  3. Andy Ward
    Member
    Posted 1 year ago #

    I am having a similar problem. It works as normal on pages but doesn't appear anywhere for blog posts.
    I have deactivated the plugin, rolled back to a previous version, deactivated all plugins etc and nothing has worked so far. I just cannot get the plugin working again.
    Really frustrating as I have replaced several plugins (xml sitemap, robots etc) with this one and now face having to deactivate this and set up several different plugins again as well as finding a way of transferring the SEO data for each post to a new SEO plugin...

  4. prospectfgi
    Member
    Posted 1 year ago #

    I am also having a problem with scheduling the blog posts that occurred at the same time. The edit link is there, but I cannot seem to click on it and change the scheduled time of the post - I don't know if you are experiencing this problem as well?

  5. Andy Ward
    Member
    Posted 1 year ago #

    I haven't tried scheduling blog posts so dont know.
    When I am looking at blog posts the only thing that shows that WP SEO is installed is the small colored circle indicating how good the SEO is - that's it though. No menus to actually fill in the details or anything. When I click on "posts" to display all posts there are no columns anymore showing SEO although there is still the option in the drop sown menu to select which posts to show - those with good seo / bad seo / no seo etc.
    Just seems like the menus are for some reason missing for all blog posts....

  6. prospectfgi
    Member
    Posted 1 year ago #

    When I am adding a new blog post I see WordPress SEO by Yoast section underneath the posting area, however there is no longer anything underneath it to allow me to set the SEO. I have tried clicking on the title to expand the box by clicking on it, but nothing happens. I still see the colored circle in the upper right of the page, however it is grey as I cannot set the SEO.

    I have installed another plugin for the time being - All In One SEO Pack - which has allowed me to set the title and meta tags for new posts for the time being.

    I am hoping to find a way to get Yoast functioning properly again, as I have used that for all pages on my site and like how it indicates the level of the SEO...

  7. Andy Ward
    Member
    Posted 1 year ago #

    Yoast fixed this for me - really, really simple fix:
    Go
    WP SEO settings
    Titles and Meta
    Post types
    and uncheck "Hide" under WordPress SEO meta box

    Spent hours on this, he fixed in about 8 seconds :)
    Much appreciated Yoast!

  8. lorissa
    Member
    Posted 1 year ago #

    I tried that solution, but when I go to "Titles and Meta" under the SEO settings, I don't see any options at all. There is no content, other than the right hand column with the support, "Spread the Word" and latest news boxes. The tabs at the top, "General", "Home", etc. don't do anything either.

    Any ideas?

  9. prospectfgi
    Member
    Posted 1 year ago #

    I looked into that as well and "Hide" was not checked in that section. Tried re-saving the setting with "Hide" unchecked as well and not luck.

    Any other suggestions on how to resolve this issue?

    Thank you!

  10. RoamFree
    Member
    Posted 1 year ago #

    Some of the phrasing is not what I would use, so I'm not sure if everyone has been using the general WordPress navigation tools.

    • When editing a blog entry, in the upper right corner is a "Screen Options" tab. You can select whether to hide the editing widgets. If the Yoast SEO widget is not visible, make it visible.
    • If only the SEO widget title is visible, move the mouse to the far right of the gray bar which has the widget title, and an arrow icon should appear which makes the widget expand.

    WordPress has a habit of only making some tools pop up when you hover over a part of the screen. I don't know how it works on a touchscreen (where you can't hover).

  11. prospectfgi
    Member
    Posted 1 year ago #

    Under the screen options tab Yoast is checked. Yoast appears under the content area for the blog entry, however when I click on the arrow to make it expand nothing happens - only the WordPress SEO by Yoast title appears.

  12. Dustin
    Member
    Posted 1 year ago #

    I am having the same issue as prospectfgi. The title area for the SEO plugin appears on the page but none of the boxes to enter text are there. It looks collapsed and if you click the expand arrow nothing happens.

  13. smitchio
    Member
    Posted 1 year ago #

    Hello
    I am having the same issue. I can see the 'WordPress SEO by Yoast' on each page but clicking on it to expand it does nothing.
    I would be really grateful if somebody could help out as I have spent a really long time on this with no luck.
    Thanks very much.

  14. smitchio
    Member
    Posted 1 year ago #

    Hello
    I am having the same issue. I can see the 'WordPress SEO by Yoast' on each page but clicking on it to expand it does nothing.
    I would be really grateful if somebody could help out as I have spent a really long time on this with no luck.
    Thanks very much.

  15. PeterParkorr
    Member
    Posted 1 year ago #

    I am also having 'this problem' but I think it is a problem with 3.5, not Yoast SEO. I also can't edit post permalinks, show the screen options tab when editing a post, add media or anything else. So the Yoast SEO plugin is not displaying because wordpress itself is having a problem.

    It is probably being covered on the 3.5 master list;
    http://wordpress.org/support/topic/troubleshooting-wordpress-35-master-list?replies=4

  16. PeterParkorr
    Member
    Posted 1 year ago #

    It's most probably a plugin or any jQuery stuff built into your theme. Check your plugins and themes for updates from the developers, and see the master list for known problems and fixes. A theme update from the developer fixed this issue for me.

  17. Dustin
    Member
    Posted 1 year ago #

    I use the Magic Fields plugin and thought it was the source of my problem because it was also acting erratically. I use Cloudflare to speed up my site and it turns out that it was causing 502 errors on random files that were preventing Magic Fields from working properly which in turn was causing WP SEO to act strange. Interestingly the problem only happened from my work IP address, everything worked fine from home. Cloudflare support has yet to answer my support request. . .

  18. PeterParkorr
    Member
    Posted 1 year ago #

    Prospectfgi,

    You should mark this thread resolved.

    PP

  19. jymber
    Member
    Posted 11 months ago #

    We couldn't see the "WordPress SEO by Yoast" under Screen Options on Posts either (although it was ok for Pages). We also confirmed that "Hide" was not checked under the WordPress SEO meta box for Posts.

    Here are the steps that worked for us to make it visible:
    1. Upgraded the plug-in to Version 1.4.13 (using 3.5.1 of WP)
    2. Deactivated and reactivated the SEO plug-in
    3. Under the SEO Plugin under Plugins, went to Settings
    4. From here, just clicked Reset Default Settings and it magically appeared

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.