WordPress.org

Ready to get started?Download WordPress

Forums

yet another establishing db error (8 posts)

  1. Anonymous
    Unregistered
    Posted 9 years ago #

    ive been through all the docs and i cant figure out why im getting the standard "Error establishing a database connection!" error when i try and run wp-admin/install.php. ive made sure my sql db is alive and responding (using mysqlcc and mysql admin, not a cpanel), ive given my wordpress user complete privs to the wordpress db and even tried connect as root. i dont get it, mysql is responding (seeing as how i can get and set anything using mysqlcc) and mysqld is running...
    any clues?

  2. NuclearMoose
    Member
    Posted 9 years ago #

    How about some more specs...what version of MySQL and PHP? What server are you using? IIS or Apache or ??. Is this hosted or your own local server? Have you edited wp-config.php properly?

  3. Anonymous
    Unregistered
    Posted 9 years ago #

    Try this, I am having the same problem. Will try this out : http://codex.wordpress.org/Answers-Installation

  4. viperstyx
    Member
    Posted 9 years ago #

    wow thats really lame. ill have to try that tomorrow. anyone have a clue WHY the latest version of mysql doesnt work with wordpress?

  5. Mark (podz)
    Support Maven
    Posted 9 years ago #

    A lot of IIS post problems have been resolved when the user ran something that allowed php to talk to mysql properly. Both look like they are working, but they are ignoring each other until this 'thing' is run. Not being an IIS user (and not having copied a thread location) I can't tell you right now what it could be.
    I'll search if you will too :)

  6. Mark (podz)
    Support Maven
    Posted 9 years ago #

  7. viperstyx
    Member
    Posted 9 years ago #

    awesome, that last link gives a great explination. thanks! between podz and anon i think i can get everything working now =]

  8. viperstyx
    Member
    Posted 9 years ago #

    well, the following worked.
    because im using mysql 4.1 i had to force mysql to use the old password function for setting my wp user pass:
    mysql> SET PASSWORD FOR
    -> user @ localhost = OLD_PASSWORD("password");

    the white space on either side of the @ should be removed.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.