WordPress.org

Ready to get started?Download WordPress

Forums

(yet another) database error (9 posts)

  1. mrsnrub143
    Member
    Posted 6 years ago #

    I just tried to upgrade to the latest version of WordPress.

    After installation, I ran the:

    http://mysite.com/wordpress/wp-admin/setup-config.php

    and it told me that there was no "wp-config.php" file. So it gave me the option of creating a new one via online. So I entered the MySql information and it created a file.

    Then I recall it told me I had to "empty tables". I ignored this because I did not know what it meant.

    I then realized that I had entered in the wrong information (used: p50mysql1.secureserver.net instead of "localhost"). I called my hosting company (godaddy) and they gave me the correct information.

    I went ahead and re-edited the "wp-config.php" file and uploaded it to the wp-admin folder.

    I just re-deleted the wp-config file....

    and still there is a database error. Can anyone help me?

    thanks

    I am still getting a "Error establishing a database connection" message.

  2. mrsnrub143
    Member
    Posted 6 years ago #

    I am currently stuck on this message:

    Error establishing a database connection
    
    This either means that the username and password information in your wp-config.php file is incorrect or we can't contact the database server at p50mysql1.secureserver.net. This could mean your host's database server is down.
    
        * Are you sure you have the correct username and password?
        * Are you sure that you have typed the correct hostname?
        * Are you sure that the database server is running?

    The only problem is, is that I deleted the wp-config.php file and I don't understand why WordPress still thinks that "p50mysql1.secureserver.net" is a valid database name.....

  3. michaelb123
    Member
    Posted 6 years ago #

      you could not have replaced that file.

    1. always FIRST copy the original file as {name.ext}.ori (or similar}
    2. goto the wordpress start page /admin so that the database can be set up correctly IF you havent already done so
    3. delete the file wp-config file
    4. attempt to open your site again and hope you get an error message that may indicate this file is missing
    5. from a new copy of wp-config, enter the correct un,pw,database name, location. BE CAREFUL to keep your punctuation correct
    6. save the file
    7. now see if site comes up (use correct pathing according to how you installed it)

    that should do it. if it is still messed up, you may have a database issue. you can always re-install and remove the database and start over.

    i am not a coder with wp. if my 'advice' is not correct, feel free to correct me.

  4. mrsnrub143
    Member
    Posted 6 years ago #

    Ok update.

    I read through some older threads on here and figured out I was putting the config.php in the wrong folder.

    I re-upped it to the right directory, but now do not know the correct addres of the database server for Godaddy.

    Godaddy account panel is telling me that "p50mysql1.secureserver.net" is the right address, but WordPress is rejecting it.

    Any suggestions?

    "localhost" wont work....
    "p50mysql1.secureserver.net" wont work either.

  5. mrsnrub143
    Member
    Posted 6 years ago #

    Update:

    I finally got it to work....but when it finally did load, all of my content (going all the way back to 8 months ago when I started the blog)
    is gone.

    How do I get my old content back? I made backups of the site, but am not sure which folders to upload...

  6. mrsnrub143
    Member
    Posted 6 years ago #

    Is all of my posts stored on the Mysql part of the server? I already cleared those tables....

    I think I accidentally deleted my entire site...

  7. michaelb123
    Member
    Posted 6 years ago #

    all your posts are in the mysql database. never delete an already used and working database. backups of a site are NOT the same as backups for a database!

    I already cleared those tables....

    I think I accidentally deleted my entire site...

    huh?

    1. never work on a site when you at all tired, distractable or lack sufficient food or sleep
    2. if you are running a commercial or important site, alwats backup the database- never host where you cannot back it up

    godaddy may have database backups. ask.
    define('DB_NAME', '{WHATEVER}');// The NAME of the database
    define('DB_USER', 'yourloginname'); // Your MySQL username
    define('DB_PASSWORD', 'password'); // ...and password
    define('DB_HOST', 'p50mysql1.secureserver.net'); // THIS SHOULD WORK! why? godad may not have the db on the same server!

    as you have an existing database, you could check your code by creating another database and setting it up (/admin) then, if that works, change your wp-config to your previous database.

  8. mrsnrub143
    Member
    Posted 6 years ago #

    1. I just moved into a new place and am exhausted.

    You hit that one right on the head.

    Oh well...8 months of work down the drain. Luckily it wasn't an important site. But still....

  9. michaelb123
    Member
    Posted 6 years ago #

    usually the database is elsewhere and deleting your site may NOT remove the tables. check with godaddy.

Topic Closed

This topic has been closed to new replies.

About this Topic