WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] [closed] Yet Another Admin White Screen of Death Post (3 posts)

  1. tallreed
    Member
    Posted 1 year ago #

    I'm at the shoot-myself-in-the-head stage with this issue.

    The problem started when I was playing with cache plugins. I had used WP-Cache for a long time and thought I'd upgrade, trying Hyper Cache and W3 Total I believe. First my blog was garble and then when I tried manually removing the Cache plugin files and code only the admin side white screen of death remained. I get the login screen. Use proper password get white screen, improper password get improper password screen.

    I've tried all the suggestions from frikafrax's post (e.g. re-installed WP, looked for blank spaces, disabled plugins):

    I finally resorted to frikafrax's solution to recreate an entirely new WordPress site. Bizarrely the same problem occurs with a completely new WP site with no plugins, no changed theme, when I upload the MySQL database back-up (from WP-DB-Backup) from a month ago. This is confounding because the white screen of death only appeared days ago when I did the cache plugin dance. I'm at a loss as to how the database flaw is in such an old backup.

    My error log (thanks govpatel) is as follows:

    Notice: Constant ABSPATH already defined in /home2/suburrac/public_html/blog/wp-config.php on line 19
    
    Warning: include(/home2/suburrac/public_html/blog/wp-content/advanced-cache.php) [function.include]: failed to open stream: No such file or directory in /home2/suburrac/public_html/blog/wp-settings.php on line 62
    
    Warning: include() [function.include]: Failed opening '/home2/suburrac/public_html/blog/wp-content/advanced-cache.php' for inclusion (include_path='.:/usr/lib64/php:/usr/lib/php') in /home2/suburrac/public_html/blog/wp-settings.php on line 62
    
    Notice: add_option was called with an argument that is deprecated since version 2.3 with no alternative available. in /home2/suburrac/public_html/blog/wp-includes/functions.php on line 3553
    
    Notice: Undefined property: s2_frontend::$s2_mu in /home2/suburrac/public_html/blog/wp-content/plugins/subscribe2/classes/class-s2-core.php on line 13
    
    Warning: Cannot modify header information - headers already sent by (output started at /home2/suburrac/public_html/blog/wp-config.php:3) in /home2/suburrac/public_html/blog/wp-login.php on line 349
    
    Warning: Cannot modify header information - headers already sent by (output started at /home2/suburrac/public_html/blog/wp-config.php:3) in /home2/suburrac/public_html/blog/wp-login.php on line 361
    
    Warning: Cannot modify header information - headers already sent by (output started at /home2/suburrac/public_html/blog/wp-config.php:3) in /home2/suburrac/public_html/blog/wp-includes/pluggable.php on line 669
    
    Warning: Cannot modify header information - headers already sent by (output started at /home2/suburrac/public_html/blog/wp-config.php:3) in /home2/suburrac/public_html/blog/wp-includes/pluggable.php on line 670
    
    Warning: Cannot modify header information - headers already sent by (output started at /home2/suburrac/public_html/blog/wp-config.php:3) in /home2/suburrac/public_html/blog/wp-includes/pluggable.php on line 671
    
    Warning: Cannot modify header information - headers already sent by (output started at /home2/suburrac/public_html/blog/wp-config.php:3) in /home2/suburrac/public_html/blog/wp-includes/pluggable.php on line 866

    As one can see it points to an error in line 62 of the wp-settings.php file. Line 62 reads:

    // For an advanced caching plugin to use. Uses a static drop-in because you would only want one.
    if ( WP_CACHE )
        WP_DEBUG ? include( WP_CONTENT_DIR . '/advanced-cache.php' ) : @include( WP_CONTENT_DIR . '/advanced-cache.php' );

    Any suggestions? Is there a way for me to restore my database backup table by table? I'm hoping that I can at least salvage my blog posts table at this point. I use Bluehost shared hosting.

  2. tallreed
    Member
    Posted 1 year ago #

    Finally figured out problem by myself. I get the Super Idiot hat on this one.

    I used govpatel's suggested error log code in frikafrax's post. Googled the error message "headers already sent" from a cleaned up version (removed WP-Cache refuse) and quickly was led to this link that clearly stated the problem.

    I had been misreading the error logs as to where the problematic file was - confusing problem code with victim code. Read link in previous paragraph.

    I had also been using Kompozer to edit wp-config file and Kompozer had been adding HTML to the beginning and end outside the <?PHPs. DON'T EDIT PHP FILES IN KOMPOZER.

  3. emcarnahan756
    Member
    Posted 11 months ago #

    I know you have resolved this, and my issue yesterday was with a different cache plug-in. I am just replying to post this general wisdom for dealing with the "white screen of death": I learned that from phpMyAdmin you can deactivate all your plugins at once, and get your WP admin back. Then reactivate as you wish. It is possible to rename the plugin folder, but this was compounding my problem -works locally but not when there was already a problem.

    Here is the tutorial I used — saved me manually reinstalling WP. Note that if you look at the code you may be able to just uninstall the cache plugin, or whichever is offending.

    One note of caveat from my case: I had two different plugins associated with my caching setup: It only worked when I activated and deactivate themd /together/. Good luck!

Topic Closed

This topic has been closed to new replies.

About this Topic