WordPress.org

Ready to get started?Download WordPress

Forums

Yet Another Related Posts Plugin (YARPP)
YARPP's "consider titles" and "consider bodies" not working (25 posts)

  1. Loiseau2nuit
    Member
    Posted 10 months ago #

    Hello there !

    I've been trying to set YARPP up for 2 days now and I'm facing a strange problem :

    YARPP's "consider titles" and "consider bodies" are appearing light gray, meaning that I can't set them as I want. Those 2 options are blocked on "Do not consider".

    In the meantime, I have an error message mentioning "YARPP's "consider titles" and "consider bodies" relatedness criteria require your wp_posts table to use the MyISAM storage engine, but the table seems to be using the 1 engine. .../... If, despite this check, you are sure that wp_posts is using the MyISAM engine, press this magic button:"

    Fact 1 : All my database is allready using MyISAM
    Fact 2 : Pressing the "magic button" does not change anything
    Fact 3 : Nor does the ALTER TABLE wp_posts ENGINE = MyISAM; command.

    As a consequence, on public side, not any single related posts is showing up under my articles.

    I don't know what to do.

    Thanks in advance for any help :-O

    http://wordpress.org/plugins/yet-another-related-posts-plugin/

  2. jeffparker
    Member
    Plugin Author

    Posted 10 months ago #

    One thing you might want to try is to completely reset YARPP's settings. Uninstall YARPP, then, in the wp_options table, find the options containing the word "yarpp" and delete those. Then, reinstall YARPP.

    Sorry this happened in the first place. Very soon, we'll have a clean uninstall process included with YARPP that should make the reinstall process easier.

  3. pema
    Member
    Posted 10 months ago #

    I am also having the same problem as Kelseo2nuit and i uninstall yarpp as you suggest in above post but i didn't find yarpp word in wp_options tables. I install it again and it didn't solve my problem. is there any other solution.

    Thanks

  4. pema
    Member
    Posted 10 months ago #

    I tried again today and it is working now. thank you for the great plugin.

  5. Loiseau2nuit
    Member
    Posted 10 months ago #

    Done this three times here and still K.O.

    Yarpp's still unable to realize that my database IS using MyISAM engine, Magic button still has no effect, options still not configurable and still no related posts displayed under my posts...

    I really don't know what to do ... :(

  6. Ahaenor
    Member
    Posted 10 months ago #

    Good day!

    I'm having a problem similar to Kelseo2nuit, but in my case "yarpp_relatedness" div is hidden right from the beginning (not just inactive). My WP is 3.6.1, YARPP is 4.0.7.

    After YARPP reinstallation the message about wp_posts not having MyISAM disappeared, but relatedness settings are still not available.

    Any help would be much appreciated.

  7. jeffparker
    Member
    Plugin Author

    Posted 10 months ago #

    Hi, Ahaenor. Are you seeing the "Relatedness options" checkbox in the "Screen options" panel at the very top of the YARPP settings page?

  8. Ahaenor
    Member
    Posted 10 months ago #

    Hi, jeffparker,

    no, it's hidden (display:none).

  9. Ahaenor
    Member
    Posted 10 months ago #

    It's div has both "hide-if-js" and "hide-if-no-js" css classes, both of them seems to give it "display:none" property.

  10. MusicalJournaal
    Member
    Posted 9 months ago #

    I have this issue every now and then, and it could always be solved by deleting all lines containing "YARPP" from wp_options. That still works, however, for the last couple of days, the issue "magically re-appears", even without any update or change in the WP configuration. For some reason, it will work for a couple of hours and after that, the "MyISAM" message appears again. This way, the YARPP plugin is too unstable to maintain.

  11. jeffparker
    Member
    Plugin Author

    Posted 9 months ago #

    Hi MusicalJournaal. The latest version of YARPP (4.0.7) has "clean uninstall" built in. You could try activating that version, then deactivating and deleting the plugin (to remove extraneous files and db lines), then reinstalling.

    This should take care of any remnant YARPP code.

  12. MusicalJournaal
    Member
    Posted 9 months ago #

    It helps in restoring the correct configuration, but after that, it again falls back (after some hours) to the "MyISAM" situation and I have to redo it all over again. I have to redo the configuration at least once every day.

  13. jeffparker
    Member
    Plugin Author

    Posted 9 months ago #

    When you say that it "falls back to the MyISAM situation," what messages do you see again?

  14. MusicalJournaal
    Member
    Posted 9 months ago #

    In the settings page of YARPP I get following message: "YARPP's "consider titles" and "consider bodies" relatedness criteria require your wp_posts table to use the MyISAM storage engine, but the table seems to be using the 1 engine. These two options have been disabled.
    To restore these features, please update your wp_posts table by executing the following SQL directive: ALTER TABLE wp_posts ENGINE = MyISAM; . No data will be erased by altering the table's engine, although there are performance implications.
    If, despite this check, you are sure that wp_posts is using the MyISAM engine, press this magic button:"

    I must do a complete reinstall of YARPP to fix that, because the magic button seems to have lost it's magic touch....

  15. Loiseau2nuit
    Member
    Posted 9 months ago #

    Same situation here. I4ve done many re-install since my last message but still not found any way to fix it :(

  16. MusicalJournaal
    Member
    Posted 9 months ago #

    I decided to deativate the plugin, since it's complete lack of stability. Settings get lost within hours after I reinstalled it. If this gets solved in a next version I will give it another try.

  17. jeffparker
    Member
    Plugin Author

    Posted 9 months ago #

    Sorry to hear, MusicalJournaal. To help us out, would you mind letting us know:

    • Your version of WordPress
    • Your theme
    • Your version of YARPP

    Also, if you're using phpmyadmin, there's a new version out that fixed some bugs. Thanks.

  18. MusicalJournaal
    Member
    Posted 9 months ago #

    My version of WordPress: 3.6.1
    Theme: Weaver II 2.0.1
    YARPP: 4.0.7 (in the meantime, I have updated to 4.0.8, but not yet re-activated)

  19. wpmnger
    Member
    Posted 9 months ago #

    Hi there,

    I did everything advised here and in similar posts:
    Convert posts table to MyISAM, clean out yarpp options, uninstall re-install etc...

    Now the "consider titles" and "consider bodies" don't even show up anymore. The first box is the 'Display options for your website'

    Is that supposed to happen?

    Thanks,

  20. jeffparker
    Member
    Plugin Author

    Posted 9 months ago #

    wpmnger, make sure the "Relatedness" box is checked in the very top "Screen options" section.

  21. Ahaenor
    Member
    Posted 9 months ago #

    jeffparker, i have a bingo! This last advice completely solved my problem.

    I've noticed that you've already telled me that, but i had not understood that it's about "that" screen options. It's very easy to not noticing of forgotting about this WP feature.

    Anyway, thank you very much.

  22. jeffparker
    Member
    Plugin Author

    Posted 9 months ago #

    Glad you found that section, Ahaenor! Now if anyone has info regarding the stability issue mentioned above, I'd appreciate it.

  23. wpmnger
    Member
    Posted 9 months ago #

    Can't believe I overlooked that!!!!!! rookie mistake.

  24. Ahaenor
    Member
    Posted 9 months ago #

    Yeah, it's just my thought ^^ It's almost fun - "if you want to hide something, place it just in a plain sight".

  25. rbaccaro
    Member
    Posted 14 hours ago #

    Hi,

    This was my solution:

    1) Uninstall and remove the plugin.

    2) Drop the indexes:

    ALTER TABLE wp_posts
    DROP INDEX yarpp_title,
    DROP INDEX yarpp_content;

    3) Download and reinstall the plugin.

    4) If the options to relate title and body do not show up, drop the indexes again, item 2 above.

    5) On plugin settings, run the ALTER TABLE to MyISAM.

    6) Done.

    If you still have problems, probably you need to run the query manually to create the indexes.

    The problem should be related to some sort of time out when installing the plugin for large database as ours, specially creating the indexes.

    BTW,

    I am still not seeing the YARPP Experiments, event looking to at the screen options tab.

    Any idea?

    Thank you for the plugin.

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.