WordPress.org

Ready to get started?Download WordPress

Forums

Yet Another Related Posts Plugin (YARPP)
[resolved] YARPP css is delayed or doesn't load (6 posts)

  1. xiabolai
    Member
    Posted 1 year ago #

    Hi,

    I LOVE the plugin and would like to use it but I'm having an issue with the css loading late or not at all. I think it's been reported before but I can't find the solution.

    When a post loads the related posts below at first look all out of line and the titles below are forced out of their boxes. Then, a split second later the related posts look fine. So, for the first second or so the css is not loading.

    My temporary solution is to put the entire YARPP css in my themes style.css, that's the only way the related posts look right on page load. Of course that's not a long-term solution as it's loading the CSS twice.

    Any ideas?

    Thanks!

    http://wordpress.org/extend/plugins/yet-another-related-posts-plugin/

  2. mitcho (Michael Yoshitaka Erlewine)
    Member
    Plugin Author

    Posted 1 year ago #

    Because the YARPP css should only be loaded if there are related posts on the page, the CSS is enqueued for display while the page is being written, and it will be called at the bottom of the page. In some cases (though not always) I should be able to check whether YARPP will be called on the page, and then enqueue that CSS at the top of the page instead... let me see if I can do that.

  3. mitcho (Michael Yoshitaka Erlewine)
    Member
    Plugin Author

    Posted 1 year ago #

  4. xiabolai
    Member
    Posted 1 year ago #

    Yes, that works perfectly!

    The "related posts" now look correct as the page is loading. And, I can see in the source code that on pages with "related posts" the 'yarpp-thumbnails-yarpp-thumbnail-css' is at the top of the header, but on pages without "related posts" the yarpp CSS is not being loaded.

    Awesome! Thanks for the great plugin and support.

  5. herrin
    Member
    Posted 1 year ago #

    Having the same issue (not loading CSS for thumbnails) with the latest release version. Using WP 3.5 and Twenty Twelve theme with no other plugins installed.

    Tried the beta 4 release and no love. Even tried a different theme (Twenty Eleven).

    WP 3.5
    OS Linux
    Server Apache
    PHP v5.2.17
    MYSQL v5.5.23-55

  6. mitcho (Michael Yoshitaka Erlewine)
    Member
    Plugin Author

    Posted 1 year ago #

    @herrin do you know if you're running any other plugins that might affect the loading of CSS? Some caching or "performance" plugins might do this.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.