WordPress.org

Ready to get started?Download WordPress

Forums

Yet Another Related Posts Plugin (YARPP)
YARPP appears on wrong place (11 posts)

  1. Sandal2013
    Member
    Posted 7 months ago #

    Hi,

    Thank you for great plugin.

    I have installed this plugin in the past and it works great. But recently I changed some parameters in settings page (for testing purpose) and back to the old settings again.
    But, sudenly, YARPP begin to display on front page, despite I have disabled option for showing it on front page. I check in Authomatic display Posts only.

    I have reinstalled the plugin, but in vain.

    This is big problem for me, as showing YARPP on frontpage broken my CSS and site concept.

    Thanks in advance and i hope you can answer me ASAP, as I want to keep this great plugin on my site.

    Regards,
    Sandal

    http://wordpress.org/plugins/yet-another-related-posts-plugin/

  2. jeffparker
    Member
    Plugin Author

    Posted 7 months ago #

    Try going to 'Settings' > YARPP related posts. At the top of the page, it says 'Automatically display'. Make sure 'Also display in archives' is not selected.

    If this doesn't work, try searching these WordPress support pages because this question has come up several times previously and other possible solutions are given.

  3. Sandal2013
    Member
    Posted 7 months ago #

    Thank you jeffparker,

    I have reading many instructions for fixing my issue and no one works for me.
    I think my issue is slightly different from any described in support posts.

    Yarpp worked fine on my site untill I changed some settings in Relatedness options and i probably in Display options. After I sew Yarpp shows on homepage, i switch to old (working) options and nothing has changed - it still appears in Homepage, despite I purge (and even disable) cache, despite I reinstall the plugin.

    I thing, maybe changing settings about not displaying in Pages and Archive pages didn't affect. Maybe it is database issue?

    Thanks in advance.

    [ Please do not bump, that's not permitted here. ]

  4. jeffparker
    Member
    Plugin Author

    Posted 7 months ago #

    Until you resolve this issue, you could add specific CSS code to hide the output on the home page.

    Please provide a link to your blog if you aren't sure of the CSS. Thanks.

  5. Sandal2013
    Member
    Posted 7 months ago #

    Thank you jeff,

    I have managed to hide the output on homepage, but this is not the right solution.
    Unfortunately, I can't publish URL of my site due to some reason.

    As plugin worked fine before I checked some options (later back to working settings) i suppose that the problem is because final changes don't take effect. Maybe this is database issue and I need to change some settings in DB?

    Hope you can help me.

    I have tested many related article plugins, but this is so far the best, and very smart.

    Best regards,
    Sandal

  6. jeffparker
    Member
    Plugin Author

    Posted 7 months ago #

    Glad you found a temporary solution and that YARPP is working for you! Perhaps with a reinstall, you'll see the posts disappear from the home page.

    I'm trying to find out from YARPP users how they heard about YARPP. Hope you'll let me know via this quick survey: http://www.surveymonkey.com/s/Z278L88

    Thanks!

  7. Sandal2013
    Member
    Posted 7 months ago #

    Hi jeff,

    I have submited survey.
    Also, reinstalled YARPP and the issue still persists :(

    Regards,
    Sandal

  8. jeffparker
    Member
    Plugin Author

    Posted 7 months ago #

    Sorry to hear. Is "Also display in Archives" checked?

  9. Sandal2013
    Member
    Posted 7 months ago #

    Hello jeff,

    "Also display in Archives" is not checked.
    At first YARPP worked fine, than I have checked "Also display in Archives", and, when I see it appears on homepage, i have unchecked it.
    But YARPP still appears on homepage.
    I am using static page as homepage.

    Sandal

  10. jeffparker
    Member
    Plugin Author

    Posted 7 months ago #

    Sandal2013, please review this thread and see if anything helps with your issue. It seems to be related:

    http://wordpress.org/support/topic/new-behavior-bad

    Thanks.

  11. Sandal2013
    Member
    Posted 7 months ago #

    Hi jeffparker,

    I am afraid I don't clearly understand wheather my issue is related to this link or not. But, I can confirm that my issue started to appear when I created a new Featured category from which iOS slideshow take featured posts or when I check "Display to archive page" (I am not sure when exactly started this issue, but I am sure that one of this two actions caused this issue (creating new Featured category or changin YARPP settings and switching them back).
    I am using Magazinly theme: http://themeforest.net/item/magazinly/full_screen_preview/4792747

    (iOS slider on homepage displays posts from featured category called Featured)

    I don't know this is important for resolving the issue or not.

    Also, i have installed this plugin, following the suggestions in this topic. But, this doesn't resolve my issue or I didn't understand what I need to do with this plugin. I have created a custom post type, but what I need to do whit this?

    Regards,
    Sandal

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.