WordPress.org

Ready to get started?Download WordPress

Forums

YAK for WordPress
YAK and Authorize.net issues (7 posts)

  1. PSSMike
    Member
    Posted 1 year ago #

    I'v installed YAK and the authorize.net plugin and I am having trouble getting it to work in test mode or even live. When I try and do a transaction it seems to work but I always get "My I'm Sorry your transaction didn't go through" message . The message I would expect to get if authorize.net had declined the transaction. However when I log into my authorize.net account to look at the activity none shows up. Normally when we use the authorize.net terminal even "decline" transactions show up. I've talked to authorize.net to see if there was some setting that need to be turned on or something and they said no, as long as I am using the ID and current Transaction Key of which I have checked several times. My site does have an SSL. I host with Godaddy.

    I'm using wordpress 3.5

    I am stuck please help.

    I love the idea of YAK for wordpress and really want it to work an willing to pay for support if needed.

    The test page is:
    http://web-tokens.com/store/HypnoticHaylee/?page_id=16

    Thanks in advance.

    http://wordpress.org/extend/plugins/yak-for-wordpress/

  2. nolongeractive
    Member
    Plugin Author

    Posted 1 year ago #

    The response from Auth.net is logged against the individual orders. If you go to the Orders page and check there, you should hopefully see something more useful...

  3. PSSMike
    Member
    Posted 1 year ago #

    Thanks for the response but that is just it, I do look at the order pages and nothing shows up in the "declined" list nor the "Settled" list.

    It's like the connection to authorize.net isn't happening.

    Is there a way I can verify that the link to authorize.net is happening and that for some reason authorize.net is not accepting it?

    Thanks for your time.

  4. PSSMike
    Member
    Posted 1 year ago #

    I'm sorry you meant the order page on YAK.. I do see it and the error is that my Authorize.net requires and "Invoice #" Can YAK generate an Invoice # ?

    Thanks again for your time.

  5. nolongeractive
    Member
    Plugin Author

    Posted 1 year ago #

    Can you post the exact text of the error message so I can look it up. I don't see this error in my testing.

  6. PSSMike
    Member
    Posted 1 year ago #

    Here you go..

    2013-01-21 10:12:43 An error occurred processing the Authorize.net transaction: Invoice Number is required.
    2013-01-21 10:12:43 response received from Authorize.net was: 3|2|33|Invoice Number is required.||P|0||Products|1.00|CC|auth_capture||||||||||||||||||||||||||7E166313F37A42AF3D9DD545024030CE|||||||||||||XXXX4718|Visa|||||||||||||||||1262946869|

  7. nolongeractive
    Member
    Plugin Author

    Posted 1 year ago #

    You've setup authorize.net to require an invoice number. Apparently this is something that can be changed in your authorize.net settings...

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic