WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Yahoo hosting, custom 404s and a 500 internal server error (7 posts)

  1. brittanie
    Member
    Posted 8 years ago #

    I am using the Relaxation 3-column theme, which comes with a custom 404 error page. I have also copied that page per Yahoo's instructions and placed it at the root of my site.

    When you attempt to access a non-existent url on my site, such as http://rulebrittaniea.org/error, you get the 404 page in my root directory. However, when you try to access a non-existent url that is in a directory below the root, such as http://rulebrittaniea.org/index.php/2006/02/20/error/, you get Yahoo's 500 error page.

    I just got off the phone with Yahoo's totally retarded customer service team, who told me that the custom error page is being redirected to the 500 page because of the index.php extension — the guy's exact words were that "There are certain parameters the error page looks for, but php does not have those parameters, so the custom error page fails."

    His suggestion was to get rid of the index.php extension on all my permalinks, but because Yahoo does not offer htaccess, this is the only way I can offer pretty permalinks (not to mention it is sort of a pain in the ass to change permalinks when you know people are linking to pages on your site).

    I don't buy the "php parameters" explaination, either, because if you use the search function to search for a bogus term, you get the correct 404 page, with the index.php extension in the url, like here: http://rulebrittaniea.org/index.php/?s=bogus.

    So, am I retarded, or is Yahoo?

  2. vkaryl
    Member
    Posted 8 years ago #

    I'm absolutely not going there....

    But to address your situation, what happens if you put a php.ini file in your folder and tweak settings through that? If you need an example one, I can post it at pastebin.

  3. brittanie
    Member
    Posted 8 years ago #

    From my quick research (I'm new to php and mostly only know the wordpress-specific stuff) I understand that this is a configuration file? I'd like to try this. It should be uploaded to my root, yes? I am unsure what would need to be tweaked to get it to work, though.

    I would appreciate your help.

  4. vkaryl
    Member
    Posted 8 years ago #

    You can actually upload php.ini to every folder, depending on what you're trying to effect (in my case, it was setting register_globals to "off" on a host who stupidly has them still set "on"....)

    First thing to do: copy the following lines to a file.

    <?php
    phpinfo();
    ?>

    Name the file phpinfo.php, upload it to your root folder, and navigate to it with your browser. This gives you a readout of everything in "working order" on your server as relates to php etc.

    You can do a CTRL A to select it all, then copy to a file and save as phpinfo.txt. Either send it to me at vkaryl *at* bytehaven *dot* com, or upload the content to http://pastebin.com, so I can see what all yahoo has maybe disabled - and until I look at that and do some research myself I'm not sure what would need to be tweaked either, but there's hopefully a way - and I know a couple of programmer gknurds who may be able to help.

    Do that stuff, and then we'll see where to go.

    Um.... is there a reason you don't WANT to ditch yahoo? Just as an idle curiosity question....

  5. brittanie
    Member
    Posted 8 years ago #

    I'm not sure — I have heard good and bad things about every hosting provider, and I also don't want to go through the hassle of switching right now. Maybe in the future. Yahoo's issues have been mostly minor for me, but occasionally they become really annoying.

    An e-mail will be forthcoming.

  6. vkaryl
    Member
    Posted 8 years ago #

    Well, I did some checking into this for brittanie. There's no way to do what she needs done using php.ini - since yahoo doesn't allow .htaccess customization, they equally do not allow use of php.ini.

    She's still checking with them for possible fixes.

  7. brittanie
    Member
    Posted 8 years ago #

    Well, I solved this problem by ditching yahoo for BlueHost.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags