WordPress.org

Ready to get started?Download WordPress

Forums

xmlrpc.php and Windows Live Writer Error (12 posts)

  1. heathj85
    Member
    Posted 5 years ago #

    I use Windows Live Writer to write posts to my blog. However, today I cannot publish any new posts using any desktop client. I keep getting errors such as the one below (Windows Live Writer):

    Error attempting to connect to blog at:

    http://www.castingthenet.net/xmlrpc.php

    Found: Moved Temporarily

    I've made sure that the xmlrpc option under Writing is check in my WordPress options settings. The xmlrpc.php file permission settings are currently "744".

    I've read on several threads that it could be a PHP 5 issue, but this was working for me all last week. Surely something didn't change on PHP 5 in a few days time.

  2. Joseph Scott
    Member
    Posted 5 years ago #

    When looking at your RSD file (used by blog clients to discover XML-RPC information about your blog) I see this at the bottom:

    <!-- Page not cached by WP Super Cache. No closing HTML tag. Check your theme. -->

    If you disable WP Super Cache does Windows Live Writer work again?

  3. Donncha O Caoimh
    Member
    Posted 5 years ago #

    This has just been fixed. Download and copy this file into your plugins/wp-super-cache/ folder. (Or download the development version of WP Super Cache)

    http://svn.wp-plugins.org/wp-super-cache/trunk/wp-cache-phase2.php

  4. Johanhorak
    Member
    Posted 5 years ago #

    Will this work on mu wordpress as well?

  5. heathj85
    Member
    Posted 5 years ago #

    i tried disabling wp-super cache and im still getting the same error messages. do i need to uninstall this plugin?

  6. Joseph Scott
    Member
    Posted 5 years ago #

    Did you try the updated version of the wp-cache-phase2.php that Donncha pointed to?

  7. heathj85
    Member
    Posted 5 years ago #

    Yeah, I automatically upgraded to the most recent version and it was still giving me the errors. So I went and disabled the WP Super Cache and two Facebook plugins I had activated, and it seems to work now. Even though there's a script error on the page now.

  8. Joseph Scott
    Member
    Posted 5 years ago #

    If you are referring to the "XML-RPC server accepts POST requests only." message when viewing the /xmlrpc.php URL in your web browser, that's normal.

    I'd suspect that it was one or some combination of the plugins that was causing the problem.

  9. kiatlc
    Member
    Posted 4 years ago #

    I didn't use supercache but still face this problem, why?

  10. TheVirtualPreacher
    Member
    Posted 4 years ago #

    Ok this is what worked for me...

    Set the following permissions for xmlrpc.php using a FTP client. If you are using CPanel set permissions using CPanel and that is much better.

    Owner (sometimes user) Read: allow, Write: allow, Execute allow

    Group: Read: allow, Write: no permission, Other (sometimes world) no permission

    Now start reconfiguring WLW. It will go up to some point. However it might ask you again to configure manually, like choosing your blog platform (choose WordPress 2.2+ or a higher number if available) and entering http://www.castingthenet.net/xmlrpc.php. Do it. and you are done.

  11. Aushiker
    Member
    Posted 4 years ago #

    Hi

    I also got this problem in the past few days and found the culprit was a Post to Facebook Plugin which happened to be the last plugin I installed.

    Regards
    Andrew

  12. thesmudger
    Member
    Posted 4 years ago #

    The Plug-in causing me grief is entitled Publish to Face Book by David Goldstein.

    If this is the same one as previously mentioned, it doesn't look very good if the plug-in has caused this issue over such a time. If it is similar names syndrome, then is the issue being fed back from face Book, as I think that it's API system may have changed in some way

    Update - although the error message first appeared with Live Writer, it also faults out with Blogjet on my desktop, and wpToGo on my G1 phone.

Topic Closed

This topic has been closed to new replies.

About this Topic