WordPress.org

Ready to get started?Download WordPress

Forums

xmlrpc not working on 2.3.2 (4 posts)

  1. mackgreen
    Member
    Posted 6 years ago #

    So I have written a java app to make posting image galleries to our wordpress blog much easier. I had evaluated it on wordpress 2.0.8 orignally and it worked (and still does). On my development site, I am using 2.3.2 and can not seem to connect to the xmlrpc.php.

    Also, I installed blogdesk and it can connect to the older (2.0.8) install, but it also fails when connecting to the 2.3.2 blog. It seems that something has changed with xmlrpc since blogdesk specifically seems to treat < 2.2 different than > 2.2 and I do not know what those changes are.

    Thanks.

  2. mackgreen
    Member
    Posted 6 years ago #

    BUMP

  3. eliotc
    Member
    Posted 6 years ago #

    are you running PHP4 or PHP5?

    I had problems with PHP5 and the 2.3.3 xmlrpc, but reverting to PHP4 worked.

  4. whooami
    Member
    Posted 6 years ago #

    you do know there is a security vulnerability in 2.3.2's xmlrpc implementation?

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags