WordPress.org

Ready to get started?Download WordPress

Forums

Jetpack by WordPress.com
[resolved] xml_rpc-32700 Doesn't connect to wordpress.com (12 posts)

  1. mokah
    Member
    Posted 1 year ago #

    Hello, I've recently installed Jetpack onto my WordPress installation and I keep getting the following error:

    Your Jetpack has a glitch. Something went wrong that’s never supposed to happen. Guess you’re just lucky: xml_rpc-32700
    
    Try connecting again. Error Details: The Jetpack server could not communicate with your site's XML-RPC URL. Please check to make sure http://mgakashim.com/xmlrpc.php is working properly. It should show 'XML‑RPC server accepts POST requests only.' on a line by itself when viewed in a browser and should not have any blank links or extra output anywhere.

    I've checked my xmlrpc.php file and it shows 'XML‑RPC server accepts POST requests only.'.

    I am running Worpress on a micro EC2 instance with NGINX, PHP5, CloudFlare and W3 Total Cache with APC. I am also using the TwentyTwelve theme. I have a feeling it could be to do with my security group settings but I don't know for sure.

    The website is mgakashim.com.

    Anyone have any clues?

    http://wordpress.org/extend/plugins/jetpack/

    EDIT:

    I just ran:

    curl -i -L --data 'test' 'https://jetpack.wordpress.com/jetpack.register/1'

    ...and got this back:

    HTTP/1.1 400 Bad Request
    Server: nginx
    Date: Thu, 08 Nov 2012 21:00:22 GMT
    Content-Type: application/json
    Transfer-Encoding: chunked
    Connection: keep-alive
    Vary: Cookie
    X-hacker: If you're reading this, you should visit automattic.com/jobs and apply to join the fun, mention this header.
    X-Pingback: http://jetpack.wordpress.com/xmlrpc.php
    Expires: Wed, 11 Jan 1984 05:00:00 GMT
    Cache-Control: no-cache, must-revalidate, max-age=60
    Pragma: no-cache

    EDIT 2:

    I've just read this thread and it basically says with my setup, this is currently unsolvable.

  2. designsimply
    Member
    Plugin Contributor

    Posted 1 year ago #

    Good find! (the thread you linked to)

    I entered http://mgakashim.com/ at http://jetpack.me/support/debug/ and it returned a different curl test than the one you mentioned:

    It looks like XML-RPC is not responding correctly. Please make sure XML-RPC is turned on for your site and is set up to respond to all content types. If you continue to get this error, please refer to our troubleshooting guide, or contact support.

    You can test this yourself by running the following command from the command line:

    curl -X POST -H 'Content-Type: text/xml' 'http://mgakashim.com/xmlrpc.php'

  3. mokah
    Member
    Posted 1 year ago #

    Hello, I ran that command on my server. It returned:

    XML-RPC server accepts POST requests only.

    I have enabled XML-RPC in 'Settings' > 'Writing'.

    How do I set my site up to respond to all content types?

    Thanks for the help.

  4. KarelDonk
    Member
    Posted 1 year ago #

    not sure if related by i get this error trying to connect jetpack to wordpress.com:

    Your website needs to be publicly accessible to use Jetpack: site_inaccessible

    Error Details: The Jetpack server was unable to communicate with your site [HTTP 408]. Ask your web host if they allow connections from WordPress.com. If you need further assistance, contact Jetpack Support: http://jetpack.me/support/

  5. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    @KarelDonk Could you contact your hosting provider, and give them the details I mentioned in your other post.

  6. designsimply
    Member
    Plugin Contributor

    Posted 1 year ago #

    @mokah, it appears you have something in your server configuration that is blocking XML-RPC for some reason, but I am not sure what. I also found that you have another support ticket open where our developers are working with you on this issue. You should finish the discussion by email and then post the results of your findings here once everything is sorted.

  7. KarelDonk
    Member
    Posted 1 year ago #

    Yes I already contacted Network Solutions about this and once I hear more and if this gets fixed I'll let you know. Thanks. :)

  8. mokah
    Member
    Posted 1 year ago #

    @designsimply, yes, I am currently in contact with the support team but they're quite slow. I assume they're very busy.

    I've had this problem for over a week now and I really just want to get it sorted. I've been looking for alternative plugins which can help me accomplish some of the things Jetpack would to no avail.

  9. designsimply
    Member
    Plugin Contributor

    Posted 1 year ago #

    @mokah, also, I think your case is unique. Plus, it's hard to determine what's going on from an outside perspective without access to your hosting setup and without more details. When it's a rare error like the one in your case, it can even be hard to know what to ask you to look for because I'm not an expert with your server environment and there are a variety of things that could be causing the issue. It may just take some extra time to track it down. Hang in there!

  10. mokah
    Member
    Posted 1 year ago #

    I agree, I am running quite an unusual setup by deviating from the common LAMP stack. I still think using NGINX and Varnish is worth the bump in performance on a tiny server.

    I guess I'm just going to have to wait and do without Jetpack for a while. Thanks.

  11. mokah
    Member
    Posted 1 year ago #

    The support team pulled through and provided me with a link to a blogpost which contained instructions on how to sort this exact problem out with my exact setup. It worked!

    For anyone else who is having the same issue:

    http://usefulmix.com/wordpress-nginx-varnish-jetpack-xml_rpc-32700-glitch-fix/

    Thanks to anyone else who helped.

  12. designsimply
    Member
    Plugin Contributor

    Posted 1 year ago #

    Nice!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic