WordPress.org

Ready to get started?Download WordPress

Forums

WordPress SEO by Yoast
[resolved] XML Sitemaps cannot be found?? (10 posts)

  1. PhillShaw
    Member
    Posted 1 year ago #

    WordPress version: 3.5.1
    WordPress SEO version: 1.4.1

    I did this:
    Activated XML sitemaps

    I expected the plugin to do this:
    Allow me/Google to access sitemaps.

    Instead it did this:

    You tried going to http://www.phillshaw.co.uk/home/home/sitemap_index.xml, and it doesn't exist. All is not lost! You can search for what you're looking for.

    If you go to the xml index page: http://www.phillshaw.co.uk/home/sitemap_index.xml I get the message above. I have switched to 2012 theme and turned off all other plugins to test for a conflict but I cannot seem to resolve this. It looks like something is adding an extra '/home/' directory. Any idea how to correct this?

    Thanks,
    Phil

    http://wordpress.org/extend/plugins/wordpress-seo/

  2. PhillShaw
    Member
    Posted 1 year ago #

    I also tried: http://www.phillshaw.co.uk/sitemap_index.xml to try and omit the extra /home/ folder but I still get a 404 error, any thoughts Mr Yoast?

  3. SRD75
    Member
    Posted 1 year ago #

    I received the same symptom.

    WordPress version: 3.5.1
    Wordpress SEO version: 1.3.4.4

    I deactivated all other plugins and reverted to the default theme without a fix.

    I noticed the plugin was not up to date - I updated it and the problem was solved for me.

  4. jgreen100
    Member
    Posted 1 year ago #

    I am not sure if I have the same issue. I recently re-built my site on WordPress. It did not change domain names but I did move the site from a template site company to a Bluehost WordPress implementation. Using Yoast's WordPress SEO plugin my XML sitemaps are also not showing up in Google Webmaster tools. I get the following error from Google:

    We encountered an error while trying to access your Sitemap. Please ensure your Sitemap follows our guidelines and can be accessed at the location you provided and then resubmit.

    General HTTP error: 404 not found
    HTTP Error: 404

    Going to http://creativecakesallison.com/page-sitemap.xml it looks like the Sitemaps are set up correctly. Any idea why Google can't see the Sitemaps?

  5. SRD75
    Member
    Posted 1 year ago #

    Maybe your robots.txt file is disallowing search engines?

  6. ggg377
    Member
    Posted 1 year ago #

    Same is happening to me. I think it started with one of the recent plugin updates (sitemaps were generating fine before). Not using a cache currently.

  7. ggg377
    Member
    Posted 1 year ago #

    Found a solution for myself. Disabled the sitemap functionality and re-enabled it. Works now.

  8. PhillShaw
    Member
    Posted 1 year ago #

    I disabled the entire plugin, re-enabled it, disabled Sitemaps, re-enabled and now they're working again!

    Thanks guys!

    http://www.phillshaw.co.uk/home/sitemap_index.xml

  9. jgreen100
    Member
    Posted 1 year ago #

    I don't think my robots.txt file is set up correctly. However I can't see how to edit it. When I go to the page: http://creativecakesallison.com/robots.txt

    All it says is this:

    User-agent: *
    Disallow: /wp-admin/
    Disallow: /wp-includes/.

    My site is set to be search engine visible in WordPress's configuration. Do I need to create my own robots.txt file? Is something not set up correctly in Yoast or WordPress? Thanks in advance for your help!

  10. PhillShaw
    Member
    Posted 1 year ago #

    Im no robots expert but to me:
    Disallow: /wp-admin/
    Disallow: /wp-includes/.

    Tells google to ignore those directories, for a good reason. WP creates virtual robot.txt files that, to my knowledge, we cant edit manually.

    To confirm are you getting the same Yoast Sitemap issues?

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.