WordPress.org

Ready to get started?Download WordPress

Forums

WordPress SEO by Yoast
XML Sitemap is Missing! (9 posts)

  1. AV8NLVR
    Member
    Posted 5 months ago #

    In the dashboard I went to the "xml sitemaps" tab and where it says "you can find your sitemap here" I clicked on the link - and my browser says page not found!

    How do I generate a new one?

    https://wordpress.org/plugins/wordpress-seo/

  2. Rudolph Smits
    Member
    Posted 5 months ago #

    I encountered the same problem for http://www.magoster.com. I thought that this sitemapfile is not a physical file but a virtual one. So searching with tools as FileZilla doesn't help.

    I hope somebody has solved this and is willing to share his solution.

    Regards
    Rudolph Smits

  3. AV8NLVR
    Member
    Posted 5 months ago #

    Well it is a physical file that resides in the home directory of the site....I checked with Filezilla but mine's not there.

  4. Reiner030
    Member
    Posted 5 months ago #

    @AV8NLVR
    I "missed" informations in this problem to... but after only 1+ hour problem analytics I found in the FAQ:

    https://yoast.com/wordpress/plugins/seo/faq/#my-sitemap-index-is-giving-a-404-error-what-should-i-do

    => WHY ISN'T THIS INFORMATION LINKED in the Admin Backend of this plugin?

    I first thought that there is a problem in combination with WPML like in this thread:
    http://wpml.org/forums/topic/wpml-yoast-sitemap-problem/#post-375509

    => @support: please check this because you have a buggy URL there produced:

    The sitemap header moved from:
    <?xml version="1.0" encoding="UTF-8"?><?xml-stylesheet type="text/xsl" href="//my.test.domain/main-sitemap.xsl"?>
    to:
    <?xml version="1.0" encoding="UTF-8"?><?xml-stylesheet type="text/xsl" href="WPSEO_FRONT_URLcss/xml-sitemap.xsl"?>
  5. Reiner030
    Member
    Posted 5 months ago #

    ... accidently double posted ...

  6. Rudolph Smits
    Member
    Posted 5 months ago #

    @Reiner30

    Sorry, duurde even voor ik kon reageren.

    Dank voor je oplossing, ik heb .htaccess conform aangepast en inderdaad, er is een sitemap. Zojuist die ook meteen in Google Webmaster aangeboden, dus nu maar afwachten. Maar ik heb goede hoop, de sitemaptest gaf geen fouten.

    Nogmaals dank!!

  7. jumbo
    Member
    Posted 5 months ago #

    Experienced this once before. Resolved it by

    1) going to the XML settings page
    2) unchecking "Check this box to enable XML sitemap functionality."
    3) save changes
    4) checking "Check this box to enable XML sitemap functionality."
    5) save changes

  8. Rudolph Smits
    Member
    Posted 5 months ago #

    @Reiner30, @jumbo

    I see only now that I did put my reaction in dutch. Sorry!

    I followed the suggestions of Reiner and they seem to work. I can see now a sitemap and redelivered it to Google via Google Webmaster. Now I have to wait a few days.
    If no result, Jumbo, I will act as you have suggested.

    Thanks for your help.

    Kind regards,
    Rudolph Smits

  9. tidanielsdw
    Member
    Posted 5 months ago #

    Thanks Jumbo, I've been experiencing this problem and your solution worked!

Reply

You must log in to post.

About this Plugin

About this Topic

Tags