WordPress.org

Ready to get started?Download WordPress

Forums

WordPress SEO by Yoast
[closed] XML Sitemap gives an empty page (19 posts)

  1. Webredactie4u
    Member
    Posted 1 year ago #

    Version SEO Yoast: 1.3.4.3

    When I click on XML Sitemap in the SEO Plugin, I see an empty page. Before today, it worked ok. I didn't change any information in WordPress, so I don't understand why my sitemap is empty.

    http://wordpress.org/extend/plugins/wordpress-seo/

  2. amar.wordpress
    Member
    Posted 1 year ago #

    I've the same problem.
    The Xml sitemap not show anything.
    the website is : http://notes.sosoon.it ( domain 3 Level )
    the sitemap is : http://notes.sosoon.it/sitemap_index.xml
    Wordpress version : 3.5
    Wordpress SEO Version : 1.3.4.4 ( same as developer version )

    I've tried with 2 different themes : standard Twenty Twelve
    and a Child Theme ( modified iFeature by CyberChimps

    I've tried with W3CT and without and the result is the same

    What i need to do.

    Thanks for this great plugin !

  3. tlaban
    Member
    Posted 1 year ago #

    I just installed SEO and the same thing is happening.
    http://www.cartoonimpact.com

  4. damdo74
    Member
    Posted 1 year ago #

    Hello,

    the same for me but only on one of the three sitemaps.

    http://www.cantaussel.fr/post-sitemap.xml > OK
    http://www.cantaussel.fr/page-sitemap.xml > OK
    http://www.cantaussel.fr/features-sitemap.xml > 404 error

    Even if I have 5 features online.

    Cannot find the solution.

    Please help.

  5. scuderiadank
    Member
    Posted 1 year ago #

    Same thing here.

    WordPress: 3.5
    Wordpress SEO: 1.3.4.4

    And my sitemap (http://www.motorsportmusings.co.uk/post-sitemap.xml) is completely blank.

    I've deactivated all my plugins and reverted back to the Twenty Twelve theme and it has made no difference.

    I have even contacted my webhosts to see if they could increase my memory allocation, but according to them I'm on a shared package so it wouldn't be the case.

    Have to say that trawling through similar threads online and not seeing a solution is very disappointing - not to mention a waste of time - so I, and countless others, would appreciate it if a solution could be forthcoming sooner rather than later...

  6. WordPress Fan
    Member
    Posted 1 year ago #

    Wow, still no answers!?

  7. scuderiadank
    Member
    Posted 1 year ago #

    I've given up on this 'feature' and used the Google XML Sitemaps plugin instead.

    http://wordpress.org/extend/plugins/google-sitemap-generator/

  8. tizz
    Member
    Posted 1 year ago #

    Try this

  9. scuderiadank
    Member
    Posted 1 year ago #

    Noting within that link works.

    The only thing that does is if I set the number or max entries per sitempap page to something like 20.

  10. somarco
    Member
    Posted 1 year ago #

    Similar issue. Sitemap won't load in Chrome, but in FF I get this.

    Error loading stylesheet: A network error occurred loading an XSLT stylesheet:http://www.mysite.com/wp-content/plugins/wordpress-seo/css/xml-sitemap-xsl.php

    Like others, I have reverted to Google XML Sitemap plugin so search engines don't think I have closed shop.

  11. scuderiadank
    Member
    Posted 1 year ago #

    Problem still persists. Anyone managed to resolve this yet?

  12. somarco
    Member
    Posted 1 year ago #

    Apparently Yoast doesn't care if humans can see the sitemap or not. Checking webmaster tools, Google can "see" and review the sitemaps without issue.

    I started using Google XML sitemaps and had to disable it because of a conflict with SEO.

  13. iboudreau
    Member
    Posted 1 year ago #

    It worked!

    1. disable XML map, Save
    2. in Permalinks, set Custom %postname%, Save
    3. enable XML map, Save.

    The only thing I wish to have is a single general sitemap, in addition to 3 separate ones.

  14. TIEPIEZ
    Member
    Posted 10 months ago #

    Wow! iboudreau's fix worked for me. Thanks!

  15. johnstell
    Member
    Posted 10 months ago #

    what happens if you don't want permalinks like: %postname%
    1. disable XML map, Save
    2. in Permalinks, set Custom %postname%, Save
    3. enable XML map, Save.

  16. johnstell
    Member
    Posted 10 months ago #

    also what happens if you have products for this fix:

    1. disable XML map, Save
    2. in Permalinks, set Custom %postname%, Save
    3. enable XML map, Save.

    The only thing I wish to have is a single general sitemap, in addition to 3 separate ones.

    I'm reluctant to do it so i'm using google sitemaps at present.

  17. ivanrojas
    Member
    Posted 8 months ago #

  18. B_Dark
    Member
    Posted 8 months ago #

    @ivanrojas

    i have add
    robots\.txt
    sitemap(_index)?\.xml(\.gz)?
    [a-z0-9_\-]+-sitemap([0-9]+)?\.xml(\.gz)?
    sitemap(_index|[0-9]+)?\.xml

    but still have problems :/

  19. alpineace@alpineace.com
    Member
    Posted 7 months ago #

    @B_Dark

    What works for me is to have the following.

    Prevent caching exception list:
    sitemap(_index|[0-9]+)?\.xml

    404 error exception list:
    robots\.txt
    sitemap(_index)?\.xml(\.gz)?
    [a-z0-9_\-]+-sitemap([0-9]+)?\.xml(\.gz)?

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.