WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] XML Sitemap Generator: "There was a problem writing your sitemap file." (12 posts)

  1. X-Evolutionist
    Member
    Posted 4 years ago #

    Error message when I try to activate XML Sitemap Generator for WordPress 3.2.2:

    There was a problem writing your sitemap file. Make sure the file exists and is writable.
    There was a problem writing your zipped sitemap file. Make sure the file exists and is writable.

    At this point, for some reason, I am unable to loadup anything from within WordPress admin. I have to download it and load it up with FTP.

    What file in this plugin can I edit and load back up to let me use this? I really want a site map......

    If this is not possible, other sitemap work-arounds to get a sitemap for google webmaster would be great.

    Thank you,

    X

  2. Samuel B
    moderator
    Posted 4 years ago #

    bump removed per forum rules
    really...after only an hour?

  3. X-Evolutionist
    Member
    Posted 4 years ago #

    Sorry. I'm brand new here. I do not know the established practices.

    Thank you,

    X

  4. Samuel B
    moderator
    Posted 4 years ago #

    try this -I tested in on my local install
    open notepad
    save empty file as sitemap.xml
    upload it to your wordpress root and chmod 666
    run the generator again
    should work

  5. X-Evolutionist
    Member
    Posted 4 years ago #

    I did as you said, then deactivated the plug in, and activated it again. This is the error message I get:

    There was a problem writing your sitemap file. Make sure the file exists and is writable. Learn more
    There was a problem writing your zipped sitemap file. Make sure the file exists and is writable. Learn more
    The building process took about 0.01 seconds to complete and used 13.07 MB of memory.
    If you changed something on your server or blog, you should rebuild the sitemap manually.
    If you encounter any problems with the build process you can use the debug function to get more information.

    I just installed my WordPress blog two days ago. I have learned a lot, but there is still a lot to learn, obviously. I do not know what to try now.

    Thank you,

    X

  6. X-Evolutionist
    Member
    Posted 4 years ago #

    I'm hoping I can get a sitemap somehow. Is there a work around?

    Thank you,

    X

  7. Samuel B
    moderator
    Posted 4 years ago #

    try chmod 777 on the sitemap.xml

  8. X-Evolutionist
    Member
    Posted 4 years ago #

    samboll,

    Woohoo! I have a sitemap! http://www.x-evolutionist.com/blog/sitemap.xml

    Thank you very much! I still get the error about the zipped file. But, do I need one?

    Unrelated question please: I have my blog in my-site.com/blog. It is looking so nice that I want to run my site with WordPress, too. How much of a mess is it to move WordPress to the root directory? I suppose that I could not control my-site.com from my-site.com/blog where WordPress is.

    Thank you!

    X

  9. Samuel B
    moderator
    Posted 4 years ago #

    I still get the error about the zipped file. But, do I need one?

    no, definitely not

    not hard to move
    easiest
    http://codex.wordpress.org/Giving_WordPress_Its_Own_Directory

    or

    http://codex.wordpress.org/Moving_WordPress#Moving_WordPress_Within_Your_Site

  10. X-Evolutionist
    Member
    Posted 4 years ago #

    Thank you very much! You have been very helpful! I just posted a new question. There is so much to learn..:

    http://wordpress.org/support/topic/369814?replies=1

    I just changed my permalink stucture to this:

    /%category%/%postname%/

    It looked fine when I looked at my posts and pages in admin. But, it is not working. WordPress can't find my pages. Everything returns a 404 error and I don't have a custom page yet. UGLY.

    http://www.x-evolutionist.com/blog/

    Help.

    Thank you.

    X

  11. Samuel B
    moderator
    Posted 4 years ago #

    hi
    delete the .htacces from /blog completely
    now go and set your custom permalinks again
    save and make sure you get a success message
    if so, should work now

  12. X-Evolutionist
    Member
    Posted 4 years ago #

    samboll,

    I did not have an .htaccess file yet. I created one per answer on my question's location:

    http://wordpress.org/support/topic/369814?replies=6&r

    I followed the directions, but it did not work.

    Please see that post.

    Thank you,

    X

Topic Closed

This topic has been closed to new replies.

About this Topic