WordPress.org

Ready to get started?Download WordPress

Forums

WordPress SEO by Yoast
XML Sitemap, debug steps (4 posts)

  1. TimoVeld
    Member
    Posted 10 months ago #

    My XML sitemap is not working, this seems to be a common problem, and tends to be our own damn fault in 9 out of 10 cases.

    Now I'd like to fix my site to make the XML Sitemap work, but I have no idea where to start.

    I've got the following error message:

    This page contains the following errors:
    error on line 4 at column 6: XML declaration allowed only at the start of the document
    Below is a rendering of the page up to the first error.

    Which can mean a lot of things. But I have no Idea where to start debugging.

    Is there some sort of basic debugging guide for failing XML Sitemaps?

    Some basic steps I can follow to try and make my XML work?

    http://wordpress.org/plugins/wordpress-seo/

  2. pdillon809
    Member
    Posted 10 months ago #

    I have the same issue and posted in a separate thread. Not had any suggestions yet.

  3. pdillon809
    Member
    Posted 10 months ago #

    Here's the solution that worked for me.

    Hope this helps.

  4. TimoVeld
    Member
    Posted 10 months ago #

    Thanks for your reply.
    Unfortunately I already narrowed it down to my child theme.

    What I was looking for was debug steps like you suggested; "checking for whitespace between the php tags".

    So I'll try that now, thanks for your input.

Reply

You must log in to post.

About this Plugin

About this Topic