WordPress.org

Ready to get started?Download WordPress

Forums

All in One SEO Pack
XML Sitemap (21 posts)

  1. Grace Massa Langlois
    Member
    Posted 12 months ago #

    Good Morning,

    I currently have both the All In One Seo Plugin and the XML Sitemap Plugin installed on my site, would it be best to remove the XML Sitemap Plugin and activate the XML Site Map option in the All In One SEO plugin?

    Thanks

    Grace

    http://wordpress.org/plugins/all-in-one-seo-pack/

  2. wpsmort
    Member
    Posted 12 months ago #

    Hi Grace,

    The XML Sitemap feature in All in One SEO Pack does everything that the XML Sitemap plugin does so yes you can switch to using the feature in All in One SEO Pack if you like.

  3. Grace Massa Langlois
    Member
    Posted 12 months ago #

    Good Afternoon

    Should I uninstall the XML Sitemap Plugin first?

    Grace

  4. wpsmort
    Member
    Posted 12 months ago #

    You should definitely deactivate it first. It's up to you if you want to delete it.

  5. Udi
    Member
    Posted 12 months ago #

    I've deactivated the Google sitemap plugin, renamed the sitemap files and activated the XML sitemap of All in Once SEO.
    The All in one SEO XML sitemaps didn't create the sitemap files.
    Why is that?
    What I did wrong?

    Udi

  6. Peter Baylies
    Member
    Plugin Author

    Posted 11 months ago #

    Udi,

    Check your settings; if you have dynamically generate sitemaps checked, then go to Settings -> Permalinks to check your permalink structure and then see if you can view your sitemap. If you don't have it checked, then click the Update Sitemap button to generate a static sitemap.

  7. Udi
    Member
    Posted 11 months ago #

    Peter,
    I have Dynamically generate checked.
    And when I click the view sitemap it shows me this:
    https://www.dropbox.com/s/im488m9ff2iior3/Sitemap.jpg

    But when I look for these files in my root of my blog using FTP or SSH I can't find the files over there.
    How can it be?

  8. Peter Baylies
    Member
    Plugin Author

    Posted 11 months ago #

    Udi,

    That is what the 'dynamically generated' checkbox means, it is produced on the fly from WordPress, not served from a file. WordPress can handle the robots.txt file in the same manner as well.

  9. Udi
    Member
    Posted 11 months ago #

    Peter,

    So I can we relaxed that this is working properly and give up on the Google XML sitemap plugin?

  10. Peter Baylies
    Member
    Plugin Author

    Posted 11 months ago #

    Udi,

    Yes; my advice would be to turn off sitemap indexes as well, it doesn't look like you have enough posts on your blog to require using them.

  11. wpsmort
    Member
    Posted 11 months ago #

    Hi Udi,

    You will want to uncheck the box for Enable Sitemap Indexes under All in One SEO, XML Sitemap. You only need this checked if your sitemap contains more than 50,000 URLs or is over 10MB in size.

    When you have Dynamicall Generate Sitemap checked (the default setting) there are no static files created on the server. The Sitemap is dynamically generated and displayed in a virtual file whenever a robot visits the URL for the sitemap. This avoids the numerous problems with static sitemap files.

  12. Udi
    Member
    Posted 11 months ago #

    Hi Peter and wpsmort,

    Thank for your help!
    Appreciated.

  13. pieterdeschutter
    Member
    Posted 3 weeks ago #

    Hi,

    I'm running this plugin on several sites and works perfect.
    But now on on a certain site after 'updating site map' there is no the site map….

    http://surfersmap.es/fuerteventura/sitemap.xml >>>>'Nothing found'

    Weird, because there is no error message after updating

    Regards,

    Pieter

  14. wpsmort
    Member
    Posted 3 weeks ago #

    Hi Pieter,

    Is /fuerteventura/ a sub-directory site? Can you try flushing your permalinks and unchecking Dynamically Generate Sitemap (http://semperplugins.com/documentation/xml-sitemaps-module/#dynamicallygeneratesitemap).

  15. pieterdeschutter
    Member
    Posted 2 weeks ago #

    Hi wpsmort,

    > /fuerteventura/ is not a sub-dir site, I added this in the general settings for SEO purposes

    > when I uncheck 'Dynamically Generate Sitemap ' I get alle this kind of warnings:
    'Failed to write file /sitemap.xml!'

    > How do i 'flush' my permalinks?

    Greetings,

    Pieter

  16. wpsmort
    Member
    Posted 2 weeks ago #

    Hi Pieter,

    Ok so the first thing to do is to make sure your permalink structure is set to one of the standard permalink structures such as Post name (https://codex.wordpress.org/Settings_Permalinks_Screen). I recommend setting it to Post name if it is not already set to that. This will also flush your permalinks.

    Where did you add the /fuerteventura/? Did you add it to the Site Address or the WordPress Address (http://codex.wordpress.org/Settings_General_Screen)? Do the Site Address and the WordPress Address match? If no, what is the URL for each one?

    Right now I think it's the fact that you've added /fuerteventura/ to one of those fields that's messing with the permalink structure. I can tell this because I can't even get to the URL for the dynamically generated robots.txt that WordPress creates so this proves it's a WordPress configuration issue and not a problem with All in One SEO Pack.

  17. pieterdeschutter
    Member
    Posted 2 weeks ago #

    Hi wpsmort,

    I'm using POST NAME permalinks and this are my settings:

    WP Address: http://surfersmap.es/wordpress
    Site Address: http://surfersmap.es/fuerteventura

    Greetings,

    Pieter

  18. wpsmort
    Member
    Posted 2 weeks ago #

    Hi Pieter,

    Yes, I believe it's those settings for WordPress Address and Site Address that's breaking WordPress' ability to recognize path names correctly. WordPress returns a 404 error for http://surfersmap.es/wordpress/ and trying to browse to anything at http://surfersmap.es/fuerteventura/ results in either a redirect to http://surfersmap.es/wordpress/ or a 404 error.

    I think you should read the guidelines for using a custom site URL.

    http://codex.wordpress.org/Giving_WordPress_Its_Own_Directory http://codex.wordpress.org/Changing_The_Site_URL

  19. pieterdeschutter
    Member
    Posted 1 week ago #

    Hi Wpsmort,

    I have been trying all possible solutions without effort.

    Now I realized I have a similar WP site with the same general settings (Site Address and WordPress Address > subdirectory). And there I can create without any problem the site map… weird.

    This can't be theme related I suppose?

    Regards,

    Pieter

  20. wpsmort
    Member
    Posted 1 week ago #

    Hi Pieter,

    As I said before, this is definitely not a problem with All in One SEO Pack. This is most likely a problem with the way you set up WordPress or your server. I can't help you there, all I can do is confirm it's not a bug with our plugin and its not due to a misconfiguration with our plugin. Sorry, I wish I could help you further, maybe someone in the general WordPress forums will have an idea what's causing this.

  21. Grace Massa Langlois
    Member
    Posted 6 days ago #

    Good Afternoon Gentlemen,

    I hope you don't mind my jumping in. I'm not sure if this is causing any issues but I scanned the site through Sucuri's Free SiteCheck tool and the results show the following - Warning: Malicious Code detected on this Website.

    It also shows that Apache is outdated.

    See the results here - http://sitecheck.sucuri.net/results/surfersmap.es/fuerteventura.

    See Redleg's File Viewer results too - http://goo.gl/E25E7J.

    I recommend updating Apache asap and then checking to see if site is in fact infected (which it appears it might be).

    After cleanup I would take another look for the sitemap.

    Grace

Reply

You must log in to post.

About this Plugin

About this Topic