WordPress.org

Ready to get started?Download WordPress

Forums

XML-RPC services disabled (15 posts)

  1. mamabeann
    Member
    Posted 4 months ago #

    I'm having an issue with my WP app ever since it did an auto update yesterday saying my blog's "XML-RPC services" are disabled? How can I fix this so I can access my blog from the app? TIA!

  2. esmi
    Forum Moderator
    Posted 4 months ago #

    From what app?

  3. mamabeann
    Member
    Posted 4 months ago #

    From the wordpress app

  4. esmi
    Forum Moderator
    Posted 4 months ago #

    Which app.? There is more than one.

  5. mamabeann
    Member
    Posted 4 months ago #

    The one that pops us first in the app store, wordpress "automattic" it says

  6. esmi
    Forum Moderator
    Posted 4 months ago #

    Go to https://wordpress.org/mobile/ and identify which app you are using.

  7. mamabeann
    Member
    Posted 4 months ago #

    it's for iOS, on my iPhone

  8. esmi
    Forum Moderator
    Posted 4 months ago #

    Have you tried asking on http://iphone.forums.wordpress.org/

  9. mamabeann
    Member
    Posted 4 months ago #

    no i haven't, i will ask there now, thank you

  10. tech-otaku
    Member
    Posted 4 months ago #

    Am having a similar problem with Mars Edit since updating to WP 3.8.2

    According to to the release notes the file wp-includes/class-wp-xmlrpc-server.php has been updated.

    Looks like this could be an issue with the WP core.

  11. Kelson
    Member
    Posted 4 months ago #

    I'm unable to connect to any of my self-hosted blogs with the Android WordPress client today, after upgrading to WP 3.8.2 yesterday (though to be fair, a lot has been going on the last two days). Trying to refresh posts or comments gives me a "...couldn't be refreshed at this time" error.

  12. tech-otaku
    Member
    Posted 4 months ago #

    The WP 3.8.2 update may have been a red herring. Disabling the Wordfence Security plugin that was updated to 5.0.2 around the same time fixed my issuse with Mars Edit.

  13. Kelson
    Member
    Posted 4 months ago #

    Aha! Good catch. The new Wordfence Options page has an option way down at the bottom under "Other Options" -- "Disable XML-RPC for DDoS protection." Unchecking that lets the mobile app back in on my sites.

  14. jaydeland
    Member
    Posted 4 months ago #

    That worked for my site as well when I ran into a publishing problem from livewriter.

  15. TJ Kelly
    Member
    Posted 4 months ago #

    Hi all, Wordfence has updated to 5.0.3. Upgrade to the latest version and this problem goes away.

    I wrote a longer explanation here and I learned about it from another thread here.

Reply

You must log in to post.

About this Topic