WordPress.org

Ready to get started?Download WordPress

Forums

DJD Site Post
[resolved] XML Parse Error :( (8 posts)

  1. Martin
    Member
    Posted 1 year ago #

    Well, all I get in testing this plugin is an error"

    XML Parse Error: The function site_post_form did not return wellformed XML:

    You can check it at http://www.cooney.com.au/guest-post-for-us if you like. Running PHP5.3 and a responsive theme.

    Any ideas?

    http://wordpress.org/extend/plugins/djd-site-post/

  2. djarzyna
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Martin,

    I don't see anything related to the plugin on your site. Dir you disable it?

  3. ljcremer
    Member
    Posted 1 year ago #

    Hi

    I get the same error on my site: Cape Town F&T

    Warning: DOMDocument::loadXML() [domdocument.loadxml]: EntityRef: expecting ';' in Entity, line: 15 in /home/ljcremer/public_html/capetown.fashionandtrunk.com/wp-content/plugins/djd-site-post/djd-site-post.php on line 495

    I have another site where it works fine.

  4. djarzyna
    Member
    Plugin Author

    Posted 1 year ago #

    Martin, if seen this shortcode on your page: [fep_submission_form] Did you change anything in code because the correct shortcode would be [djd-site-post]?

  5. djarzyna
    Member
    Plugin Author

    Posted 1 year ago #

    ljcremer, I just visited your site and saw a stripped down site post form there. I didn't want to use that form and try to enter a new post on your site just for testing purposes. So since a form is there does this mean it works for you now? If so, can you tell me what the problem actually was and how you fixed it? It's just because this XML stuff seems to come up every now and then and I just cannot find the cause of this kind of problem. Actually I am thinking about rewriting this plugin without using xml, but this will be time consuming task I really would like to avoid.

  6. Martin
    Member
    Posted 1 year ago #

    Thanks, I only allow Contributors to post and they need to use the WP New Post - cuts down my huge plugin list :)

  7. ABCDiamond
    Member
    Posted 1 year ago #

    I have just got this "XML Parse Error: The function site_post_form did not return wellformed XML:" error today.

    I installed the plugin on two of my sites today. It works well on one site, but the second site shows that error.

    This one works: http://www.abcdove.com/add-your-thoughts-or-opinions/

    This one does not work: http://www.abcdiamond.com/add-your-news

    and it shows this error page:
    http://www.abcdiamond.com/images/DJD-Site-Post-error.jpg

  8. Emerson4br
    Member
    Posted 1 year ago #

    djarzyna, nice plugin, keep great work!

    I solve it, was a permalink problem, i changed wp_login_url( get_permalink() ); to wp_login_url(); in display.php on line 43 i guess and it work like a charm ;)

    in my case, theme-my-login plugin make my life hard, once it has no permalink yet in my project

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.